BMW M5 Forum and M6 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
Hey all my M5 brothers!

The other day about 2 weeks ago I filled up my tank right to the top, Then just after leaving the gas station a couple of guys in a gay honda pulled up next to me revved up there engine and rolled down there window and said lets race! So I push my M button and here we are ready to race soon as the light turns green, It turns green we are off and then I hit 1st then 2nd then 3rd and around 3rd or 4th or 3rd going into 4th a message all of a sudden pops up when the engine was at around 6500rpm maybe 7000rpm shifting gears to the next gear, So this message pops up saying engine malfunction reduced power.. So I eaze off the gas let the honda rip away... But now I dont know what I have just done to my baby!
So I pull over turn off the beast then count to like 30 seconds then restart the beast and message is still there.. So this message now dosnt go away at all every thing on my beast seems to work absolutely fine there dosnt seem to be one single thing wrong with it even when the message popped up there was no sound nothing at all.. Just a stupid error message.. So I notice that it has my beast only running at 7000rpm max redline now instead of the normal 8500rpm that it should be able to go too..

So any ways this message dosnt go away after a few starts and stops I tryed removing the battery I tryed every thing I could think of check the air filter get a new one.. So any ways I couldnt figger this issue out so I made an appointment to go to my BMW dealership! The soonest they could get me in was like 10 days away so I booked the appointment and waited the 10 days and just kept driving my beast around normally still raced around a bit just not hard! I was able to do this still because the car seems like nothing has even been done to it just the dumb message!

Well any ways about 3 days before the appointment with my dealership and about 3 quarters of a gas tank and about i dunno lets say 100 km's around town in this limp mode with this light on I go to bed one night after a bunch of driving ( I had to drive my friends around all the way downtown Vancouver and back one night) So allot of driving in one night then parked my beast woke up the next morning and flashed my beast up... BANG theres NO stupid light any more NO error message NOTHING SAYING engine malfunction / reduced power!

So I cancel the BMW dealership appointment then about 4 nights after never seeing this light again I could start stop restart the beast as many times as I wanted to and it was always gone out now never seen it again and now it gave me full power again I got 8500rpm now not the 7000rpm it gave me with the light on!

So about 4 nights after this light going out and never seeing it again and being so happy I just saved a trip to the dealership and allot money! I was racing around again because I just put a new pair of AFE air filters in and I wanted to test them out and see what they can do for my beast any ways after installing these bad boys and filling the gas tank again right to the top again must I say! I raced around and got the beast up to about 7000rpm and BANG the light comes back on! And now it wont turn off again I havnt waited the 7 days like I did the last time to see if it go's out on its own again it just happened about 15 mins ago of me writting this post... So now I have this light back on and I cant get it to go out and Im back at 7000rpm only and every time I start my baby it says engine malfuction / reduced power and its super annoying mostly if I cant even drive my baby the way I want too..

I want to know how to get rid of this light and why do you think it keeps coming on?? and do you think it will go away again after a few days and the gas tank gets lower again like last time because I sure hope soo I cant have a car with this stupid light on any more if it continues I will have to sell the car!
 

·
Registered
Joined
·
827 Posts
Hmmm... even if it is only an idrive message and not a detailed fault code, engine malfunction sounds like one shouldn't keep driving the car like everyday or... well race it.

Something is wrong, and getting the message go away will not fix the issue itself.

- Antti -
 

·
Registered
Joined
·
103 Posts
Discussion Starter #3
But when it happens it there is not one single thing wrong with the car no sounds no nothing!
It only happens at high revs at like 7000rpm
 

·
Registered
Joined
·
827 Posts
You think it's only the message, and nothing is wrong with the car...? All faults are not visible or hearable. There is still something that creates the message and the safe mode.

I suggest you take the car to a dealer or individual and get the error codes read. Even if the fault message is not on at that moment.

- Antti -
 

·
Registered
Joined
·
133 Posts
100% agree with Antti and Hasan.

Something *is* wrong with your car. Have a trusted shop (dealer or indy) pull the codes, this could save you a lot of trouble and money in the future.
 

·
Registered
Joined
·
3,940 Posts
Possibly fuel related as mentioned since it comes up under high demand situations. Still could be anything though.


I don't know why people think when a message disappears for awhile without doing anything whatever is wrong is now fixed. Of course it's going to come back it is just a matter of time! Things just don't fix themselves on these cars.
 

·
Registered
Joined
·
991 Posts
There is absolutely no sense in trying to guess the issue. With these cars, that is nearly impossible and a very expensive game of chance. You must be decent with a computer and a wrench to own these cars, or be wealthy enough to have a dealer service them.

Pull codes, analyze, and replace affected part. Simple and easy.

For the lions share of your issues, engine related anyways, you can purchase a PEAKE scanner for a few bucks. You plug it in, read the codes, and replace what's wrong without guessing. Last week for me, I had an Increased Emissions. I plugged in the PEAKE, threw a Thermostat Coolant Temperature Monitor code, and swapped out the T-Stat a day later. Problem is gone, zero down time while guessing. Simple easy.
 

·
Registered
Joined
·
3 Posts
Ok.
I just have a similar issue

I got a super clean 2008 M5. With 95k
It was inspected and rated 4.2 over 5.0. This is a dealers auction and is is garaunteed
Got the car delivered to my shop with no fuel. I mean nothing at all So I put half tank and started up the car. All is well. I started a quick test drive It went fine for a couple of miles. Then I started to rev it and all of a sudden an awful smell came into the cabin
Shortly I got the same msg. Reduce speed. Engine malfunction

So I did. And went back to my shop. The car was not driving well. Cutting out and barley making it
After stopping it for few hours. Everyone that approach the car say it smells like there is a dead rat in the engine

I am lucky that I got the car with a 7 days garaunteed. So I sent it back to auction and it is in arbitration now. There is a chance a chance that they offer me to take it at a reduce price
The car simply looks great and sharp. Nice white color and black interior with all options that one can think of

I want your advise if I should return it back if I have the chance. And in case I am offered to keep it. What is the maximum amount I need to spend to make it right.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #14
When I got my scanner It turned up that my throttle actuator was on it's way out I got the code 2796 I think the exact words where throttle actuator lower test stop some thing like that.. I heard it had some thing wrong with the throttle adaption or some thing because on anthor guys scanner it said some thing about the throttle control adaption on his and same code basically meaning when I push the pedal all the way down it is not or is opening too much on one side of the engine mine was bank 1 left side... So it went sooner or later as you will find by my other post on here and then i found a used one on ebay for 250$ they are $1200-$1600 new and upto a grand to put them in I found an Indy shop for $480 to
Do it but ended up costing me $850 after all said and done with! So 850 plus 250..

For my advise to you is first off take the car back to them and go buy a scanner or take it in to a Indy shop the dealer will charge you the same amount as what the scanner is worth so stay away from there.. Once you have the codes tell me them and judge for your self how bad the repairs are.. By the sounds of the smell thing it sounds bad to me I have only small issues with mine and they turn out to cost me a ton.. Every time too yours sounds like a very high cost repair so bad that I wouldn't even want to own the guy unless if I knew what the codes where and I knew there where not bad to fix.. To be honest you can't own these cars with out a scanner so don't feel bad buying one some kinda scan happens every few months some thing always is going wrong with them... Where are you located and tell me how much you got it for and pictures if you can it will try to help out as much as I can
 
1 - 14 of 14 Posts
Top