BMW M5 Forum and M6 Forums banner

1 - 20 of 30 Posts

·
Registered
Joined
·
4,143 Posts
Discussion Starter #1
Popped up while i was driving. Got the yellow check engine light on. idrive Error said Increased Emissions! Took it to a local bmw mechanic shop and owner said it might be an o2 sensor. He reseted the check engine light and after 30mins of driving it came back. Today i booked it in to my local BMW Dealrship. My service advisor said sometin about the gas cap. I checked it and it looks ok. I did search this forum but i'd want some more input on this. Thanks


Mike
 

·
Registered
Joined
·
246 Posts
Hey Indy,

Do you have an update? I just got the same error message about 'service engine soon' and HUD says increased emissions!!

thanks
 

·
Registered
Joined
·
4,143 Posts
Discussion Starter #4
Hey Indy,

Do you have an update? I just got the same error message about 'service engine soon' and HUD says increased emissions!!

thanks
Going for service on the 20th . But my service advisor said it's probably the 02 sensor.
 

·
Registered
Joined
·
148 Posts
It's probably is the O2 sensor. I had to replace two of them between 30K and 40K miles. At 74K miles all my cats were said to be bad, and unfortunately they are not warranted by BMW after 70K miles in CA. Extended warranty did not cover exhaust items as well. 4 cats on the 2006 M5 are $12K installed. My dealer was able to get the whole thing done as good will. Dodged that bullet!
 

·
Registered
Joined
·
246 Posts
I called the dealer and they said I have to bring the car in for a diagnostic. They are not sure what the problem is.

I am out of original warranty but did purchase a non-maintenance warranty throught east bay bmw. Not sure what it covers though..

Should I mention anything about checking the cats as well?

Also I need sparks plugs and microfilter replaced but I am sure that these issues have nothing to do with the emissions error.

As the car is aging (06 with 40K) one has to start worrying about costs....
 

·
Registered
Joined
·
911 Posts
I called the dealer and they said I have to bring the car in for a diagnostic. They are not sure what the problem is.

I am out of original warranty but did purchase a non-maintenance warranty throught east bay bmw. Not sure what it covers though..

Should I mention anything about checking the cats as well?

Also I need sparks plugs and microfilter replaced but I am sure that these issues have nothing to do with the emissions error.

As the car is aging (06 with 40K) one has to start worrying about costs....

First of all you should see what your warranty covers and hope that it covers most items. Number two if any of your sparkplugs don't fire it will set off the high emissions error. Number 3, you should be able to change the filters yourself, having the dealer install the plugs will cost you between $700 and $1K. If you are worried about cost then maybe an M5 isn't for you, just having the oil changed by the dealer is around $300.:eek:h:
 

·
Registered
Joined
·
59 Posts
Hey indy
sorry dont want to deviate from thread just that i cant send PM yet. Im in toronto. did you DIY the RPI scoops and block plate? or someone did it for you? Im worried if i try to DIY, something breaks lol
 

·
Registered
Joined
·
4,143 Posts
Discussion Starter #11
Hey indy
sorry dont want to deviate from thread just that i cant send PM yet. Im in toronto. did you DIY the RPI scoops and block plate? or someone did it for you? Im worried if i try to DIY, something breaks lol
I got mine installed by a buddy of mine. But he's from the US so he can't really help you out. Can't you get a shop to install it for you?
 

·
Registered
Joined
·
4,143 Posts
Discussion Starter #12 (Edited)
Update: service advisor said it's a DME issue?!?! Still investigating what it really is. I just dont why the DME would be at fault. Car runs normal without any issues just a check engine light and increased emssions warning!:crying:
 

·
Registered
Joined
·
4,143 Posts
Discussion Starter #13
ok it was the o2 sensor. Fixed!
 

·
Registered
Joined
·
29 Posts
hai indy

i have also a problem with check engine CEL/increased emissions. i owned the car for a year now and its a garage queen.
My cel came on when i started the car up in the cold below 0 degree. after one minute it comes on.
After driving the car i shut it down and start up again the CEL disappears.

every time the CEL comes on i cannot find the fault in the I-drive.

did you had the same symtomps?
 

·
Registered
Joined
·
1,309 Posts
UPDATE:

My CEL came on 2 days ago. I started my car and decided to take it for a spin since the streets were dry and salt free. I haven't driven my car in about 6 weeks so I thought the cold start may have something to do with it. I checked the gas cap and it did seem a bit loose. After I re-tightened it and drove the car for about 20 min the CEL light still remained on but when i went out and started it this morning the CEL didnt appear! I guess the computer takes some time to adjust.
 

·
Registered
Joined
·
101 Posts
Is CEL light same as "service engine soon", "increased emissions"? Mine just came on this morning while starting out on a 45 minute drive to a meeting. When I left the meeting it was still on. And tonight I have to drive an hour each way to another meeting. Does anyone know if this could cause damage if I continue to drive?

P.S. I have scoops and charcoal filter delete with BMC filters, no plates.
 

·
Registered
Joined
·
148 Posts
Is CEL light same as "service engine soon", "increased emissions"? Mine just came on this morning while starting out on a 45 minute drive to a meeting. When I left the meeting it was still on. And tonight I have to drive an hour each way to another meeting. Does anyone know if this could cause damage if I continue to drive?

P.S. I have scoops and charcoal filter delete with BMC filters, no plates.
I have same mods and have had same problem 2 or 3 times. It's probably an O2 sensor, driving on a bad one makes no difference. i had to drive for 3 weeks on a couple of bad ones to wait until they could get to it.
 

·
Registered
Joined
·
170 Posts
same problem. O2 Sensor.
 

·
Registered
Joined
·
49 Posts
I have this problem as well, is the replacement of the 02 sensors or whatever the problem may be fall under the 80k emissions warranty?
 
1 - 20 of 30 Posts
Top