BMW M5 Forum and M6 Forums banner

Help!!!! What's wrong

1581 Views 11 Replies 5 Participants Last post by  JT///M5
So I just bought this 2007 sapphire black m5 6speed. I have put about 300 miles in it and it won't shift properly. The clutch is not engaging all the way so it's rough to get into gear and especially rough taking off from a traffic light. It is chattering from while taking off from the traffic light. I have had slave cylinders go bad before in my M3 and it seems like that's what's wrong again. Is this common? Also is the slave cylinder external or internal?
1 - 12 of 12 Posts

· Registered
Joined
·
786 Posts
try resetting the clutch release bearing it works sometimes !

drive on a nice paved road your speed must be above 50 MPH ( i so it on 60 MPH ) in SMG mode while at speed remove your foot from throttle and brake put the SMG lever in ( N ) and fast pull the two shifters in the steering + & - together for 5 seconds release it put the car in drive again ( S mode ) floor it see how it shifts now ! GL
 

· Registered
Joined
·
786 Posts
double post ..sorry
 

· Registered
Joined
·
1,539 Posts
try resetting the clutch release bearing it works sometimes !

drive on a nice paved road your speed must be above 50 MPH ( i so it on 60 MPH ) in SMG mode while at speed remove your foot from throttle and brake put the SMG lever in ( N ) and fast pull the two shifters in the steering + & - together for 5 seconds release it put the car in drive again ( S mode ) floor it see how it shifts now ! GL
doesn't the OP have a 6 speed M5 not a SMG?
 

· Registered
Joined
·
786 Posts
sorry didn't know that..anyway manual means old school it's either clutch or syncros . GL
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top