BMW M5 Forum and M6 Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
211 Posts
Discussion Starter · #1 ·
guys need some quick assistance

I am in a fortunate position where a friend is PX'in my old 530d in and he has said i can have the MK3 Sat Nav unit and 16:9 monitor in a swap for my MK2 unit and 4:3 monitor

Brilliant, swap the Nav unit and monitor into the M5 and it all powers up and starts working as i expected - didnt need to swap TV tuners which means mine was a 16:9 unit already

Now, here is where the good time stop.... Plug my 4:3 into the 530d and nothing on the screen, not even turning on!! The radio works, the sat nav works (if you can get the right option) the multi changer work there is sound the wheel controls work but it would appear no power to the actual screen.

So, any idea's why??

It also appears that 16:9 and Sav nav was a retro fit to the 530d

There are 10 wires in my original loom in the M5 yet only 8 in the 530d...... (the white plug that goes into the monitor)

Is it a simple thing like i need another power/ignition/earth to the plug that controls the screen part of the head unit? If so does anyone have a wiring diagram ideally both the 4:3 and 16:9 looms......

I have tired every combo in the M5 and it all works. ANy combo works in the 530d until I fit the 4:3 screen
HELP.......
 

·
Registered
Joined
·
91 Posts
Just to check, but have you pulled the negative battery cable for a couple of minutes to allow the 4x3 to synch with the Nav? Of course, don't forget to wait for the red LED to power down in the Nav before pulling the battery cable.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #3 ·
I did leave it all unplugged for about 5 mins. Do you think it would be worth doing it for longer??
 

·
Moderator
Joined
·
1,939 Posts
Hi Andy,

I'm in West Wickham and have the day off if you want to pop up and I could have a look...

I swapped my 4:3 for a 16:9 without problem. But I ownder if the 16:9 TV monitor won't drive the 4:3 screen. Have you tried bypassing the tuner and taking the feed straight from the satnav first?

Cheers,

YG (Simon)

PS zero seven eight zero two thirty-one fifty-five seventy-five as I've just realised you can't do PM yet.
 

·
Registered
Joined
·
3,184 Posts
Replied on bmw5 also, but I think you have ground problem.

You can download the pinouts for the various Nav components from here, I don't believe the 4:3 and 16:9 monitors have different connections.
 

·
Moderator
Joined
·
1,939 Posts
Dunno about the pinouts, but wouldn't the synch be all wrong for a 16:9 from a 4:3 output?

YG
 

·
Registered
Joined
·
3,184 Posts
They should work, only a few earlier Mk I/Mk II Nav computers do not work with the 16:9, but they should all work with the 4:3.

The only issue using the 4:3 with the Mk II or Mk IV with the 'split screen' software (3-1/40 - V18 CD, or higher on a Mk III and anything on a Mk IV) is that the text and map will all be squashed, like watching a 16:9 film on an old 4:3 telly.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #9 ·
Thanks for the Advice Richard. I have tried all combintaions of all units in my M5 and they all work.

They also all work in the 530d with the 16:9 monitor, just not the 4:3 so i am sure that isnt the issue.

It would seem that my inital idea of a ground missing could be the ticket. Do you happen to have a PDF of the 4:3 plugs too? That would be a sure fire why of telling
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #10 ·
Hi Richard

Sorry to bug, do you think that i am missing PIN 7 (would explain only 8 of the 9 needed) and if so do you think i would be OK to simply earth this to say any close earth??
 

·
Moderator
Joined
·
1,939 Posts
I should've known better than to question Richard ;)

The offer's still there though. You could always swap the 4:3 unit in my car for the 16:9 in the 530 - everyone's a winner :)

Cheers,

YG
 

·
Registered
Joined
·
3,184 Posts
Probably have the same problem though, if the 4:3 requires an extra ground (maybe pin 7 on the white plug) then your 4:3 will not work either.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #13 ·
Thanks Yellowgixxer

I havnt had acess to the 530d today, I should have tomorrow though
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #14 ·
An update to those who are interested

It can be done. Spent about 45 mins today getting the 4:3 working.

Richard to my surprise it wasn't the earth on Pin 7. That was already there!!

The white plug was missing Pins 8 and 12. So a 12v DIR and Back Display illumination.

The blue plug was also missing Pin 12 which was Back Display illumination.

The 12v DIR was easy as I tapped into the same feed on the Blue plug, then got stuck on the Back Display Illumination, on all the wiring diagrams i had it was only referenced to the 2 plugs on the back of the screen unit. A bit of googling and it seems its just a loop from one plug to the other. So a deep breath and i looped it over, closed my eyes, turned the key and Bingo 4:3 screen powers up!! Relief as now i get my free 16:9 unit!!
 

·
Registered
Joined
·
3,184 Posts
Interesting.

So are you saying that the 4:3 requires the backlight connection in order to work at all? In that case does the 4:3 monitor come on before you turn the ignition on, as the main car backlight is off up to that point.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #16 ·
Yep it 100% needed the back light PIN. I tried it with just the 12v Dir plumbed in and it didnt work but needed the loop.

The 16:9 car didnt have it in either plug!

I removed the pins from my car to install in the 530d and the 16:9 unit works perfectly in mine still.
 
1 - 16 of 16 Posts
Top