BMW M5 Forum and M6 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter · #1 · (Edited)
Hi All,

I have a little problem with my car not starting on the first try. It usually starts fine on the second try. This usually happens when the car sits there for two hours and longer. When the car is warm it starts on the first try without any problems.
Also some of the time it picks up the idle for a brief moment but it dies down again.

So it turns over fairly quickly when turning the ignition which excludes battery problems. I took her to my local mechanic and here are the things he did but the problem persists:

  1. Changed fuel relays
  2. changed temprature sensor
  3. changed fuel filter
There does not seem to be a problem with the fuel injectors as the cars drives and revs just fine once it starts.

Before I spend any more money on diagnosis, I wanted to see if anyone has any suggestions of what this could be. Other than this , the car runs perfectly but ths issue is starting to become really annoying.

Thanks for advance for any replies.

Cheers,
Rob
 

·
Registered
Joined
·
763 Posts
I would suspect the check valve in the fuel pump. When it goes, it releases the pressure in the line so cold start ups take a few cranks to run the pump and pressurize the line.
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #4 ·

·
Registered
Joined
·
189 Posts
Discussion Starter · #6 ·
I would suspect the check valve in the fuel pump. When it goes, it releases the pressure in the line so cold start ups take a few cranks to run the pump and pressurize the line.
So apparently it was a faulty fuel pump which got replaced. But I am not exactly sure if that solved it. need to let the car sit for some time to test it out.

Cheers,
Rob
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top