BMW M5 Forum and M6 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter · #1 ·
Hey guys,

I have a 99 540i/6 and while at a track event this weekend, I tried rolling down the rear shade by pushing the button on below the hvac and it didn't move. left it alone and checked the fuses today -- all are good.

Now that I am away form the track and have some quiet, if i repeatedly press the button it seems to click faintly like its trying to roll down. I don't want to force anything as I know the common problem are plastic clips breaking and mine are good, so I don't know how to remedy this.

Anyone have this problem and/or know what I can do to fix it?

thanks!
 

·
Registered
Joined
·
1,878 Posts
First thing to try is to have someone press the button while you help the shade get started down. It's possible that the mechanism is in a bind. I had mine out recently to do the rear shocks and it is not a very complicated mechanism. The power connector is behind the seat back on the passenger side, so you have to undo some bolts to get to it. Probably be a bear to get the rear shelf out with the shade extended. You might be able to manually back drive it back into position if it won't cooperate. Then remove the shelf so you can get to the motor and assembly.
 

·
Registered
Joined
·
1,061 Posts
I had this problem with my 98 540i a few years ago when I had it. I was able to pry open the slot the shade goes into and see the motor/mechanism. I got a pair of channel lock type pliers in there and was able to turn the motor drive a little bit then it went down. It's a very tight squeeze. I cycled it up and down a couple of times and it worked ok, but I never used it after that until I had time to pull the shelf, but then to car got rear ended and EOS.
 
1 - 4 of 4 Posts
Top