BMW M5 Forum and M6 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
Always had this problem since i got my car im pretty sure.

when i press the drivers seat heat button, the light comes on but then after a few seconds it turns off, i do it again and then in just a second it goes away, then just instantly.

I think when i first got the car, it began heating for like 15 seconds then went away.

Anyone have this problem?

Would love to fix this since winter is comming. and none of my 2 cars have a functioning Drivers seat heater!!:sad2:
 

·
Registered
Joined
·
136 Posts
I have the same problem in my 2008 X3. I have concluded that I have a wire break in the heat element. When the problem first occured it could stay on if I "lifted" a bit from the seat, but would then turn off if I sat down.

I havent fixed it yet as I would have to replace the leather as the element is sown into it. For the X3 it's about usd 1000$ for the seat leather alone. (In Norway)
 

·
Registered
Joined
·
307 Posts
Isn't there a link to ambient temp or am I imagining it? Over the summer, my heated seat would turn off completely and/or not seem to work (early, cold mornings) but now in the winter, is fine. Is there a safety auto switch off mode or something like that?
 

·
Registered
Joined
·
77 Posts
Discussion Starter #7
Yeah i somewhat began thinking it had something to do with my weight as well, if sitting still or not on seat it stayed on longer but now its very sensitive
 

·
Registered
Joined
·
77 Posts
Discussion Starter #8 (Edited)
Any way to disconnect the bottom seat heat coushin and just leave the "back" seat heat working?

Ooops sorry for not "quoting"
 

·
Registered
Joined
·
77 Posts
Discussion Starter #9
Update: more mystery, so todays outside temperature was 23*C, decide to try the seat heat, and it worked!!!??? steyed on and all. wtf!? when its cold doenst do it but when its hot and no use for it it works....

Could it also have anything to do with my climate controll comming on all the time randomly? today it did it like 11 times.
 

·
Registered
Joined
·
77 Posts
Discussion Starter #10
Wohooo! somewhat. Traced the problem down. it seems to be if i press down on the part of the thing that moves under your knees, i feel like a wire is there and as soon as i touch it it shuts it off. so now im good if i dont touch it, which can be solved by pulling the ender knee support thing forward. kinda want to fix it for good later though.
 
1 - 10 of 10 Posts
Top