BMW M5 Forum and M6 Forums banner

521 - 540 of 561 Posts

·
Registered
Joined
·
77 Posts
For what its worth I prefer email as well.
Meanwhile...
When I first installed my BlueBus it worked perfectly. The only problem was there was no sound because my Euro C43 radio module was defective. This problem preceded the BlueBus.
Today I installed a replacement C43 unit I got off eBay. I now have sound again. However the BlueBus is acting funky. Instead of the BlueBus menu, I get "CD 1". It still streams whatever I've got playing on my phone, but there is no BlueBus menu. If I initiate a phone call from my smartphone the screen will switch from "CD 1" to saying Bluebus, and it will give me the details of the music I'm streaming. However I can't get the BlueBus menu to come up at all. Also, sometimes it won't switch back from streaming to radio, but sometimes it will.

Could it be that the C43 I've got is an older one that is somehow incompatible?

My setup is:
1997 E38
Mk4 nav (retrofitted over Japan Mk 1 nav)
16x9 head unit (retrofitted over 4x3 unit)
Phillips DSP with coax input
iBus CD changer (retrofitted over mBus unit), now replaced with BlueBus connected via coax
Analog TV (retrofitted over Japan TV module)
North American C43 radio (retrofitted over Euro C43, which was retrofitted over Japan module)
 

·
Registered
Joined
·
215 Posts
Discussion Starter #522
For what its worth I prefer email as well.
Meanwhile...
When I first installed my BlueBus it worked perfectly. The only problem was there was no sound because my Euro C43 radio module was defective. This problem preceded the BlueBus.
Today I installed a replacement C43 unit I got off eBay. I now have sound again. However the BlueBus is acting funky. Instead of the BlueBus menu, I get "CD 1". It still streams whatever I've got playing on my phone, but there is no BlueBus menu. If I initiate a phone call from my smartphone the screen will switch from "CD 1" to saying Bluebus, and it will give me the details of the music I'm streaming. However I can't get the BlueBus menu to come up at all. Also, sometimes it won't switch back from streaming to radio, but sometimes it will.

Could it be that the C43 I've got is an older one that is somehow incompatible?

My setup is:
1997 E38
Mk4 nav (retrofitted over Japan Mk 1 nav)
16x9 head unit (retrofitted over 4x3 unit)
Phillips DSP with coax input
iBus CD changer (retrofitted over mBus unit), now replaced with BlueBus connected via coax
Analog TV (retrofitted over Japan TV module)
North American C43 radio (retrofitted over Euro C43, which was retrofitted over Japan module)
The MKIV / C43 combo is just "odd" to Say the least (cars did not come equipped with this combo from the factory, so you're relying on backwards compatibility), which is why the UI is a bit glitchy.

You need to use the radio overlay button to summon the BlueBus UI (it's the button next to "MODE"). You'll see a few flickers of the screen as the BlueBus tricks the C43 into thinking the screen is reading correctly, but the UI should write correctly at this point.

On the music not switching from FM to Bluetooth and vice versa, I would say this is a C43 issue most likely. Make sure the BlueBus is set to "DSP: Analog" under Settings > Audio so it isn't trying to intervene.

Thanks!
-Ted
 

·
Registered
Joined
·
77 Posts
Radio overlay button brought up Bluebus, thank you. And it seems to be switching inputs reliably now. I still can't get the Bluebus menu to appear though. All I see is this when I'm not streaming:

943903
 

·
Registered
Joined
·
199 Posts
What volume levels on the iPhone and with the settings in BlueBus are you all running for best results? I’m trying to figure out why if I’m listening to music, it gets super loud for a second when I receive a call. Any thoughts?
 

·
Registered
Joined
·
988 Posts
I have noticed some volume throttling too, but in my case, when I'm listening to music and it's at an acceptable volume and then the phone call comes in, or I use Siri to go make one, the volume that then transpires for the phone is ultra-low and has to be turned way up. Yes I do have the mic gain set appropriately, it's the volume of the phone audio that comes through the speakers that is way way down.
 

·
Registered
Joined
·
23 Posts
What volume levels on the iPhone and with the settings in BlueBus are you all running for best results? I’m trying to figure out why if I’m listening to music, it gets super loud for a second when I receive a call. Any thoughts?
I have this issue too - when I receive a call the music level goes to max and if it weren't for the seatbelt I'd jump through the sunroof.
 

·
Registered
Joined
·
215 Posts
Discussion Starter #529
What volume levels on the iPhone and with the settings in BlueBus are you all running for best results? I’m trying to figure out why if I’m listening to music, it gets super loud for a second when I receive a call. Any thoughts?
I have noticed some volume throttling too, but in my case, when I'm listening to music and it's at an acceptable volume and then the phone call comes in, or I use Siri to go make one, the volume that then transpires for the phone is ultra-low and has to be turned way up. Yes I do have the mic gain set appropriately, it's the volume of the phone audio that comes through the speakers that is way way down.
I have this issue too - when I receive a call the music level goes to max and if it weren't for the seatbelt I'd jump through the sunroof.
Essentially, this is because of a few bugs in the way I handle the call volume offset. I discovered today that I'm increasing that offset every time you increase the volume outside of a call, rather than decreasing it.

This firmware should fix it up: https://t3ddftw.s3.us-east-2.amazonaws.com/BlueBus/firmware/bluebus_1_1_15_9.hex


Do note that there are other unrelated experimental changes in this build.

Thanks!
-Ted
 

·
Registered
Joined
·
1,398 Posts
Hey Ted. What's the word on the latest batch? I ordered back in July and if I remember correctly, the ship date was scheduled for some time this month. Thanks!
 

·
Registered
Joined
·
59 Posts
Thought I'd ask here instead of bombarding Ted with question after question...How do you adjust the volume of the call audio? My call volume is lower than the music volume. Is that the mic gain or something else?
 

·
Registered
Joined
·
215 Posts
Discussion Starter #534
Thought I'd ask here instead of bombarding Ted with question after question...How do you adjust the volume of the call audio? My call volume is lower than the music volume. Is that the mic gain or something else?
Simply using the volume knob should raise the call volume.

Thanks!
-Ted
 

·
Registered
Joined
·
59 Posts
Yes raising the radio knob does increase the call volume but after the calls ends then the music will be too loud...Is there a way to normalize the volume between music and calls?
 

·
Registered
Joined
·
215 Posts
Discussion Starter #536
Yes raising the radio knob does increase the call volume but after the calls ends then the music will be too loud...Is there a way to normalize the volume between music and calls?
If you upgrade to the firmware in post #529 (a few days ago), that should do the trick :). There were numerous bugs with the way I handled call volume offset.

Thanks!
-Ted
 

·
Registered
Joined
·
221 Posts
So this is going to seem counterintuitive considering the last few posts, but I like to drive with the windows down/sunroof open, most of the year. Is it possible to add a speed-based volume increase if the windows are down like they do in the convertibles?

Sent from my Pixel 4 XL using Tapatalk
 

·
Registered
Joined
·
215 Posts
Discussion Starter #539
So this is going to seem counterintuitive considering the last few posts, but I like to drive with the windows down/sunroof open, most of the year. Is it possible to add a speed-based volume increase if the windows are down like they do in the convertibles?

Sent from my Pixel 4 XL using Tapatalk
The car actually supports this on its own (based on speed, not window status) -- it's called GAL and you'll find it under the radios service menu. I can dig up the the info on this if you're not able to find it with a cursory Google :)

-Ted
 

·
Registered
Joined
·
221 Posts
Found it. Never occurred to me that it would exist. Now I have another secret set of controls to contend with.


Thanks Ted.
 
  • Like
Reactions: t3ddftw
521 - 540 of 561 Posts
Top