BMW M5 Forum and M6 Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #4
I tried switching the MAFs and I still got the code, they look fairly new (changed by the prior owner) The car had a cyl 7 missfire with a rough idle. I put the new cyl 7 injector in and now its idling smoothly but the entire bank of injectors are not working. I will try switching my ionic sensors as well. The plenum seems to be on correctly (I sprayed carb clearner post install. and no jumpy idle.
 

·
Registered
Joined
·
5,679 Posts
This is ionic current line related. Were you having the fault prior to swapping the ionic units between banks?
 

·
Registered
Joined
·
723 Posts
I tried switching the MAFs and I still got the code, they look fairly new (changed by the prior owner) The car had a cyl 7 missfire with a rough idle. I put the new cyl 7 injector in and now its idling smoothly but the entire bank of injectors are not working. I will try switching my ionic sensors as well. The plenum seems to be on correctly (I sprayed carb clearner post install. and no jumpy idle.


Hmmmmm.... yea def try swapping iconic modules and see if Code follows.. i had similar issues but mine were MAF sensor bad


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
What is the best way to check both- (DME and harness)?
When I purchased the car I had a cyl 7 missfire issue. I changed the cyl 7 injector
Now the entire bank is not displaying fuel injector timing.
Car has fuel pressure (104psi)
The Vanos units are new.
The car also has compression within factory ranges
Valve springs are all good on that bank.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #11
If I take the rail off; put the car on "On Mode" the injectors should spray right.. I guess I will work backwards on Friday..
 

·
Registered
Joined
·
21 Posts
Discussion Starter #14
That I'm not sure; but I do wonder when the dealership (Prior to me buying the car) - who did try to troubleshoot (swapped the L/H and R/H mis installed the ionic sensors).
 

·
Registered
Joined
·
5 Posts
Ok thx ill give that a try... but ive also swapped the coils from one side to the other and now the 1-5 still is the same and im gettin a couple other now here and there (7 &9)
 

·
Registered
Joined
·
5 Posts
Would u Happen to remember exactly which fuse it was and it’s location? Ive removed the covers already
 
1 - 20 of 21 Posts
Top