BMW M5 Forum and M6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,857 Posts
Discussion Starter #1

·
Registered
Joined
·
12,777 Posts

·
Registered
Joined
·
1,857 Posts
Discussion Starter #3
but im having hesitation issues

and i got check engine light with MAF code and bank 1 and 2 are running rich codes
 

·
Registered
Joined
·
12,777 Posts
but im having hesitation issues

and i got check engine light with MAF code and bank 1 and 2 are running rich codes
Perhaps there are problems, but based on your flow numbers, it does not point to MAF's. However, they are cheap enough to replace, less than $200 a pair. Worst case is you have a spare set for when you really do need to replace.

MAF failures do not usually cause running rich, usually bad MAF's result in not enough fuel, so if anything, I would expect lean. However, if you have an air leak after the MAF's then you will run rich as all the air the MAF "sees" is not getting to the engine. Check the plumbing from the MAF housings back to the plenum, including the little gasket where the tubes go into the plenum housing.

Regards,
Jerry
 

·
Registered
Joined
·
1,857 Posts
Discussion Starter #6
i havent replaced my o2 or cat's yet
 

·
Registered
Joined
·
531 Posts
I thought you needed to? That'd be my thought as to why you are running rich. If the O2's or Cat's aren't working correctly then you'd run rich. And if your Cat's are bad then something else went bad that you need to fix as well. Cat's don't go bad for no reason under 500k.
 

·
Registered
Joined
·
1,857 Posts
Discussion Starter #8
Well got my SES cleared last week, and cars been running beautifully so far

new spark plugs, new MAFS, coolant temp sensor ...

so far so good
 
1 - 8 of 8 Posts
Top