BMW M5 Forum and M6 Forums banner

1 - 20 of 26 Posts

·
Registered
Joined
·
690 Posts
Discussion Starter #1
Just downloaded my OEM ECU file and emailed it off to the guys at Evolve!

Can't wait to install their tune!

Will be back to post my experience!
 

Attachments

  • Like
Reactions: [email protected]

·
Registered
Joined
·
1,837 Posts
Yes please do!! I'm on the fence about this. Come on docs!

Dan
 
  • Like
Reactions: DocsV10

·
Registered
Joined
·
3,033 Posts
Yes please do!! I'm on the fence about this. Come on docs!

Dan
Drive my car once I'm back from business. You won't be on the fence anymore :)
 
  • Like
Reactions: DocsV10

·
Moderator
Joined
·
2,149 Posts
Damn everyone is getting evolved tuned.. I guess my time is coming aswell! Congrats man, looking forward to the review.
 

·
Registered
Joined
·
422 Posts
Great move! You will not be disappointed. LeeDan00, do it!
 
  • Like
Reactions: DocsV10

·
Registered
Joined
·
3,940 Posts
This tune should be one of the very first mods a new owner does. It was my second after the RPi intake setup back when I first got my car.
 
  • Like
Reactions: Benzin and DocsV10

·
Registered
Joined
·
690 Posts
Discussion Starter #8
How do I install the Evolve MAF plates (see picture)? They didn't come with instructions.


 

Attachments

·
Registered
Joined
·
146 Posts
Sorry for the noob question. But what is the benefit with the mafless setup?
 

·
Registered
Joined
·
690 Posts
Discussion Starter #12

·
Read Only
Joined
·
1,256 Posts
Doc I used AMP spades on the IAT sensor and plugged them into the factory MAF connector. It's a little ghetto but does the trick while I'm working on a more OEM looking connection.
 

·
Registered
Joined
·
690 Posts
Discussion Starter #16
Quick update:

I installed the "tuned" file from Evolve yesterday. Followed the instructions to the letter and got a "service engine soon" light along with "increased emissions". The instruction manual said this may occur, and would be cleared after a few driving cycles. I've only driven about 20 miles thus far, and have not pushed it that hard; waiting for the CEL to clear off before I really test out the tune.

A few comments:

  • Can you run a Sprint Booster with the Evolve tune (or any tune for that matter)? I'm not sure if the Sprint Booster would interfere at all with the tune, but just curious if any members on here are still running their Sprint Booster along with a tune and what their experience has been. I'd assume that throttle response would be extremely aggressive and ultra-responsive.
  • I'm running 93 octane; shouldn't this correlate to the Stage 2 tune (and NOT Stage 1)? I was sent the Stage 1 file :eek:h:
  • The IAT sensor was a real PITA to get into the MAF plate. Would've been much better to have received it already placed inside the MAF plate.
  • Regarding wiring: I just spliced into the OEM MAF harness and wrapped it with some electrical tape. I'll probably address this later and clean it up a bit (see pics).
 

Attachments

·
Registered
Joined
·
3,940 Posts
Quick update:

I installed the "tuned" file from Evolve yesterday. Followed the instructions to the letter and got a "service engine soon" light along with "increased emissions". The instruction manual said this may occur, and would be cleared after a few driving cycles. I've only driven about 20 miles thus far, and have not pushed it that hard; waiting for the CEL to clear off before I really test out the tune.

A few comments:

  • Can you run a Sprint Booster with the Evolve tune (or any tune for that matter)? I'm not sure if the Sprint Booster would interfere at all with the tune, but just curious if any members on here are still running their Sprint Booster along with a tune and what their experience has been. I'd assume that throttle response would be extremely aggressive and ultra-responsive.
  • I'm running 93 octane; shouldn't this correlate to the Stage 2 tune (and NOT Stage 1)? I was sent the Stage 1 file :eek:h:
  • The IAT sensor was a real PITA to get into the MAF plate. Would've been much better to have received it already placed inside the MAF plate.
  • Regarding wiring: I just spliced into the OEM MAF harness and wrapped it with some electrical tape. I'll probably address this later and clean it up a bit (see pics).
Do you have a generic OBD code scanner? I get the increased emissions and SES light each time I switch between tunes I just clear it with the OBD scanner and all is good afterwards. I don't like the Alpha N setup for that reason having to splice wires and all thats why I didn't opt for it.

Regarding the Sprint Booster I run one with my tune and it is fine. Still able to modulate the throttle without being overly sensitive. Confirm with Evolve regarding the octane rating they might have mislabeled the file.
 
  • Like
Reactions: DocsV10

·
Registered
Joined
·
2,490 Posts
I don't like the Alpha N setup for that reason having to splice wires and all thats why I didn't opt for it.

Regarding the Sprint Booster I run one with my tune and it is fine. Still able to modulate the throttle without being overly sensitive. Confirm with Evolve regarding the octane rating they might have mislabeled the file.
Is there a Alpha N Stage 2 and non Alpha N stage 2? I see you have an Evolve tune but got around splicing the wires somehow. Curious what I would need to go with as I don't want to splice either. I run 93oct so I was contemplating the stage 2....but not if I have to splice.
 

·
Registered
Joined
·
3,940 Posts
Is there a Alpha N Stage 2 and non Alpha N stage 2? I see you have an Evolve tune but got around splicing the wires somehow. Curious what I would need to go with as I don't want to splice either. I run 93oct so I was contemplating the stage 2....but not if I have to splice.
If you don't go with Alpha N than no splicing. I just have the regular stage 3 tune non alpha so it still uses the mass air flow sensors. They have Alpha N variant of each tune but you don't have to get it plus its more expensive.
 
  • Like
Reactions: horse86

·
Registered
Joined
·
690 Posts
Discussion Starter #20
Do you have a generic OBD code scanner? I get the increased emissions and SES light each time I switch between tunes I just clear it with the OBD scanner and all is good afterwards. I don't like the Alpha N setup for that reason having to splice wires and all thats why I didn't opt for it.

Regarding the Sprint Booster I run one with my tune and it is fine. Still able to modulate the throttle without being overly sensitive. Confirm with Evolve regarding the octane rating they might have mislabeled the file.
I guess I could use the Evolve-R software to clear the code IF it doesn't go away on its own. Personally, I was very hesitant to cut into the OEM MAF harness to splice the wires from the IAT sensor. However, I made a decision on the spot that I would not return to the OEM MAF sensors lol.

Thanks for the feedback on the Sprint Booster. I think I'll reinstall mine!

Evolve just sent me a new file for the 93 octane.
 
  • Like
Reactions: 5soko
1 - 20 of 26 Posts
Top