BMW M5 Forum and M6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Long story short of my M5 e61. Bought it a couple of months ago with some electronic gremlins caused by typical e61 flooding of the trunk. Nivo relays, EHC Nivo units and PDC unit replaced and coded/set. Car running nice with no issue. EDC unit was also flashed due to the after car purchase error which was just coding issue. After this electronic mess was managed, no errors, no problems, just the TPM is out of order.
May be someone of you had faced the same issue (checked the forum, but no answer), hence can give me a hint. The car is 06.2007 - Germany (Euro) specification. So, it is a face-lift one.
TPM says system error, check the dealer... That is it. No way to reset wheels, nothing. We had temporarily turned the system off by coding it to not bother me by alarm message and the page is shadow in iDrive menu.
As it is the 06. 2007 year and Euro ( I live in EU), then we are not 100% sure what exact system is in the car. It looks that only the FTM [flat tire monitoring system] without sensors in the wheels. I mean the FTM that gets the warning just from DSC indirect measurement of wheels spinning. The car does not have the RDC module in the trunk. It has the button on the dash above the active seat button in the middle console.
What we already did is as follows:
  • re-flashed DSC just to be sure it is fine FW.
  • re-flashed EHC unit (the nivo regulation, that was originally taken from a donor e61 not M5) as it sends some null signal to TPM as well.
  • We had checked in Inpa the dash buttons and we are not capable to get the button to get us ani pressed indication. The others buttons do the job (active seats or heating) and we can see their status in Inpa.
It can be a button, but we would expect that in such a case the system would not turn itself completely out of order, but rather just throw some error like button permanently closed. It says nothing in diagnostics.
Problem with this particular button is, that we are not sure if it is on CAN or wired one. Anyone has an idea before we start dismounting the dash? Anyone has any idea what to check else? Any idea is welcomed.
934393
 

·
Registered
Joined
·
891 Posts
Čus,

are you sure the car wasn't accidentally coded for TPMS (the radio one with the trunk module) in the VO? The option code is $2VB - if you have that in the VO, it will look for the trunk module. I'm pretty sure cars with the radio tpms option don't have the reset button.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the hint. Will check with in garage with the team there asap. We had tried to change a different variants of coding the car, non eliminated the problem. Anyway. let's check it.
 

·
Moderator
Joined
·
1,739 Posts
That's weird. All I can say is my 08 has a tpms button and I can read absolute tyre pressures in inpa. Whenever I switch between summer and winter tires (both sets with tpms sensors) the system prompts me to reset by pressing the button.
 
1 - 6 of 6 Posts
Top