BMW M5 Forum and M6 Forums banner

1 - 20 of 31 Posts

·
Registered
Joined
·
496 Posts
<object width="853" height="505"><param name="movie" value="http://www.youtube.com/v/IwHD-gdQZOk?fs=1&hl=en_US"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/IwHD-gdQZOk?fs=1&hl=en_US" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="853" height="505"></embed></object>

I finally got a chance to dyno my car after the SC install.
2000 M5 VT550, stock.
Fuel used : Chevron 91.
Ambient temperature : 93F

So without further due, the pictures.

Filled up with our great CA 91 oct gas and drove 100 miles to the nearest reputable dyno shop, the temperature was already 87 degrees around 10am!




Setting up - they certainly know what they are doing.




The results - the shop said it was too lean towards the end, what do you guys think? Another thing that bothers me a bit is the torque between the two runs are so different... why?




Test conditions.

 

·
Registered
Joined
·
4,413 Posts
Actually to me it looks a tad rich from 5-7, a tad lean at the top of the band

But those numbers are GREAT!!! Its 472whp right?
 

·
Registered
Joined
·
4,413 Posts
Yes. The numbers are WHP, I am going to round it to 473 ;-). It is desirable to be rich than lean esp at higher rmp/boost as it is safer for the engine.
Yup. At any rate I would still look to possibly getting it re-mapped to smooth out that A/F ratio line.
 

·
Banned
Joined
·
233 Posts
Congtrat's. 473 RWHP can be very fun. That is what ESS markets their E39 M5 kit at? Also you seem to have more boost on your highest #'s run. I would also have your tuning sorted out, then go out and have some fun! :wroom:
 

·
Registered
Joined
·
4,597 Posts
Thanks for sharing the graphs! Great numbers for the temperature. I'm glad to see a supercharged beast above 100k miles. Where in CA are you located?

You are running the ESS software tune, correct?
 

·
Registered
Joined
·
410 Posts
Very Nice numbers! I hope I can at least match yours lovelove

Can't wait to get mine dyno'd.
Just got her all buttoned up and put 250 miles on today.
How much do dyno runs cost nowadays anyways?
 

·
Registered
Joined
·
4,597 Posts
Very Nice numbers! I hope I can at least match yours lovelove

Can't wait to get mine dyno'd.
Just got her all buttoned up and put 250 miles on today.
How much do dyno runs cost nowadays anyways?
Since you're in San Diego, check out Dyno Shop San Diego

I had my car dynoed there a few years ago when I first got my ESS N/A tune. At the time was $30/8 pulls. Now its $50/4 pulls :)
 
  • Like
Reactions: Ransidd

·
Registered
Joined
·
410 Posts
Since you're in San Diego, check out Dyno Shop San Diego

I had my car dynoed there a few years ago when I first got my ESS N/A tune. At the time was $30/8 pulls. Now its $50/4 pulls :)

Sweet! Thier reservation page is down tho for the $50 special. I'll call tomorrow and see if I can make an appt.:3:
 

·
Registered
Joined
·
5,532 Posts
Great numbers !!

Did they measure the AFR by sticking a sniffer up the tailpipe ? If so I wouldn't get so worked up about your AFRs.
 
  • Like
Reactions: M55555

·
Registered
Joined
·
4,597 Posts
Sweet! Thier reservation page is down tho for the $50 special. I'll call tomorrow and see if I can make an appt.:3:
Might be late in the night! But talk to Jame, he's the owner. Let me know when you go, I'd love to swing by and see a local ESS M5 in action :)
 

·
Registered
Joined
·
416 Posts
AF ratio looks normal in the mid range, but leaner than spec up top (readings may be off due to sniffer location in the tailpipe as well). The values are not dangerous, but if correct I would replace the fuel pump and fuel filter as it seems to not be quite up to the task when the boost kicks in hard in the top RPM range.

Great numbers in 87F and on 91AKI!

It is normal for torque to differ between runs as the engine heats up and creates optimum power, when you run it to much the opposite will happen and it will gradually go down as it gets to hot to create optimum numbers.
 

·
Registered
Joined
·
496 Posts
Discussion Starter #13
Thanks for sharing the graphs! Great numbers for the temperature. I'm glad to see a supercharged beast above 100k miles. Where in CA are you located?

You are running the ESS software tune, correct?
I am in Santa Barbara. Right, I have the ESS VT550 tune.

Very Nice numbers! I hope I can at least match yours lovelove
There is no reason you should not as my car was bone stock!

Great numbers !!

Did they measure the AFR by sticking a sniffer up the tailpipe ? If so I wouldn't get so worked up about your AFRs.
Yes they used the sniffer, what would be the most accurate way to read the AFR?

AF ratio looks normal in the mid range, but leaner than spec up top (readings may be off due to sniffer location in the tailpipe as well). The values are not dangerous, but if correct I would replace the fuel pump and fuel filter as it seems to not be quite up to the task when the boost kicks in hard in the top RPM range.

Great numbers in 87F and on 91AKI!

It is normal for torque to differ between runs as the engine heats up and creates optimum power, when you run it to much the opposite will happen and it will gradually go down as it gets to hot to create optimum numbers.
Thanks AJ.
I can really feel the extra push from when it reaches the orange limit section, 6500-7000. It's good to hear that it's not dangerous. I will do the recommended fuel pump and filter in the near future.

I am happy with the numbers. To celebrate, I treated my car with some better gas on my way back home.





And temperature is 20 degrees cooler :3: back home.

 

·
Registered
Joined
·
410 Posts
Did you have any issues with boost leaks during initial install? I haven't checked my boost yet so for all I know I might be pushing 1psi lol. But it sho does look and sound purty! I'd be ecstatic with 470 whp.
 

·
Registered
Joined
·
776 Posts
Great to see your numbers. Love the color of your car too! Avus, I think....... You may want to explore cooling the intake charge as well.
 

·
Registered
Joined
·
496 Posts
Discussion Starter #16 (Edited)
Did you have any issues with boost leaks during initial install? I haven't checked my boost yet so for all I know I might be pushing 1psi lol. But it sho does look and sound purty! I'd be ecstatic with 470 whp.
I never had any leak, the boost gauge was just for peace of mind - something I can verify everyday. I changed some hoses and the plenum gasket while I was at it.

Great to see your numbers. Love the color of your car too! Avus, I think....... You may want to explore cooling the intake charge as well.
Thanks! I heard Avus is the fastest color. :7:. Where I live, the temperature only gets up to maybe 75 F on a hot day in August, I usually see temperatures in the 60s whenever I drive.

Video of the dyno.

<object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/IwHD-gdQZOk&hl=en&fs=1"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/IwHD-gdQZOk&hl=en&fs=1" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"></embed></object>
 

·
Registered
Joined
·
3,553 Posts
Kev,

Greetings from Maryland. Congrats on the run. GREAT #'s! I WOULD do something about the 6,500+ AFR's since they are going lean vs. fat. I believe AJ makes a valid point suggesting the pump & filter.

P.S. How did yer girl like her 100 octane cocktail :3:
 
  • Like
Reactions: KevN23

·
Registered
Joined
·
496 Posts
Discussion Starter #19
Kev,

Greetings from Maryland. Congrats on the run. GREAT #'s! I WOULD do something about the 6,500+ AFR's since they are going lean vs. fat. I believe AJ makes a valid point suggesting the pump & filter.

P.S. How did yer girl like her 100 octane cocktail :3:
Steve,

I recall you had similar readings and you had NEW pump and filter? Did you ever get it resolved? Please PM me if if you want.
I think I am chickening out a bit on going WOT in 2nd now, feels like front is going to lift up and snap something in the rear.

BTW - I saw the thread on Peters build got delayed, I assume that's what you are there?

Did you get the dyno runfiles?
Yup. we did 4 runs and I got them all. I plotted all the charts I posted using WinPEP 7.
 

·
Registered
Joined
·
2,078 Posts
Steve,

I recall you had similar readings and you had NEW pump and filter? Did you ever get it resolved? Please PM me if if you want.
I think I am chickening out a bit on going WOT in 2nd now, feels like front is going to lift up and snap something in the rear.

BTW - I saw the thread on Peters build got delayed, I assume that's what you are there?



Yup. we did 4 runs and I got them all. I plotted all the charts I posted using WinPEP 7.
Nice numbers Kevin! Wish I would have been around to go with ya! Would have been nice to run our cars on the same dyno, same day...with my SS Headers, 92mm pulley and race gas...just to get a comparo

Cheers
 
1 - 20 of 31 Posts
Top