BMW M5 Forum and M6 Forums banner

21 - 27 of 27 Posts

·
Registered
Joined
·
232 Posts
Hello fellow M5 enthusiasts,

I purchased my 2007 M5 in July of 09 and the car is awesome. However, recently twice this engine malfunction warning has come up. the first time was when I returned from vacation after the car was sitting for two weeks garaged.
Look forward to hearing from you.

Thanks
It happened to me recently....took it to dealer and was confirmed to be gasoline quality related. The high ethanol mix on certain station is messing up the M5 timing. I switch gas station and problem went away. So I only get gas from certain selected station (not just brand) , of course you want to go with Tier-1 Gas like Shell or Chevron.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #22
Just got the call back from service and the car will be ready tomorrow morning. they said the problem was with the oil line. It was losing pressure not oil and the computer was recognizing a failure. They said the long wait was due to a special oil gauge they needed from bmw for the M5. Thankfully the car is under warranty because who knows what the bill would have been. I have to say driving their loaner, a brand new 335i, made me crave to be back in my M5. I really miss the beast! I will keep you posted.

Thank you to everyone who took the time to share their opinions.

J
 

·
Registered
Joined
·
6,353 Posts
Good luck bro!

My 2006 stayed at the dealers for a whole month until they finallly got approval from BMW to replace the clutch. I made a huge scene and refused to pay a penny as my car only has 19k miles on it.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #24
well done. glad to hear you hung in there. Persistency pays off. I will keep that in mind if the dealer gives me any grief. I will say they really have been great. I have been going to them since January of 2001 and never had anything bad to say.

JL
 

·
Registered
Joined
·
1,306 Posts
damnit, I just got this error today when I parked my car on a slight decline. Started the car up to move it to a better parking spot and I got the reduced power message. I haven't even been driving her hard at all. Don't know what could be wrong. Maybe it will go away once I start it up later to go home.
 

·
Registered
Joined
·
1 Posts
Can you describe the way you are driving the car when the warning comes on. I had that same problem but only when I got to around 8k rpms in 3rd geer. My problem ended up being a faulty EKP sensor. But it was a bit of a headache to get someone to fix.
Hi, I wanted to see if you can tell me how you were able to get this issue fixed. I'm having the same problem as you were having were the car would give me an emissions reduce power at high RMP in 3rd or 4th geer. I wanted to see if you can tell me where the EKP Module was located and if that fixed your problem?? In 1st and 2nd geer it runs like a beast but when i get into high RMP in 3rd or 4th geer the car goes limp.....it drives me crazy specially when I get on it and it just losses power. It looks like you were able to fix this problem so your prompt reply would be greatly appreciate it.

Thanks
Carlos

P.S. Im new to this so here is my email: [email protected]
 

·
Registered
Joined
·
2 Posts
Hey man I had the same thing happened to me today driving in sport mode. I gave it a quick acceleration but my gear was fourth- about 7k rpm than the message popped up, engine malfuciton!!! is this thing expensive to fix?
 
21 - 27 of 27 Posts
Top