BMW M5 Forum and M6 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter #1
I just received this code , how safe is to drive like this ? :sad2:
What can it be ? :sad3:
This means visit to dealer tomorrow ??????
 

·
Registered
Joined
·
2,099 Posts
I'm assuming Engine Failsafe Mode is the European equivalent of the SES light and limp mode? It often is a temporary thing and fixes itself by shutting off and restarting the engine. If it persists, that is a good thing as it is easily diagnosed. With the engine in limp mode, it is OK to drive short distances but don't run it hard. It's happened to me twice, once a Vanos problem and once an oxygen sensor. Both times, I had no problem driving to the dealership for service.
 

·
Registered
Joined
·
6,354 Posts
Yes it is, the car will go into limp mode and stay at low RPM regardless of throttle!!! You can pull to the side, and restart the car again and find out if it comes on again!

I get this message all the time because RMS screwwed up my ECU!!! I get it when the engine is cold. It could be caused by many things, but mainly software related issues because if you had faulty MAF's or CAM sensors, or even O2 sensors, your car would stutter and drive rought, but this message will come on if there is a software error!!!!
 

·
Registered
Joined
·
105 Posts
Discussion Starter #4
This morning code came twice but I did't notice any difference in throtle or anything else , Beast was running nice. :wroom:
This afternoon did small drives and no code :D
Anyway I will visit my dealer tomorrow :flag:
 

·
Registered
Joined
·
2,099 Posts
Have you checked the fuel filler cap? That can cause an SES light but no drive-ability problems.
 

·
Registered
Joined
·
6,354 Posts
iMac said:
This morning code came twice but I did't notice any difference in throtle or anything else , Beast was running nice. :wroom:
This afternoon did small drives and no code :D
Anyway I will visit my dealer tomorrow :flag:
You mean the "Engine Failsafe Prog" message appeared, and the car was running fine?????? Thats not possible!
 

·
Registered
Joined
·
784 Posts
Ahmed said:
You mean the "Engine Failsafe Prog" message appeared, and the car was running fine?????? Thats not possible!
The Engine Fail Safe program places everything in default mod.. It could have been a simply hiccup or an issue that needs to be addressed. Regardless it is not a Euro code..... it is throughout. Turning the car off and restarting it after 25-30 seconds will reset the DME and most times you will be fine. A visit to the Dealer to scan for codes will show it and hopefully what caused it. Again, have seen it numerous times and most times it is a simple hiccup......for example; if you clear adaptations while the car is running it will produce this code......

Take care

Shadowman
 

·
Registered
Joined
·
105 Posts
Discussion Starter #9
Just came from my dealer and diagnosis was that some air flap for bank2 is open a little more than other . Tommorow will be fixed (hopefully) cherrsagai
Has any one of you had this problem ?
 
1 - 9 of 9 Posts
Top