BMW M5 Forum and M6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
631 Posts
Discussion Starter #1
First off these noted concerns are the only thing on my M5 to deal with really.
Quite a well behaved animal it is.

1. Driver side vanity light doesn't come on when sliding the mirror cover. I was told by shop it was pinched wire and it wasn't worth it to order new one since leather looks so good anyways. Is this a potential hazard? Anybody ever change one of these out?

2. Seat memory button. It wasn't working (drivers door M/1/2/3 button) when I bought car and I ordered/installed new one. Works great except "M" light doesn't light up when pressed. The "1" setting I use works fine. Is this easily traced to the fault?

Any comments or tips are welcomed.

Btw; both issues are not happening on my 530i...I'd like to clean them up.
 

·
Registered
Joined
·
854 Posts
Regarding the vanity light. Does it not come on no matter what position the sun visors are in? Mine go off if the visor is pushed all the way to the windshield
 

·
Registered
Joined
·
631 Posts
Discussion Starter #4
Regarding the vanity light. Does it not come on no matter what position the sun visors are in? Mine go off if the visor is pushed all the way to the windshield

No, the light doesn't come no matter what. I think the wire may be pinched...my question is if anybody has expereince with this as to being a potential fire hazard. I keep the mirror closed just in case.

The "M" light not comming on when "priming" the button for setting I thought would be tied to something obscure...if any1 can weigh in....
 

·
Registered
Joined
·
4,488 Posts
First off these noted concerns are the only thing on my M5 to deal with really.
Quite a well behaved animal it is.

1. Driver side vanity light doesn't come on when sliding the mirror cover. I was told by shop it was pinched wire and it wasn't worth it to order new one since leather looks so good anyways. Is this a potential hazard? Anybody ever change one of these out?

2. Seat memory button. It wasn't working (drivers door M/1/2/3 button) when I bought car and I ordered/installed new one. Works great except "M" light doesn't light up when pressed. The "1" setting I use works fine. Is this easily traced to the fault?

Any comments or tips are welcomed.

Btw; both issues are not happening on my 530i...I'd like to clean them up.
Re sun visor, it could just be the bulbs.

Also, based on how both of mine work, the bulbs only light over a range of rotation of the visor, i.e. they turn off when the shade is getting close to being up against the roof and also when the visor gets close to the windshield. In other words they only light when you have the visor adjusted as required to refresh your lipstick. I noticed as I rotate it between those two positions, the bulbs flicker a bit which makes me think there is a sliding contact-type switch monitoring the shade position. Those things can get dirty or oxidized and quit working.

Or the on-off switch activated by the mirror cover in the visor could be bad.

Or the flexing could have broken a wire.

I'm sure you done lots of searching so if you haven't found anything, then you have an unusual problem. You're going to have to take the visor apart somehow to troubleshoot. TIS may have instructions.

It shouldn't be a hazard. The fuse will blow if it shorts out.
 

·
Registered
Joined
·
631 Posts
Discussion Starter #6
Re sun visor, it could just be the bulbs.

Also, based on how both of mine work, the bulbs only light over a range of rotation of the visor, i.e. they turn off when the shade is getting close to being up against the roof and also when the visor gets close to the windshield. In other words they only light when you have the visor adjusted as required to refresh your lipstick. I noticed as I rotate it between those two positions, the bulbs flicker a bit which makes me think there is a sliding contact-type switch monitoring the shade position. Those things can get dirty or oxidized and quit working.

Or the on-off switch activated by the mirror cover in the visor could be bad.

Or the flexing could have broken a wire.

I'm sure you done lots of searching so if you haven't found anything, then you have an unusual problem. You're going to have to take the visor apart somehow to troubleshoot. TIS may have instructions.

It shouldn't be a hazard. The fuse will blow if it shorts out.

Thanks. My 530i operates over any rotational range. I'll try the bulbs...shop did some other stuff and I told them to try that and they said it's not bulbs but who knows. Seems like DIY is only way many times.
 
1 - 6 of 6 Posts
Top