BMW M5 Forum and M6 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
917 Posts
Discussion Starter #1 (Edited)
Hi:
It is a 2008 m5 with 85000 miles,,this happened two days ago when left car not started for 5 days.but if I start the car everyday car is normal no coded no high battery drain.
In dash high rate battery discharged and when I put my c110 scanner it give me this code
279D output stage,electric fan...and only this code nothing else
Are these related ..I mean if the electric fan in fault does it trigger high rate battery discharge.

I looked and searched but no final answer in this issue.
Do I need to change the fan?
Or there is any solution for this.
Bear in mind as I said before it happen only if I left car not started for 4 to 5 day...if I started every day all good
Battery new October 2018..secret minue # 9 give 14.1 volts while running and 12,5–12.6 v while off.

Thank you
 

·
Registered
Joined
·
917 Posts
Discussion Starter #4 (Edited)
If you put a new battery make sure you registered it, the code and battery issue are on unrelated.
Of course I register it. I am more 30 year owning bmw’s
The weird thing is when electrical fan code triggerd immediately the high rate battery discharge comes in dash.
This what I want answer for it.
I will be changing the fan and see if problem still there.
Very very strange this only happened two times in the last two weeks.
Is IBS has the do something with this bevaior,,but there is no code for IBS code.
Only code is what I wrote above.

Thank you
 

·
Registered
Joined
·
526 Posts
Possibly a regulator. I’ve heard of the battery cable having issues at the connector on drivers side valve cover. Check for voltage drop at battery and said connector.
 

·
Registered
Joined
·
917 Posts
Discussion Starter #6
Possibly a regulator. I’ve heard of the battery cable having issues at the connector on drivers side valve cover. Check for voltage drop at battery and said connector.
I changed new oem alternators plus new battery from dealer...and they say battery cable is good and IBS is good also
Problem still there after 5-6 days I get the same thing and the same code.
Car with dealer now for a month and they can not figure what is the problem .
Thing is when I brought car to them they say alternator and battery I gave them the green light to change,,,got the car and within 6 days of not starting it I got the same problem.
Now this is their problem to fix it.
It is has been mor Than 35 days and they did not found the issue.
Anyone can help here

Thank you
 

·
Registered
Joined
·
1,513 Posts
Dealer can query the IBS for excessive discharge for the last 32 drive cycles or so. If no excessive discharge then I'd consider your battery is faulty (yes I know it's new).

Just an idea: unplug the fan and wait 5 days and see if discharge message appears.
 

·
Registered
Joined
·
917 Posts
Discussion Starter #8 (Edited)
Dealer can query the IBS for excessive discharge for the last 32 drive cycles or so. If no excessive discharge then I'd consider your battery is faulty (yes I know it's new).

Just an idea: unplug the fan and wait 5 days and see if discharge message appears.
The car with dealer now.
I told them I will not pay a penny to fix.
You told me alternator and battery and I paid .
Now your turn to fix it,,,I do not care.
They left car not started for 6 days and the same message came on dash and 279d.

Thank you.
 

·
Registered
Joined
·
917 Posts
Discussion Starter #9
Updates ,,still same problem ,they change the battery again and the IBS
after 6 days same code 279d,
I told them it is a DME,,but they are not listening to me.
Thank you
 

·
Registered
Joined
·
917 Posts
Discussion Starter #10
Any help here.
 
1 - 10 of 10 Posts
Top