BMW M5 Forum and M6 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi Everyone,


this is my first post in years... so please pardon my language if not accurate.... Btw I'm in Toronto - Ontario-Canada now.


I own an E63 2005 M6 ( yup one of the first) since then I probably had the clutch changed like 5 times and flywheel 3 times ( Car as 102,000 KM on it) between 2005 - 2016 I lived and had the car repaired in The Netherlands before I moved to Toronto Canada ( shipped the car with me).


My Journey of Pain:


Aug 2018 car gives transmission erros ( Engine Fault, Transmission fault) puts its self in neutral upon restarting the egine it would drive.


Sep 2018 approx. 4 weeks later Car breaks down ( thankfully I had just stopped in the garage), care was on neutral, wont put a gear on nor start.
Jan 2019


Jan 2019 after 4 months of trouble shooting the mechanic ( indy) says it was the slave cylinder ( ripped me off for a gas tank pump, ECS programming, wiring etc..) I believe there was also water that went into the car that damaged the cables, however the car was running.


Jan 2019 2 weeks later the driving on the highway @90km/h the car starts to loose power, its as if the clutch was seizing I tried to keep going but the loss of power was continuous so I managed thankfully to pull to the side, stopped, some codes came out about clutch overheating, transmission fault, I let the car /clutch cool down for 2 hours started but nope there was no movement what so ever, however car could be put in neutral.


June 2019 Mechanic announces his complete failure ( after 5 months !!!) said he changed the clutch and bearing and flywheel but the car still wont move nor put on a gear !!! it's insane !




I Don't know what to do... could it be a faulty installation from his side ? could there be any other root cause to that other than the clutch ? I wouldn't go to the stealership as they said replacing the clutch/flywheel is like a 10,000 c$ job !!


Finally , if anyone knows an SMG expert in Toronto-Ontario, Canada ... please pass me on the contact... I am desperate and its too frustrating... any advise/guidance would be great.....I don't want to do anything anymore until I get advise from you guys....it's almost IMPOSSIBLE to find an SMG expert around here !!!


p.s I have other side isses like massive gas consumption ( 240 km a tank more or less driving in the city, used to do 350-380 in the past). and a suspension issue ( clunking from te right side when I turn the wheel as if there is a coupling seizing...)


Thanks
Xomas
 

·
Registered
Joined
·
452 Posts
I'm sorry to hear of your problems. It really sounds like you should just sell it as its giving more trouble than anything else. Would you not consider getting rid and relieving yourself of all these on going issues?

On a side note, do you have any fault codes as that will help point you in the right direction?!

Thanks

Sent from my SM-G950F using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
thanks ....


it's just very dear to My heart this car.. .I'd like to keep it...


I'll get back to you asap with the codes, on my way to tow it from the mechanic.....
 

·
Registered
Joined
·
1,460 Posts
I know exactly what you need... a new mechanic.

Can't recommend anyone but most / all SMG issues are well documented here. Since you're paying for labor you will likely want to just install a refurb'd SMG unit from Jim or elsewhere and call it good for another 100k.
 

·
Registered
Joined
·
7 Posts
I have two places you can check that have worked on both my E63 M6's. My first one was a 2006, no problems before I sold it.
My current one is a 2010 with no issues. I guess I am lucky. I had 160,000km on the 06 and have 140,000km on the 2010.

Check out these two places

RMP Motors.

and

Bimmersport.

I've been to both. The owner of bimmersport owns a E60 M5 so he's worked on the engine.

The owner of RMP motors has done a LOT of work on the S65/s85 engine from what I've heard. They both specialize in BMWs.
 

·
Registered
Joined
·
28 Posts
As post states above those 2 shops should sort you out. I’m in Toronto and you NEED to know where to take it. If they can’t help, Clarkson Fine Cars has sorted out my Smg issues a few times.
 

·
Registered
Joined
·
97 Posts
Oh man ... i feel your pain. Having to replace my SMG clutch recently , and studied the SMG tranny up close and personal ... these things aren't really rocket science. Their complexities are over-rated and faults are actually easily rectifiable. As someone mentioned earlier, better to refer to a competent mechanic who won't make a mountain out of an ant hill over SMG issues.

As for me, i'd run the SMG adaptation routines (more specifically, the clutch valve characteristics and also the clutch slip-in values) each time i feel the tranny isn't shifting too nicely. Probably doing it like 1 or twice a year but I'm kinda OCD. As for the SMG electrohydraulic shifting points, i noticed that these don't deviate too much over time and they're pretty stable so far.

Also get your car's integration level up to the latest one available. There was a Tech Service Bulletin that highlighted some SMG software bugs in module versions prior to 2007 or 2008's integration level.
 

·
Registered
Joined
·
468 Posts
Purchase a new SMG Pump motor and have it replaced or get INSTA + installed on your laptop buy yourself the Dcan Cable and replace the motor and re-bleed your SMG system using Insta. pretty sure that will fix your issue.

Good luck!

Hi Everyone,


this is my first post in years... so please pardon my language if not accurate.... Btw I'm in Toronto - Ontario-Canada now.


I own an E63 2005 M6 ( yup one of the first) since then I probably had the clutch changed like 5 times and flywheel 3 times ( Car as 102,000 KM on it) between 2005 - 2016 I lived and had the car repaired in The Netherlands before I moved to Toronto Canada ( shipped the car with me).


My Journey of Pain:


Aug 2018 car gives transmission erros ( Engine Fault, Transmission fault) puts its self in neutral upon restarting the egine it would drive.


Sep 2018 approx. 4 weeks later Car breaks down ( thankfully I had just stopped in the garage), care was on neutral, wont put a gear on nor start.
Jan 2019


Jan 2019 after 4 months of trouble shooting the mechanic ( indy) says it was the slave cylinder ( ripped me off for a gas tank pump, ECS programming, wiring etc..) I believe there was also water that went into the car that damaged the cables, however the car was running.


Jan 2019 2 weeks later the driving on the highway @90km/h the car starts to loose power, its as if the clutch was seizing I tried to keep going but the loss of power was continuous so I managed thankfully to pull to the side, stopped, some codes came out about clutch overheating, transmission fault, I let the car /clutch cool down for 2 hours started but nope there was no movement what so ever, however car could be put in neutral.


June 2019 Mechanic announces his complete failure ( after 5 months !!!) said he changed the clutch and bearing and flywheel but the car still wont move nor put on a gear !!! it's insane !




I Don't know what to do... could it be a faulty installation from his side ? could there be any other root cause to that other than the clutch ? I wouldn't go to the stealership as they said replacing the clutch/flywheel is like a 10,000 c$ job !!


Finally , if anyone knows an SMG expert in Toronto-Ontario, Canada ... please pass me on the contact... I am desperate and its too frustrating... any advise/guidance would be great.....I don't want to do anything anymore until I get advise from you guys....it's almost IMPOSSIBLE to find an SMG expert around here !!!


p.s I have other side isses like massive gas consumption ( 240 km a tank more or less driving in the city, used to do 350-380 in the past). and a suspension issue ( clunking from te right side when I turn the wheel as if there is a coupling seizing...)


Thanks
Xomas
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Guys thanks for all your help, ROM motors was busy.

Update:

Car runs again !I went to autobahn east in ajax, the owner mark apprently is extrmely experienced with M's, turns out to be just a clutch and the fork as for the mossfire it was just an ifnition coil .. amazing guy really, once again thanks for all your help!!
 

·
Registered
Joined
·
452 Posts
Guys thanks for all your help, ROM motors was busy.

Update:

Car runs again !I went to autobahn east in ajax, the owner mark apprently is extrmely experienced with M's, turns out to be just a clutch and the fork as for the mossfire it was just an ifnition coil .. amazing guy really, once again thanks for all your help!!
Glad to hear it's all sorted! Enjoy in good health!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
Quick question, as Mark mentioned I will need to change the SMG Pump motor, does any ody know of a shop ( online or physicial) in Canada it the US To grt the motor from ?any reliable after market brands?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #12
Quick question, as Mark mentioned I will need to change the SMG Pump motor, does any ody know of a shop ( online or physicial) in Canada it the US To grt the motor from ?any reliable after market brands?
 

·
Registered
Joined
·
985 Posts

·
Registered
Joined
·
1,460 Posts
Doubt ECS stocks these. So if they show in stock then any dealer can get them as well.

Try any of the online dealers to save some $$$. bmwpartshub and dmwdirectparts are my preferred ones.
 
1 - 14 of 14 Posts
Top