BMW M5 Forum and M6 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
672 Posts
Discussion Starter #1
Hello-
My E39 2001 celis Hella tail lights are acting up... just tonight I noticed the turn signals work fine, brake lighs are fine, reverse lights are fine..but the LED running lights are not coming on..they wont turn on in any switch position, parking light position...can't figure this out. I checked all fuses, wiring harness...don't see anything wrong. Please let me know what ideas you all have....I have never seen this or found any good posts on this.
Thanks!
Beau
 

·
Registered
Joined
·
672 Posts
Discussion Starter #3
contacts are spotless....worked even earlier today.....any wiring or fuses/relays anyone knows of?
thanks
Beau
 

·
Registered
Joined
·
672 Posts
Discussion Starter #4
So I took my taillight off and there was water on the passenger side taillight, I have shaken and dried it completely...but when i put the plug back in..no LED lights..only the turn signal, brake lights and reverse light work..both sides have LEDs not working. Could the water have shorted out a relay? Anyone know where to look from here...im out of ideas and need taillights at night!
Thanks
 

·
Registered
Joined
·
200 Posts
So I took my taillight off and there was water on the passenger side taillight, I have shaken and dried it completely...but when i put the plug back in..no LED lights..only the turn signal, brake lights and reverse light work..both sides have LEDs not working. Could the water have shorted out a relay? Anyone know where to look from here...im out of ideas and need taillights at night!
Thanks
sounds like the transistor(s) in the lcm might have gotten fried; there are no relays. if you can get your hands on a voltmeter i would test the voltage across the pins, to see if there is still power coming to the lights. iirc the pin #6 is the power to the celis bars/leds and pin #3 should be ground on the right side. and on the left side its pins 1 and 4 respectively..
 

·
Registered
Joined
·
1,548 Posts
I've had this problem with a 2002 530i that I had..
Replacing the taillight solved the problem..
didn't cost that much about $140 or so..
But before that everything was tried just as you all are doing..
You may have to replace your passenger taillight, and this was the same side mine was on
 

·
Registered
Joined
·
112 Posts
I have tested mine....

with another lamp. The other lamp worked, so looks like I'm in for one now. And they aren't $140 anymore. At your friendly BMW retailer te list price is $302.30 PER SIDE. Anyone know of someone parting a car? Maybe Vines has one, it is the same part number for 540i as well. Thanks for any suggestions....
 

·
Registered
Joined
·
12 Posts
my only advice is check the taillights when its really dark, there's two bulbs in each light and if only one is burnt out it still looks like its on pretty well.. Clean/replace the bulbs and sockets as necessary. You can refer to your auto repair manual for procedures.
 

·
Registered
Joined
·
1,548 Posts
my only advice is check the taillights when its really dark, there's two bulbs in each light and if only one is burnt out it still looks like its on pretty well.. Clean/replace the bulbs and sockets as necessary. You can refer to your auto repair manual for procedures.
There aren't any bulbs that he can take out.. they are leds built into the taillight.
He needs a new taillight.
 

·
Registered
Joined
·
672 Posts
Discussion Starter #12
allgood, got new ones
Thanks though!
 
1 - 12 of 12 Posts
Top