BMW M5 Forum and M6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,416 Posts
Discussion Starter #1 (Edited)
I recently replaced my e-brake handle with a Bimmian matte black version. Needless to say the OEM handle was a beech to get off the post. After install I realized that, when pulled, there is no more clicky at all. I am guessing that I stretched the cable as the brake no longer works as well as before (but works). There does still seem to be some tension and it does catch.

Anyone ever have this issue and have a fix besides replacement?

Handle looks pretty sweet with Slimms alcantera boots and the backlit ZHP ;)
 

·
Registered
Joined
·
3,968 Posts
highly doubt you stretched the cables. a more likley scenario is that the release button on the end of the handle is not moving freely/binding inside the new handle. remove the handle and see if the ebrake works correctly without it.
 

·
Registered
Joined
·
637 Posts
I don't believe that you stretched the cable, but I do believe that it needs to be tightened. I had a similar situation on a non BMW car. I no longer had the "clicking" sound to notify me when the parking break was being engaged. Tightening the cable solved the problem.
 

·
Registered
Joined
·
170 Posts
I am interested as to what the solution is for you. I have a similar situation, in that, mine clicks, but not at the top end of the 'pull', not all the time though. Sometimes it catches just fine, other times it will drop a notch or 2 before it catches. I have just learned to live with it, but reading your post makes me want to sort mine. Good luck.
 
1 - 4 of 4 Posts
Top