BMW M5 Forum and M6 Forums banner

1 - 20 of 39 Posts

·
Registered
Joined
·
706 Posts
Discussion Starter #1 (Edited)
Phew - just checked back over 100 or so emails with EAT that now go back more than 20 months. Still haven't got my working chips (yep two of them) that I paid for in July 2006.

Last I heard from Mark was:

Happy New Year. I spend quite a bit of time on it, and hope to finish it this weekend. I'll have it out to you early next week.


That was January 4th.

No answer to my emails since.

Anyone heard from them?

Ian

ps - I have two chips from him - but they don't work. Car cuts out at 1950 rpm until it warms up beyond 60C oil temp. Very unsafe to drive.
 

·
Registered
Joined
·
7,933 Posts
I once tried to get hold of him for a chip too.

After several non-replied e-mails (no sweat Mark, I know what its like to be busy) I started a thread and he chimed in..

Last thing I heard he still makes the chip, but since its not with speed limiter delete, I didn't order. As soon as that exists, I'll get one right away.
 

·
Moderator Emeritus
Joined
·
4,273 Posts
Mark D is around...
I have spoken to him a month or so ago.
I believe he may be contracted to an o/e manufacturer &
away from regular access due to working away from home.

His website is still up & supported.
He does answer his phone at weekends also.

Has the eprom been tried in another known 3.6 Ian ?

Refund ???

Good luck & hope you both resolve amicably:)

:cheers:
Farrell
 

·
Moderator
Joined
·
10,456 Posts
Huh, that is odd. I ordered one off his website maybe in october, it arrived in my mailbox a week or so later.
 

·
Registered
Joined
·
1,850 Posts
Mine took a little while but nothing outrageous. We had a group drive (well 5 of us anyways) last year and he and his wife came along. Extremely nice guy.
 

·
Registered
Joined
·
295 Posts
Nice guy or not, if I was waiting since July 06 I would be less than impressed. Ian, you have shown a lot of patience.
 

·
Registered
Joined
·
27 Posts
I bought a chip from him. It arrived within a week of my purchase -- however it makes the car knock/ping at open throttle < 4k RPM, probably due to crappy gas in California. I read that he made a different version of the chip for California, but I've not been able to get in touch with him either. I've tried a few different emails and left messages... I don't really want to go starting a thread on yahoo mailing list (why drag my issues out in front of the public?) but it seems I may have no choice. Right now the chip is just sitting in a drawer -- I had to take it out.
 

·
Moderator
Joined
·
10,456 Posts
I bought a chip from him. It arrived within a week of my purchase -- however it makes the car knock/ping at open throttle < 4k RPM, probably due to crappy gas in California. I read that he made a different version of the chip for California, but I've not been able to get in touch with him either. I've tried a few different emails and left messages... I don't really want to go starting a thread on yahoo mailing list (why drag my issues out in front of the public?) but it seems I may have no choice. Right now the chip is just sitting in a drawer -- I had to take it out.

I requested the 'california gas' option when i ordered my chip. No pinging (i did get some with the previous confortti chip) but it hasn't been that hot since doing the chip.

I would post at least an inquiry on the yahoo list. When my chip arrived, the return address was from a member of the list (gary something, in ny or nj, can't remember for sure) rather than d'sylvia himself, perhaps they work together and he handles the US supplies.
 

·
Registered
Joined
·
168 Posts
Phew - just checked back over 100 or so emails with EAT that now go back more than 20 months. Still haven't got my working chips (yep two of them) that I paid for in July 2006.

Last I heard from Mark was:



That was January 4th.

No answer to my emails since.

Anyone heard from them?

Ian

ps - I have two chips from him - but they don't work. Car cuts out at 1950 rpm until it warms up beyond 60C oil temp. Very unsafe to drive.
Sounds like he is burning you a custom chip. What is different about your car or what custom features are you asking for if you don't mind me inquiring? BTW he is still around, had dinner with him and his wife last month.
 

·
Registered
Joined
·
1,289 Posts
He also kindly sent me a stock 3.8 map a few weeks ago after seeing my post on here - I guess he's just very busy, I know the feeling!
 

·
Registered
Joined
·
706 Posts
Discussion Starter #11
Farrell mentioned a refund - yes Mark did offer to do that at one stage, but I had spent $100 getting the chip out of my car copied so he could see why it didn't work.

I don't know why he doesn't answer emails or deliver on his promises.

I know what I would do if he was in this country.
 

·
Registered
Joined
·
233 Posts
I requested the 'california gas' option when i ordered my chip. No pinging (i did get some with the previous confortti chip) but it hasn't been that hot since doing the chip.

I would post at least an inquiry on the yahoo list. When my chip arrived, the return address was from a member of the list (gary something, in ny or nj, can't remember for sure) rather than d'sylvia himself, perhaps they work together and he handles the US supplies.
Do you happen to remember the part number of your EAT chip for "California Gas" ? I bought my EAT chip in January and still have not installed yet and I also live in CA with the 91 octane gas available. I just want to make sure my EAT ship is the same one you installed in your M5. Mine is a 1991 E34 M5.

Thanks
 

·
Moderator
Joined
·
10,456 Posts
i don't, i just put it in the notes when i ordered, and don't remember any specific pn.
 

·
Registered
Joined
·
292 Posts
Hi all,
Ian and I have tried the chip etc. in a different car (mine) and the problem was still there. I also had an EAT chip in my car and whilst it didn't have the same problem as Ian's it didn't feel right (l'm so tempted to mention "seat of the pants dyno here :7:) so I swapped it for my 10 year old Powerchip to see if it made a difference.

After a few "issues" changing the chip, the difference in the car was incredible. So much smoother and more powerful. It didn't make sense that the difference between Mark's chip and an "old" Powerchip could be so stark, so I asked someone who knows what they are doing read Mark's chip.

The results were interesting to say the least (I apologise if I butcher the details but you'll get the general gist). Apparently the ECU's/chips have 4 different region codes (EU, NA, Asia/Pacific, and Mid east IIRC) and each region has it's own ECU map. To stop their chips being copied and sold illegally into other areas, many chip manufacturers (e.g. Conforti) only modify the map for the area they are selling the chip into.

For example if you live in the UK and buy a Conforti chip off flea bay from a "reputable" Chinese seller, it's highly likely when fitted to the UK car, the car wont perform any differently to standard. This is because the seller has most likely copied the US spec chip which only has the US region map modified. The EU map will remain standard meaning the car will perform no differently.

This appears to be the case with the EAT chip in my car. It had a standard map for my region with all the good stuff only on the US map which my car doesn't read! This would explain the dramatic difference I felt after I fitted the Powerchip.

I have since had the car back to Powerchip to have the chip updated and a standard rev limit reinstated. I am hoping to get some hard data in the near future, but for now cannot tell you how well my car runs on the Powerchip.

At the risk of this appearing like an advertisement I highly recommend the Powerchip to anyone looking to upgrade their ECU chip. The performance of the car is 2nd to none and the service they provided me was exceptional :thumbsup:.
 

·
Registered
Joined
·
706 Posts
Discussion Starter #17
At least it sounds like Powerchip understand the meaning of the words "customer service".

Mark had me copy the chip that was in the car when I bought it and email it to him. (It cost me $100 for Peak Performance to copy it - I haven't been back there since)

That file went to him in mid July 2007. I've had nothing but false promises up until early January and unanswered emails since.

How do these people sleep at night?
 

·
Registered
Joined
·
706 Posts
Discussion Starter #18 (Edited)
How's this for a history -

Paid for 2 chips (standard and performance) July 10 2006

Finally got them September 2006 (separate deliveries, lots of excuses)

Both defective - max revs 1950 until oil hits 60C

Some of the false promises since:

"I'll look for the original software for it". 13 April 2007

"I'll keep studying this in the next while, and may send you a stock 412 version to try out" 7 July 2007

"My plan was to make a chip with my maps overlaid into the file you sent but I could not do that yet." 21 July 2007<O:p

"I will try to do this in about a week to 10 days or so." 23 July 2007


<O:p"as soon as I return from <?xml:namespace prefix = st1 ns = "urn:schemas-microsoft-com
<ST1:pOttawa</ST1:place I'</st1:City>ll overlay the maps onto your file." 13 September 2007
</O:p
<O:p</O:p
"I arrived back from <st1:City w:st="on"><ST1:pOttawa </ST1:p</st1:City>this evening. I'll attempt to get this done before my 10 day trip to BC next Saturday." 16 September 2007</O:p
<O:p</O:p
<O:p"I have thought about the probalem alot and have a pretty good explaination for it. I'll email with further info this evening" 11 December 2007
</O:p<O:p</O:p
<O:p<O:p"sorry I had forgotten that the stalling was your main problem. I'll look for the file you sent, and re-do it based on your file. I've got the week off from Dec 22 to Jan 1, I'll work on it during that time." 18 December 2007 NOTE - it isn't stalling - the fuel or spark is being cut and the engine won't fire again until revs drop to just above idle. VERY DANGEROUS


"Happy New Year. I spend quite a bit of time on it, and hope to finish it this weekend. I'll have it out to you early next week." 4 Jan 2008


No emails answered since.


Is this guy on the same planet as the rest of us?


Ian

</O:p>
</O:p></O:p>
 

·
Registered
Joined
·
161 Posts
Ian,

please also allow me to tell everyone reading this thread that based on the numbers supplied from your DME when you ordered the chip, I sent exactly the software version and variant code that was indicated on your DME's cover. The file you sent me was a completely different software version, and also had a different variant code which did not match your DME. I'm thinking that someone has possibly changed the coding plug in your car.

And regarding the maps for North America, Australia and Europe, they should all be the same. Two of the 4 variant codes point to the same physical map in memory. One other map is for cars with no O2 sensor, and the other is a lower octane map.

Mark
 
1 - 20 of 39 Posts
Top