BMW M5 Forum and M6 Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
5,353 Posts
Discussion Starter · #1 ·
I was driving along today, trying to place a call with my cell phone via bluetooth. Instead of the call going through, I got an odd buzzing sound, so I clicked the right knob to terminate the call.

Then the system went wild! The nav display started blinking on and off, then the nav screen door that flips to reveal the cassette door behind it started opening and closing on its own. The stereo would go on and then off, like it does when you place a call. The phone then called the number I was trying to dial, all by itself. I briefly got a connection, then it muted or disconnected the call because I suddenly got my stereo music again. I tried turning off the radio, and then it went back on by itself. I turned off the cell phone but the nav door kept opening and closing. :eek:oohhh:

I was in the mountains and didn't want to pull over or fiddle with it, else I crash. It was more than a bit distracting to have the nav door opening and closing every few seconds while I negotiated sharp turns and traffic.

I finally got into a town, where I briefly shut off the car and restarted it. No joy. The nav door kept opening and closing. I pulled into a gas station so I could make my call with the car turned off for several minutes while I spoke on the phone. :blabla:

Afterwards, I restarted the car and everything was normal! Anyone else have this happen or have any guess as to what caused this? :dunno:
 

·
Registered
Joined
·
12,393 Posts
Couple of reports on this... no fix. I had the nav replaced under warranty, only because I shot a phone video of it!

Search for 'nav freaking out' or 'nuts' or similar.

A
 

·
Registered
Joined
·
6,520 Posts
The short version is that something on your IBus is sending all sorts of commands it shouldn't be sending.

I've not heard of the issue before, but if Ard says it is Nav related then I'd start there!

d-
 

·
Registered
Joined
·
484 Posts
I was driving along today, trying to place a call with my cell phone via bluetooth. Instead of the call going through, I got an odd buzzing sound, so I clicked the right knob to terminate the call.

Then the system went wild! The nav display started blinking on and off, then the nav screen door that flips to reveal the cassette door behind it started opening and closing on its own. The stereo would go on and then off, like it does when you place a call. The phone then called the number I was trying to dial, all by itself. I briefly got a connection, then it muted or disconnected the call because I suddenly got my stereo music again. I tried turning off the radio, and then it went back on by itself. I turned off the cell phone but the nav door kept opening and closing. :eek:oohhh:
Did the number you were calling contain '666' ??? :pedro:
 

·
Registered
Joined
·
327 Posts
maybe your nav system got a critical security patch from Microsoft by mistake. Just hit CTL-ALT-DEL.
 

·
Registered
Joined
·
5,353 Posts
Discussion Starter · #8 ·
I was calling my home number! So I can't not call it again and no, it doesn't have the demonic digits (triple 6) in it. I'm sure there were odd signals sent on the I-bus somehow, which were close enough to something that sounded like a command that it confused the system. I'm guessing it was something sent in the bluetooth handshaking that did it. Bluetooth IMHO is still the worst "standard" in the world!
 

·
Registered
Joined
·
5,353 Posts
Discussion Starter · #11 · (Edited)
A week back I was driving on the highway when suddenly the Nav/TV freaks out! The display starts to flicker and the motordriven display starts to open and close, sometimes it even changed it's mind halfways.

It was like it literally had it's own mind and I couldn't get control over it. Tried to turn it off, but that didn't work. It kept doing this for severall minutes until I could get off the highway and turn off the car. But when I turned the ignition, it still kept "freaking out". Tried to turn the ignition off and on again, but no change.

Went to the dealer, had to wait for 45 min, to speak to the one guy that might know something about this. While waiting I decided to go out to my car and see if the problem was still there. Turned the ignition and now the Nav worked like it's supposed to! No flickering, no display open/closing! The bug was gone!
That's exactly what happened to me! :eek:oohhh:

So after they swapped in the new nav unit, did the problem ever reoccur?
 

·
Registered
Joined
·
7,578 Posts
I had something similar happen about 3 years ago now. No Bluetooth here but I did already have the Ipod/Dice in place. I pulled over and called my Tech who told me to disconnect the battery for 10 min and then restart. I did that, and it didn't act crazy any longer. This "problem" has never returned since then.
 

·
Registered
Joined
·
142 Posts
I had the same problem a few weeks ago when I drove mine. It just started blinking while the radio was playing. It was like it kept rebooting. It hasn't done it since that day. Who knows.:confused:
 

·
Registered
Joined
·
49 Posts
This just happened to me today. My screen was blinking while the panel was opening and closing, it was really annoying. The radio was not responding to any off/on commands, etc...

Since I had a 30 minute drive home, I kept trying stuff, like unplugging the Nav system. Then, I went to the back right side of the trunk and removing and replacing two of the fuses for the radio, with a pause in between. I believe it was fuses 56 and 58. Anyhow, it stopped spazzing out, and I made it home without another incident.

Hope that helps!
 
1 - 14 of 14 Posts
Top