BMW M5 Forum and M6 Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Seems like there are some reports of this on the e46 but I couldn't find anything about it happening on the e39.

After fixing my pixels in my cluster I reconnected the battery and noticed the cruise control light was on. I think the only strange thing I might have done was disconnect the light switch with the battery still connected (caused the lights to come on) but I don't think this should have had any effect. Any other plugging / unplugging was done with the battery disconnected.

The light will go away after 1-2 seconds in either key position 1 or key position 2. If I go directly to KP2 and hit the cruise control button quickly it will go away also.

It does go out eventually if I leave the car sitting (haven't timed it yet), but it stays lit longer than the interior lights or nav monitor. Opening the door causes it to come on again.

Speedometer Vehicle Odometer Tachometer Light
 

·
Registered
Joined
·
33 Posts
Yet another strange E39 electronic gremlin. I doubt your pulling the connector to the light switch while powered did anything harmful. Does the cruise control operate normally?

I recall years ago reading about a hidden menu/resets accessed thru the cluster on another forum but I did a quick search and found this earlier post- you may have already gone there… Active cruise control light on after test 2.
I believe all of it can be accessed thru INPA as well..??..
Which place did the renew on the pixels? Maybe they can help guide you thru this rabbit hole.
 
1 - 2 of 2 Posts
Top