BMW M5 Forum and M6 Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
301 Posts
Discussion Starter #1 (Edited)
Had this message pop up when I pulled into first at my mailbox. Turned off the car, code went away, drove around the block, came back, same thing happened again. Car seems fine, but not sure what it could be. :(

Orange brake light on, start off assistance disabled. :/
 

·
Registered
Joined
·
354 Posts
could be the steering angle sensor. google it. i have the same codes. i've done the diy of cleaning the sensor with no luck. next i'll go get an alignment before i go out and buy a new sensor. good luck.
 

·
Registered
Joined
·
301 Posts
Discussion Starter #3
I read it could be actuators too?
 

·
Registered
Joined
·
301 Posts
Discussion Starter #5
yes i'm seeing that also. these are some common problems. i'm wondering if that's my issue also.
Thanks for he heads up. Gonna try the steering angle fix first. Power doesn't seem down at all.
 

·
Registered
Joined
·
301 Posts
Discussion Starter #7
Another symptom of steering angle sensor failure: the turn signals do not clear after completing the turn :wroom:
Is that always the case, or just a possible hint?
 

·
Registered
Joined
·
354 Posts
I've had my cars code read and it mentions throttle actuator and steering angle sensor but the mechanic is saying replace the steering angle sensor first bc I my car isnt in limp mode to need the throttle actuator yet.

Rule no. 1 of E60 ownership. Don't replace anything without readin the codes first. Even if it's only the P codes at AutoZone.
 

·
Registered
Joined
·
301 Posts
Discussion Starter #12
Drove it this morning. No codes whatsoever. Even got it up to 8,500 RPM.
 

·
Registered
Joined
·
29 Posts
My errors went away after an alignment. So far so good. My exact errors on iDrive were:

- DSC Malfunction
- Electronic start assistant inactive

I DID NOT have reduced power or EDC errors and the car drove normally.

The errors would sometimes go away shortly after a restart. When that happened the car would briefñy show a DBC error before everything cleared.
 

·
Registered
Joined
·
29 Posts
Update:

My errors came back after a while. On and off for months until 3 months ago the pump finally crapped out. I had the pump removed and sent to ECUtesting in the UK for a rebuild. Part came back, installed back in - problem solved.
 
1 - 15 of 15 Posts
Top