BMW M5 Forum and M6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
991 Posts
Discussion Starter · #1 ·
Like the title states,

Can't seem to figure out why the cruise control will not engage. I can turn the unit on and off (green light illuminates on the dash with the push of the steering wheel button). But, I can't seem to get it to work.

What do you press to engage it? The power button, and then... the +? I'm lost. It's probably just broken, but in case it's the loose nut behind the wheel, how is it supposed to work?

Also, assuming it is broke (since it's a BMW), any guesses on what it sounds like is wrong?
 

·
Registered
Joined
·
12,965 Posts
It's been a while since I used it, but + should set it. But if I recall, one push merely turns it on, the next push sets it. So try pushing the "on" button a second time and then hit the + button.

If that doesn't work, then check the switches. There should be one on the brake pedal and one on the clutch, which disengage the unit. One may be out of adjustment, so the car "thinks" you are pressing the brake or clutch, either one of which will disengage the cruise control, while leaving it turned on.

Regards,
Jerry
 

·
Registered
Joined
·
1,355 Posts
Couple of things.
There are 2 switches on your transmission, 1 is for reverse lights the other is a gear indicator switch, make sure both are plugged in and have not dropped out. Also make sure the the right one is plugged into the right switch, the connectors are the same so either cable will plug into it. It the gear indicator switch is not plugged in right cruise will not work as the system does not know which gear the car is in.
 
1 - 4 of 4 Posts
Top