BMW M5 Forum and M6 Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
For what's its worth, I got one of these devices last year when Bimmerworld put them on sale, and I wanted a unit that would also do graphing of the engine performance if I wanted to do more diagnostics. I put it in the garage and forgot about it until this week when the SES light kicked on. This PM I pulled the reader out, connected it, and turned on the reader, only to have it fail to connect and read. This occurred regardless of which switch position I used - Off, Position 1, 2 or running, no joy on all of them. I remembered there was a previous post on this, and spent nearly 45 minutes digging thru the website posting without success, and went back to messing with the reader to see if I could get it to work. Some of the previous messages indicated that MY00 like mine had trouble getting ODB outputs, but some of that seemed to be due to CA smog inspection tests - NA here since I'm in MD.

I got lucky - it turns out you can get the reader to do its thing, but only if if you plug the reader in when the vehicle is switched off and wait until the reader is powered up. Then, punch the "diagnose" button and wait for about 3 seconds as it starts the communications protocol, which previously had taken about 10 seconds and failed. At about 3 seconds as the reader is going thru it's read routine, if you twist the key to position 2, the car's computer will close the link, respond, and give you the right codes. More later when I diagnose what the codes are.

Rich
 
1 - 1 of 1 Posts
Top