BMW M5 Forum and M6 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
168 Posts
Discussion Starter #1
Hello. I get this message about 2 out of 12 pulls, usaually at higher speeds. Car goes into limpmode, engine Fault etc. It seems to have something to do with the idle actuators, is it possible to clean them? I have changed throttle actuators before so I know the idle actuators are next to them. Its strange that I dont get ao specific code for just one of the idle actuators.
I did a test on the actuators and they
passed all but one on both sides. It didnt pass "integral duty factor, ramp 2 not OK"
Same Time as this but only on Carly, not on DIS I get "engine torque is not adjustable CAN"

I also sometimes do get CDC1, CDC2, CDC3. SMG CAN message like 1 out of 12 pulls.

Im thankful for inputs. :)
 

·
Registered
Joined
·
7,044 Posts
Hello Mate!

Below are the details of the CD8B fault code.

CD8B:
Bus off idling speed control valve /SMG CAN
Error will cause a warning light

It might be your speed/acceleration sensor in the SMG or the electrical cables connecting to it. Check the below thread.

http://www.m5board.com/vbulletin/e60-m5-e61-m5-touring-discussion/550594-smg-iii-gear-sensor-strip-rebuild.html

However, I am not sure if this is actually the problem you are facing.

My advice is to get the car checked by a dealer or a reliable independent workshop.

Good Luck!
 

·
Registered
Joined
·
168 Posts
Discussion Starter #3
Thank you but I did already know that. Why should I take it to the dealer? I dont need to take it to a dealer since I have DIS myself, a lift and all the tools myself. The dealer would change my idle actuators as that is what the software will tell them.

I know you are trying to help and I appreciate but I will NEVER take it to the dealer. I think I will fix it better than them. And thats also why Im asking if the idle actuators need cleaning etc? :)

Its easier and saves me time to ask here than to troubleshoot and wasting money. Regards
 

·
Registered
Joined
·
7,044 Posts
Very good :cheers: Its best if you can do it yourself.

For the throttle actuators, its mostly the plastic gears that wear out or the electronic circuit gets shot. If it is just contamination on the electronic connection, cleaning should fix that. If you can replace the plastic gears with aluminium ones, it should improve the reliability a lot.

You are correct about the gear sensor wiring. Its very difficult to tell by touching the harness. Mostly the wiring gets shot where it connects to the sensor because of the heat.

Hope this helps. Good Luck!
 

·
Registered
Joined
·
168 Posts
Discussion Starter #8
More pleassure doing it yourself too :)

Thanks. The throttle actuators are not the same as the idle Actuators, they do sit next to each other but different parts. Otherwise throttle actuators are pretty common but they gives a specific code.

My codes started coming after I changed to Evolve software....

Btw hasan I have read that you are using your car properly. Are you using 245/40/19 up front as well as 275/35/19 in the rear? Im thinking of going with a 275 in the rear and when its time to change the front go for a 245 there. Stock sizes are too wide for the rims...

Regards
 

·
Registered
Joined
·
7,044 Posts
No doubt, doing it yourself is the best :cheers:

If your codes started after switching to evolve software, maybe you should try with the stock software if you still get the codes.

Indeed! I am using 245 front and 275 rear. I agree with you that the stock tyre sizes are too wide for the width of the wheels. 245 and 275 provide much better cornering stability and are a bit lighter as well. I also run -2.0 to -2.5 camber which makes a huge difference.
 

·
Registered
Joined
·
1 Posts
I have exact same issue, same fault codes and also more importantly same symptoms

Limp mode at higher speeds, hard acceleration. What was the fix for this in the end?

Regards jason
 

·
Registered
Joined
·
2 Posts
Hello, I have the same problem, the error codes are identical, are there any solutions to this problem? In cutoff 7000 errors fly out
 

·
Registered
Joined
·
295 Posts
Hello, I have the same problem, the error codes are identical, are there any solutions to this problem? In cutoff 7000 errors fly out
What codes are you getting?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
[QUOTE = "AbdulM, сообщение: 7590154, участник: 239745"]
Какие коды вы получаете?


Отправлено с моего iPhone с помощью Tapatalk
[/ QUOTE]

Вылечено путем фиксации разъема клапана холостого хода
коды
CD8B:
Шина от клапана управления скоростью холостого хода
CDC1, CDC2, CDC3. SMG МОЖЕТ сообщение
 

·
Registered
Joined
·
79 Posts
Idle Actuators. Had same codes, change them both, no cleaning or whatsoever would bring them back. Invest now, before they come to 2k each.
 
1 - 14 of 14 Posts
Top