BMW M5 Forum and M6 Forums banner

1 - 20 of 27 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Hey guys,

Just recently on my 03 beast I noticed when I opened my door to start the car the interior lights didn't come on. Upon destination I was shocked to find that my remote had stopped locking the car as well. I figured it might have been a dead battery in the key, so I tried using my brand new spare to no avail. I also noticed my central locking button isn't working anymore.

Has anyone experienced anything like this before? I hope its a simple problem, otherwise it seems like it will be $$$ to fix.

Regards,
Sin
 

·
Registered
Joined
·
12,952 Posts
Hey guys,

Just recently on my 03 beast I noticed when I opened my door to start the car the interior lights didn't come on. Upon destination I was shocked to find that my remote had stopped locking the car as well. I figured it might have been a dead battery in the key, so I tried using my brand new spare to no avail. I also noticed my central locking button isn't working anymore.

Has anyone experienced anything like this before? I hope its a simple problem, otherwise it seems like it will be $$$ to fix.

Regards,
Sin

From memory, see if you gas door locks when you lock the car. If not, you need to replace the part ( I think it is an actuator, someone here will know).
All should be good after that if that is the problem.
Regards,
Jerry
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
Jerry,

just ran down to the garage(man its freezing outside) and the gas door does lock when I manually lock the doors.

Could it be a fuse or something else related to central locking?
 

·
Registered
Joined
·
12,952 Posts
Jerry,

just ran down to the garage(man its freezing outside) and the gas door does lock when I manually lock the doors.

Could it be a fuse or something else related to central locking?
If both keys don't work ( they get charged by using them, so you should switch keys every once in a while), then fuse is a good guess. Check the glovebox for fuses. Anything else not working?
Regards,
Jerry
 

·
Registered
Joined
·
37 Posts
Discussion Starter #5
The individual interior lights will turn on with the button, but the middle one will not.

Everything not working is related to locking/unlocking the car.

Note-the trunk still unlocks with the the remote.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #7
Battery is about 2 months old, brand new from BMW. Also, the problem started before the battery was replaced, and is still ongoing.

Sin
 

·
Registered
Joined
·
7 Posts
Deja Vu

This just happened to me a few months ago, and it was the main body module that had failed. It was about $600 to fix it at the dealer. I had the exact symtoms you do, and my alarm would go off sometimes for no reason.
 

·
Registered
Joined
·
219 Posts
innosince, Take a very very carful look at your fuses. I had the same problem and turned out to be a blown fuse. Unless you pull it out and meter it, it looked good. Now I have and spare gas locking module. Good luck, Smiles
 

·
Registered
Joined
·
567 Posts
I agree, sounds like a failure of the controller that 'operates' the locking system.
BUT, check the fuses first! The Keep It Simple Stupid rule. Or you may be doing this: ouich
 

·
Registered
Joined
·
37 Posts
Discussion Starter #11 (Edited)
Thank you for all your replies guys. Lets hope its not that locking module. I will check my fuses, and hope that fixes the problem.


On a side note- My car also had a problem with the alarm going off randomly, but only seemed to do so on warmer days (75+) I've not had any problem since the weather has cooled down. Maybe all of this could be pointing to that controller?

Heres to hoping repairs are cheap cherrsagai

Sin
 

·
Moderator
Joined
·
8,369 Posts
If all your fuses are good - You may want to try a complete system reset.

Remove the negative battery cable first, then remove the positive. Either leave the cables unplugged for about 5 minutes or touch the two cables together hard quickly.

Then reinstall battery cables - positive terminal first, then negative. You will need to reset your onboard clock after this, and so as FM memory stations.

See if that resets or fixes your lock ECU.
 

·
Registered
Joined
·
5 Posts
just wondering

innoSINce, have you made any progress with this? I'm having all of the exact same problems: remote key functionality not working (except for the trunk); interior dome light not working, central locking button not working; alarm randomly going off...started happening when i replaced my battery (and radiator)...
 

·
Registered
Joined
·
936 Posts
Sounds like you need to do recode the key;

I recoded my key the some time back as I had a similar problem you just described.

Open the car, get in, close the door.
Put the key into the ignition and turn to position 2.
Remove the key.
Within 5 seconds of removing press and hold the un-lock button and at the same time press lock 3 times.
Release the un-lock button.
The doors should then all lock and un-lock - the key is now coded.

This worked for me (on the second attempt).

Best of luck,

Richie.
 

·
Registered
Joined
·
5 Posts
i just tried recoding the keys (again - i did actually try this awhile ago)...to no avail... noteworthy (i think) though is the that when I hold down the unlock buttons on either of my keys it changes the seat/memory/side-mirrors (so that's sort of working i guess).

hope i'm just doing something wrong, but I don't think so...:confused:

i'm going to try and replace the central locking fuses, but i don't think that's the problem either since when i remove them i can't lock the doors with the key in the door but i can when the fuses are present.

i really want this to be a key recoding problem...trust me!:confused2

Thanks to everyone for their suggestions nonetheless! i'll keep at at and keep you posted.
 

·
Registered
Joined
·
936 Posts
i just tried recoding the keys (again - i did actually try this awhile ago)...to no avail... noteworthy (i think) though is the that when I hold down the unlock buttons on either of my keys it changes the seat/memory/side-mirrors (so that's sort of working i guess).

hope i'm just doing something wrong, but I don't think so...:confused:

i'm going to try and replace the central locking fuses, but i don't think that's the problem either since when i remove them i can't lock the doors with the key in the door but i can when the fuses are present.

i really want this to be a key recoding problem...trust me!:confused2

Thanks to everyone for their suggestions nonetheless! i'll keep at at and keep you posted.
I thought that when you hold the unlock button down it would open the windows and sunroof - not adjust the seats etc??

It does sound like a key problem - rather than the car, if you know what I mean?

I know a guy very well in BMW here in Dublin, I'll mention it to him and see what he says - may be different as you are in Canada!

Richie.
 

·
Registered
Joined
·
5 Posts
first, thanks for pointing out the error in my post! just to clarify...(since it was 5 am here and i wasn't really thinking straight):

the seat memory adjusting does not happen when i hold down the unlock key, however, i did notice (even before this issue arose) that some soft of key button combination would activate the appropriate memory for that key. i experienced this early this morning and described it incorrectly.

In any case, regardless of that I have confirmed that the key coding is working on some level. That is to say that I have coded Key 1 without coding Key 2 - which made the remote trunk button stop working on Key 2. As soon as I recoded Key 2, the trunk remote button worked again...

going to try replacing fuses tongiht...more 2 come!
 

·
Registered
Joined
·
5 Posts
ok not the fuses (which is what i suspected)...thanks for taking the time to look into it Richie...much appreciated.
 

·
Registered
Joined
·
36 Posts
Was there ever a resolution to this problem because my 03 beast has developed exactly the same problem after the battery whent flat.....
 
1 - 20 of 27 Posts
Top