BMW M5 Forum and M6 Forums banner

1 - 20 of 27 Posts

·
Registered
Joined
·
1,306 Posts
Discussion Starter #1
I have this buzz from the center dash area under acceleration between 3 and 4K RPM. It's pretty minor but still bugs me. I did some searching here and it appears that others have had this issue. However, I wasn't able to find how it was resolved.

I have identified this buzz to be coming from the center dash area and not the cluster or the signal/wiper stalks that others have reported buzzing at some point. I did also find a service bulletin describing an issue with the bolts connecting the strut brace to the firewall. However, that was more of a rattling noise that people experienced.

So, has anyone here been able to solve their center dash buzzing around that RPM range?:dunno:
 

·
Registered
Joined
·
79 Posts
Unfortunately I have the same problem in my 08. Mine only happens under moderate to hard acceleration (not slow). I've had it since day 1 ( 6 plus years) and just gave up trying to locate/fix it. Hope you find the problem.
 

·
Registered
Joined
·
1,306 Posts
Discussion Starter #3 (Edited)
Unfortunately I have the same problem in my 08. Mine only happens under moderate to hard acceleration (not slow). I've had it since day 1 ( 6 plus years) and just gave up trying to locate/fix it. Hope you find the problem.
Bummer. Did you ever take the car in to the dealer while it was under warranty and have them look at it? What did they think?
 

·
Registered
Joined
·
19 Posts
Is it from the center speaker cover? Mine starts to buzz on occasion. You can put your hand on it when it starts doing it and see if it stops. I think the only cure is to pry it up and put tape around the clips or place pieces of foam between it and the dash.
 

·
Registered
Joined
·
94 Posts
I noticed a slight buzz under light acceleration and found it was coming from one of the buttons on the indicator stalk. Didn't really bother fixing it as when it started to buzz I just tapped it lightly and it went away
 

·
Registered
Joined
·
79 Posts
I did ask the dealer to check it. They claimed to not hear it and I never bothered to follow up. I'm pretty sure its not the speaker. I thought it was coming from the HUD but could not track it down.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1,306 Posts
Discussion Starter #8 (Edited)
I did some more investigating today. Definitely not the strut brace bolts, indicator/wiper stalks, or center speaker cover. It sounds like it's coming from right behind the iDrive screen...
 

·
Registered
Joined
·
129 Posts
Guys, I also have the same issue and from my research,it appears that it's the vanos unit need bleeding. My car is at the dealer currently getting the smg unit replaced. I will be test driving it with the tech tomorrow to identify the noise. I will keep everyone updated on diagnoses, cost, etc.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1,306 Posts
Discussion Starter #11
Guys, I also have the same issue and from my research,it appears that it's the vanos unit need bleeding. My car is at the dealer currently getting the smg unit replaced. I will be test driving it with the tech tomorrow to identify the noise. I will keep everyone updated on diagnoses, cost, etc.


Sent from AutoGuide.com Free App
This is definitely NOT the issue I am describing.
 

·
Registered
Joined
·
1,306 Posts
Discussion Starter #12
Bumping this again. Still can't find it. It's definitely buzzing from somewhere behind the effin iDrive screen inside the dash. Center speaker and cover are both not it.

How hard is it to remove the screen?
 

·
Registered
Joined
·
1,306 Posts
Discussion Starter #15
I removed the iDrive screen, took a spin, and buzzing is gone! Now to figure out why the screen itself is buzzing.
 

·
Registered
Joined
·
1,306 Posts
Discussion Starter #16
Problem solved!

Removed the iDrive screen. Put one layer of electrical tape around the inner edge of the screen. Reinstalled it and no more buzzing! So freaking happy as I was ready to buy a new screen because it drove me nuts.
 

·
Registered
Joined
·
5 Posts
Congrats, now can u figure out the rattle at 3-4k coming from the firewall area during acceleration?
This. My 08 has this issue. I'd try the nav fix, but my noise certainly sounds firewall forward. Have had the noise since around 22k miles (28k now). 3-4k rpm under mild/hard'ish acceleration.
 

·
Registered
Joined
·
1,306 Posts
Discussion Starter #20
Congrats, now can u figure out the rattle at 3-4k coming from the firewall area during acceleration?
Well, thankfully, my car is silent now besides the glorious V10 music, lol.

Did you try checking the upper strut bar bolts are tight? There are two right under the middle of the windshield.
 
1 - 20 of 27 Posts
Top