BMW M5 Forum and M6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Buddy of mine is a Tech at a dealer, so when I brought it in for the 15k service a few weeks back he asked me if I wanted him to perform the upgrade... I remember reading some posts on here complaining about a "loss of power" feeling after the upgrade was performed, so I told him I'd pass on it.

Today I went to AAA to pick up my tags and they mentioned that the upgrade was necessary in order for me to renew my registration...

Has this happened to anyone else?
 

·
Registered
Joined
·
4,404 Posts
I am not sure the basis -- probably emissin regs -- but in any event, I think the concern about losing power after a software upgrade turned out to by myth. Avery's car actually had an issue with the header install that was the source of his issues. Nobody else had dyno supported loss of power.
 

·
Registered
Joined
·
3,244 Posts
Today I went to AAA to pick up my tags and they mentioned that the upgrade was necessary in order for me to renew my registration...
A few questions for you, since I only visit the dealer when forced ouich
Have you received anything from BMW or the DMV about required service?
What model year (or build month) is your M5?
What is you current software version?

My 2007 M6 was build in 9/2006 and has the original software (V24?).
 

·
Registered
Joined
·
2,881 Posts
TCM might want to chime in here...
 

·
Registered
Joined
·
655 Posts
how would they even know if you do or do not have the upgrade? this doesnt make sense.
 
1 - 6 of 6 Posts
Top