BMW M5 Forum and M6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter · #1 ·
Hi,

For the past week, I have been getting a "malfunction brake light" warning message on my '08 M5.

It comes on for a few, then when I turn the car off, it goes away (sometimes).

I popped open the tail light in the trunk and found that all bulbs were ok.


I have to leave on a business trip in the middle of this week and my bmw service dealer is atrocious with regards to them getting the car back to me in a reasonable time frame.


Has this ever happened to you guys and if so, how did you fix it? Could it be some sort of malfunctioning sensor, or could it be a defective CPU unit?

I was also driving the car this morning and was in "M" mode, and for whatever reason, the car took itself out of "M" mode all of a sudden.
 

·
Registered
Joined
·
160 Posts
Discussion Starter · #2 ·
Oh, I might also mention:

It's always the right brake light, and if I happen to use my right turn signal indicator, I get a error message as well (and then the blinker clicks really fast). Then if I'm in reverse, I get a "reverse light" warning message as well.
 

·
Registered
Joined
·
4,404 Posts
Do you have stock tails? If you are in the US and have upgraded to the LCI tails, that could be the problem.
 

·
Registered
Joined
·
160 Posts
Discussion Starter · #4 ·
Hi,

My taillights are lci, but they are stock....thats how they came from bmw.

Am wondering if there could be a quick fix like a fuse or something?
 

·
Registered
Joined
·
3,246 Posts
Am wondering if there could be a quick fix like a fuse or something?
Several different bulb errors on one assembly points toward a ground problem.
Check the ground (and all contacts) on the connector to the taillight.
Try to trace the ground wire, although it will likely be bundled into the wiring harness.
All the various ground wires in the trunk will connect to the chassis at a common point.
 

·
Registered
Joined
·
172 Posts
I know that I am resurrecting a really old thread, but want to mention the same error (and hopefully it might help somebody in the future):
Brake right malfunction came on today. Visually all bulbs look good. I turned the lights on and since one of the bulbs was on, I tried all 3 7506L from the rear. Surprisingly, one of the bulbs did not work (looks OK visually!!!). May be one of the bulbs has a problem which can not be seen visually
Tried to get it at autozone - no luck... Will drive to the dealership tomorrow...
 

·
Registered
Joined
·
793 Posts
I had this problem on mine. The brake like would go out, then the whole light assembly would throw errors.
I removed the whole bulb assembly and noticed that the ground was brunt and a little melted. Ended up getting a new light holder and plug.
 

·
Registered
Joined
·
144 Posts
Similar problem on my 335 as well. The last time it was a reverse light out but as soon as I pulled the bracket holding all the lights from the housing the light came back on. Weird. I've replaced a ton of bulbs over the past few years and am going to replace the bracket this week. Hopefully that fixes it.


Sent from AutoGuide.com Free App
 
1 - 8 of 8 Posts
Top