BMW M5 Forum and M6 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Some times my setup crackles on every call and then drops my connection. Other times it is perfect. What on earth can be going on?
I have deleted and paired the phone 3 times now. This is not acceptable on this high priced car. I really need to get this sorted out. Anyone have any ideas what it might be? I have tried moving the phone around during the crackling and it resolves nothing.
 

·
Registered
Joined
·
2,881 Posts
I have no problems with my iphone? you got the 8g or 16g?
 

·
Registered
Joined
·
474 Posts
Mine has been working fine on my 07 M5 since i got it back in June 07, although for the last few days I am experiencing a lot of crackling and cannot complete the calls. I have no idea what is going on, I was planning to call my SA and have the car checked.
 

·
Registered
Joined
·
240 Posts
Go to the settings on your iphone and turn wifi off. And all your problems will be solved.
 
  • Like
Reactions: scoopz

·
Moderator Emeritus
Joined
·
915 Posts
Go to the settings on your iphone and turn wifi off. And all your problems will be solved.
+1
It's hit and miss with me, sometimes it works, sometimes it cuts out but when it does cut out, if I jump into the settings menu and turn wifi off quickly, the call comes back instantly and never drops again.
I notice it drops more often than not when I've just left my house or office when the phone was on wifi and I guess the phone is searching for the wifi it suddenly lost or a new wifi network whilst simultaneously sync'ing contacts to the iDrive via b/tooth and this leads to a bit of an overload.
I generally get in the habit of turning wifi off when I'm out and about in the car.
 

·
Registered
Joined
·
994 Posts
Some times my setup crackles on every call and then drops my connection. Other times it is perfect. What on earth can be going on?
I have deleted and paired the phone 3 times now. This is not acceptable on this high priced car. .
My Bluetooth works perfectly so I wouldn't blame the car. Hope you find the solution. Could well be WiFi as others have suggested.

I have a Blackberry 8820 but never use the WiFi as I find it never hold its connection wherever I'm at.
 

·
Registered
Joined
·
469 Posts
The problem is "Apple" get a pc based phone :)
 

·
Registered
Joined
·
1,425 Posts
what version of software on the iPhone?
I have 1.1.3 and have no issues with my 06. M5 and I never turn off wifi.
 

·
Registered
Joined
·
1,372 Posts
I've experienced the issue you speak of before. I had WiFi turned on at the time, and once I turned it off all was perfect.
 

·
Registered
Joined
·
1,425 Posts
I've experienced the issue you speak of before. I had WiFi turned on at the time, and once I turned it off all was perfect.
Have you had it since upgrading to 1.1.3 or higher?

Maybe you need someone technical to help you out? :7:

Seriously though, I'm thinking it was a 1.1.2 and older issue... could be wrong. My sample set is just me, my phone, and my car... :)
 

·
Registered
Joined
·
316 Posts
Its a known issue with Apple's iPhone and BMW. Both have proposed the solution of turning Wifi 'off'. Unacceptable to toggle on and off when stepping in and out of the car, I would have rather had a plug in instead of bluetooth. What's the point if its not convenient using wireless technology. With my system, the cackling disappears after a few seconds into the conversation so I pretend to say Hello? Hello? a few times until I can hear the other person... And yes, I dont make business calls in my car because of this very issue. Hopefully the new 3G iPhone will take care of this annoying issue once and for all and not need Wifi connection for Internet, GoogleMaps, Email, etc.
 

·
Moderator Emeritus
Joined
·
915 Posts
Have you had it since upgrading to 1.1.3 or higher?
......
I'm thinking it was a 1.1.2 and older issue...
It's done it for me with 1.1.2, 1.1.3 and the recent 1.1.4 however my car is a Dec 2005 build and the iPhone is only supposed to be compatible with E60's built Aug 2007 onwards.


Even though I am upgraded the iDrive CIP to v27 I have a feeling BMW may have changed the actual hardware bluetooth module for a different one in Aug 2007 hence some have issues and some don't.

Those who are having the iPhone problems, do any of you have a build date AFTER Aug 2007?
 

Attachments

·
Registered
Joined
·
1,372 Posts
It's done it for me with 1.1.2, 1.1.3 and the recent 1.1.4 however my car is a Dec 2005 build and the iPhone is only supposed to be compatible with E60's built Aug 2007 onwards.


Even though I am upgraded the iDrive CIP to v27 I have a feeling BMW may have changed the actual hardware bluetooth module for a different one in Aug 2007 hence some have issues and some don't.

Those who are having the iPhone problems, do any of you have a build date AFTER Aug 2007?
FWIW, my car is Nov. '05 production on CIP v24. I'm running 1.14 on my phone.
 

·
Registered
Joined
·
67 Posts
Some times my setup crackles on every call and then drops my connection. Other times it is perfect. What on earth can be going on?
I have deleted and paired the phone 3 times now. This is not acceptable on this high priced car. I really need to get this sorted out. Anyone have any ideas what it might be? I have tried moving the phone around during the crackling and it resolves nothing.
well that's what you get for getting an M5. Should have gotten an M6!
 
1 - 14 of 14 Posts
Top