BMW M5 Forum and M6 Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
282 Posts
Discussion Starter #1
I couldn't find a thread for this so figured i would start one. I noticed when i went out started the car the bmw logo didn't appear on the screen and once i started the car the screen showed a blank strip down the left of the screen. Everything seems to be functioning properly. Wondering if this is the screen or a ribbon issue. Sorry if this thread already exists. Thanks for any help with this issue.
 

·
Registered
Joined
·
750 Posts
I agree a pic would help. I've had a few occasions of having various OBC information disappearing from the NAV display. I don't recall if a blank spot or black box appeared. In all cases once the car was shut down a while and restarted all was well. For me it seems to be a random software issue, not ribbon cable issue. In fact I don't recall there are any ribbon cable issues on the Nav display. The non-NAV E39s did rarely have pixel issues like the speedo display can have.
 

·
Registered
Joined
·
6,632 Posts
I agree a pic would help. I've had a few occasions of having various OBC information disappearing from the NAV display. I don't recall if a blank spot or black box appeared. In all cases once the car was shut down a while and restarted all was well. For me it seems to be a random software issue, not ribbon cable issue. In fact I don't recall there are any ribbon cable issues on the Nav display. The non-NAV E39s did rarely have pixel issues like the speedo display can have.
The wide screen monitor has issues with the ribbon cables becoming loose causing display flickering, loss of colours and other poor display issues.

OP, some pictures of the issue would be most helpful.
 

·
Registered
Joined
·
6,632 Posts
Check the ribbon cables behind the monitor. Open the cassette door and reach behind on the right side, while watching the display gently wiggle the two ribbon cables. If the display changes, I would start with cleaning the connections on both sides of the ribbon cables. If this fails check the connections to the navigation computer and the head unit. But the display issue is likely a corruption of the signal to the monitor (ribbon cables loose) or a failing monitor.
 

·
Registered
Joined
·
12,398 Posts
Does it show the same defect no matter what is displayed? Nav map, radio/audio data, on board computer? All the same?
 

·
Registered
Joined
·
282 Posts
Discussion Starter #8
yeah shows the same no matter. i tried moving the ribbon with cassette exposed. no luck. didn't want to start taking anything apart before i asked the forum.
 

·
Registered
Joined
·
6,632 Posts
You might try reaching out to some local members and see if any of them might be willing to participate in an experiment. Swap you head unit with theirs and see if the issue follows the head unit, though I suspect that it will. This will narrow down the location of the fault.

If the fault follows your HU, it is time to open it up.

Start with the ribbon cable connections on both sides (monitor and base) of the HU.
Check and clean the ribbon cables and their friction connectors.
Check the functionality. If it is fixed, reassemble the HU and enjoy, otherwise continue.
Check and clean the connections between the monitor.
Check the functionality. If it is fixed, reassemble the HU and enjoy, otherwise continue.
Probably time for a new monitor. Save yourself a good deal of fiddling around and get one calibrated for the BMW wide screen display. NathanM5 has a thread about this and his experience with a low cost alternative.
 

·
Registered
Joined
·
282 Posts
Discussion Starter #10
well i decided to send my monitor and nav to Jimmy Chen at Alpine sound. he found it to be the screen in the monitor.
i could not have asked for more a quick response: tested it, determined the problem, and fixed it and shipped in the same day.
all that for just 230.00. i would highly recommend him to anyone.
can't wait to get it back and try it out.
thanks to all those for your input.
 

·
Registered
Joined
·
6,632 Posts
thank you for posting the resolution. Could you post a link and or contact information for Jimmy at Alpine?
 

·
Registered
Joined
·
282 Posts
Discussion Starter #13
yeah, that's him. great guy.AGM5 i see in your mods you have rear fogs lights. do you have any pics? where did you get them?
 

·
Registered
Joined
·
6,632 Posts
yeah, that's him. great guy.AGM5 i see in your mods you have rear fogs lights. do you have any pics? where did you get them?
I did it myself. Though, the modification of the bulb sockets is enough of a PITA just buy the euro tails. They are available from Turner.

<TABLE cellSpacing=0 border=0> <TBODY> <TR> <TD class=r00>01</TD> <TD class=r01>LEFT REAR LIGHT, WHITE TURN INDICATOR</TD> <TD class="r00 p1"></TD> <TD class=r01>1</TD> <TD class=r00>09/2000</TD> <TD class=r01> </TD> <TD class=r00 noWrap>63216902527 </TD> <TD class=r01 noWrap align=right>$302.48</TD> <TD class=r00></TD> <TD> <CENTER></CENTER></TD></TR> <TR> <TD class=r10>01</TD> <TD class=r11>RIGHT REAR LIGHT, WHITE TURN INDICATOR</TD> <TD class="r10 p1"></TD> <TD class=r11>1</TD> <TD class=r10>09/2000</TD> <TD class=r11></TD> <TD class=r10 noWrap>63216902528</TD> <TD class=r11 noWrap align=right>$302.48</TD></TR></TBODY></TABLE>

Genuine BMW Left Rear Light, White Turn - 63216902527 - Turner Motorsport
Genuine BMW Right Rear Light, White Turn - 63216902528 - Turner Motorsport

2001 Rear Fog Install Updates

 

·
Registered
Joined
·
733 Posts
well i decided to send my monitor and nav to Jimmy Chen at Alpine sound. he found it to be the screen in the monitor.
i could not have asked for more a quick response: tested it, determined the problem, and fixed it and shipped in the same day.
all that for just 230.00. i would highly recommend him to anyone.
can't wait to get it back and try it out.
thanks to all those for your input.
A wise decision! It certainly beats spending nearly that much plus several hours ruining your system only to end up sending it to Jimmy anyway! :p
 

·
Registered
Joined
·
12,398 Posts
Could someone post contact info- not an ebay ad that will eventually expire! phone, email, etc-(but only if it is a public business number)

Thx
 
1 - 18 of 18 Posts
Top