BMW M5 Forum and M6 Forums banner
1 - 9 of 9 Posts

·
Registered
2007 E60 M5 6spd Interlagos Blue on Black perforated
Joined
·
10 Posts
Discussion Starter · #1 ·
I got the cars off cars and bids 6spd.

Last owner did bearing and actuators in Feb.
And was having issues bank 1 & 2 Exhaust vanos issues. I found oil pressure in the lines

As of now I’ve replaced the Vanos pump, high-pressure line. After bleeding the system a few times I’m still getting a rattle to 1500 RPM and of course codes.
Any thoughts ?
Guessing I’m have some in the vanos lines…


Hood Automotive tire Guitar accessory Gesture Motor vehicle

Computer Personal computer Output device Gadget Font
 

·
Registered
Joined
·
2,869 Posts
Measure the Vanos oil pressure and to each bank, test the quality of the Vanos solenoid, if all good you may need to check Vanos timing especially on the exhaust gear, this engine may have more than a rod bearing replacement and they failed to adjust the exhaust cam gears initial timing, it is different from main camshaft/crankshaft main timing.
Run the Vanos test and show me the results.
 

·
Registered
2007 E60 M5 6spd Interlagos Blue on Black perforated
Joined
·
10 Posts
Discussion Starter · #3 ·
Measure the Vanos oil pressure and to each bank, test the quality of the Vanos solenoid, if all good you may need to check Vanos timing especially on the exhaust gear, this engine may have more than a rod bearing replacement and they failed to adjust the exhaust cam gears initial timing, it is different from main camshaft/crankshaft main timing.
Run the Vanos test and show me the results.
Well I just got it back from a friends shop and the rebuilt pump was only making 150 psi 300 less then when i had a leaking line......
Another pump was installed and so its fine and back to normal!
 

·
Registered
2007 E60 M5 6spd Interlagos Blue on Black perforated
Joined
·
10 Posts
Discussion Starter · #7 ·
Well, my HP line was bad so I knew that..
I went with the 400 rebuild since turning my stock pump was not smooth.
But the pump I got back was not working soooo they overnighted me a another pump which worked fine and not sure what level of rebuild it was on that unit 😅.
all in all cost me 3600 bucks, which was a lot of clean up work from last shop and the last owner. Also switched motor mounts, alternator, ARP rod bolts all new pan hardware times 2, new oil twice
and valve cover gaskets.
 

·
Administrator
Joined
·
4,084 Posts
Well, consider yourself lucky that only the internal vanos line failed. I think you're the second documented case on this board that vanos errors ended up being a failed internal line and not failed rod bearings which = engine rebuild time.
 

·
Registered
2007 E60 M5 6spd Interlagos Blue on Black perforated
Joined
·
10 Posts
Discussion Starter · #9 ·
The bearing were replaced only 800 miles ago and for some reason they didnt swap the line..... or check the pump when they had it all out and when they put the line back in it was rubbing on the block which made the damage to the line happen.... and this was a BMW specialist shop :rolleyes:
 
1 - 9 of 9 Posts
Top