BMW M5 Forum and M6 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey guys, just bought a 2006 M5 from a board member and flew all the way from DC to Tallahassee to drive it home :) Could not be happier.

The car has the AUX jack in the glove box and has had the ModMyNav backup camera installed already. For some reason the AUX jack is not working properly though. I have tried multiple devices and made sure they were all working properly before I plugged them in. Is it possible that that the AUX jack is not hooked up properly? Any ways to trouble shoot this problem?

Thanks guys, and I am glad to be part of the board.
 

·
Registered
Joined
·
3,246 Posts
The ModMyNav module might have added a AV input for a DVD player (or other device), using the AUX input.
Look for and AV input hidden someplace, also check if the ModMyNav has a menu or controller to enable an AUX or AV input.
 

·
Registered
Joined
·
296 Posts
Modmynav are using the AUX for their module as per their FAQ section on their website. So i guess you connect your Ipod or something through that module, not through the ext Aux input.

Why AUX input is required?
Since interface module won't be connected to your stock audio system, you will need to connect audio output from the module to your external audio input (AUX), if you are going to connect any multimedia devices to module other than cameras, then AUX input is a MUST.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Thanks guys, Im going to post some pictures today of what im looking at in hopes that someone here might be able to help. I have tried the ModMyNav Aux Jack and connecting that directly to the iPod and even filtered through all 4 sources to see if it would play... No go.

Pics to come tonight. Thanks for the input so far.
 
1 - 4 of 4 Posts
Top