BMW M5 Forum and M6 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Please let me know what 19s are you running and whether you need spacers in the front to clear the BBK.
If you have BBS RG-R that would be even better. :)

Thank you.
 

·
Registered
Joined
·
977 Posts
Can you not run stock 19's with the 6 piston front 4 piston rear setup? I am thinking of investing in a set myself as I need new rotors and pads.
 

·
Registered
Joined
·
1,354 Posts
Can you not run stock 19's with the 6 piston front 4 piston rear setup? I am thinking of investing in a set myself as I need new rotors and pads.
yes you can run a 6 piston 15" setup (brembo in my case) with stock 19's wheels- the 16" kit will not fit.......
the rear 4 piston setup is totally fine with stock 19's.....
 

·
Registered
Joined
·
932 Posts
Can you not run stock 19's with the 6 piston front 4 piston rear setup? I am thinking of investing in a set myself as I need new rotors and pads.
i have stock 19' with brembo bbk. it fits just fine.
 

Attachments

·
Registered
Joined
·
932 Posts

·
Registered
Joined
·
932 Posts
Sorry for the hijacking, so 380mm front and rear kit will fit inside stock 19's?
Yes, I have 380mm yellow brembo bbk right now. And it fits the stock wheel no problem.:haha:
 
  • Like
Reactions: M5aud

·
Registered
Joined
·
71 Posts
Where would one shop for Brembo Brake Setups? Do they come in Red or is yellow the kit size?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #10
I believe http://www.RaceTechnologies.com/ can probably find a dealer for the Brembo GT kit. I also know that Dinan uses the Brembo GT kit if that's what you want.

Back to the thread. I asked originally because many people said the Brembo BBK is too big to fit in many of the 19 and even some 20s without spacers so I was curious as I run the BBS RG-R and even though BBS website shows it fits the rear but doesn't list it to fit in the front. I don't mind running a little bit of spacers in the front but just wonder if anyone who has had the same/similar setup runs into the same problem before.
 
1 - 10 of 10 Posts
Top