BMW M5 Forum and M6 Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1,934 Posts
Discussion Starter · #1 ·
Hello all

I am getting a new stereo on the car (3.8), its replacing the proff rds with the 6 cd changer in the back.

Anyway, I have taken out the stereo and there is a gaping wire filled hole in the dash now, I also disconnected the amp. Car computer did not complain (for a week), everything is fine, yesterday I changed the language from German to English. Today I start the car and what happens - I get "CHECK CONTROL" - "OWNERS HANDBOOK" and nothing else.

Also when i started the battery seemed really low, I thought the car would not start - but actually did.

Anybody make an informed guess as to what the devil is going on? Will get BMW diagnostic to check it too.


Regards
J
 

·
Registered
Joined
·
2,415 Posts
Check Control message with no other warning means the computer is detecting a miscellaneous or unknown electrical fault.

First thing is to check all the internal toys, lights, buttons, everything to see if anything has stopped working. If not, then usually it`s caused by an unexpected grounding of a cable somewhere.
This can be a minefield to determine where.

You may be in luck, as obviously a loose wire of problem with the installation of the stereo may be an easy fix.

Ivan.



P.S. I`ve had this error for three years, ever since the car was bought, no-one can trace it and everything seems to work. I know there`s a wiring fault as it complains of Brake Linings even though the sensors and brakes are new, and most of the time it won`t detect Lights On, even wioth four new door sensors!
 

·
Registered
Joined
·
1,934 Posts
Discussion Starter · #3 ·
P.S. I`ve had this error for three years, ever since the car was bought, no-one can trace it and everything seems to work. I know there`s a wiring fault as it complains of Brake Linings even though the sensors and brakes are new, and most of the time it won`t detect Lights On, even wioth four new door sensors![/QUOTE]
---------------------

Thanks Ivan - I went back and connected the Amp wiring, even though its coming out soon, and guess what? You were right it was a grounding.

But - I am having problems with an electrical leak somewhere, since Jan 05, when we put a newer engine in. The car battery will be flat if left undriven for more than two days. weird. Tried finding it many times, will ask BMW to look.

Its like they have amind of their own sometimes.

rgds

J
 

·
Registered
Joined
·
970 Posts
Hi Ivan

I had a 'brake lining' error which BMW could not track down. My local Specialist 'Munich Motors' at Wokingham found it straight away. It turned out to be the right rear brake wiring harness. Maybe this could be your fault?





IvanDias said:
Check Control message with no other warning means the computer is detecting a miscellaneous or unknown electrical fault.

First thing is to check all the internal toys, lights, buttons, everything to see if anything has stopped working. If not, then usually it`s caused by an unexpected grounding of a cable somewhere.
This can be a minefield to determine where.

You may be in luck, as obviously a loose wire of problem with the installation of the stereo may be an easy fix.

Ivan.



P.S. I`ve had this error for three years, ever since the car was bought, no-one can trace it and everything seems to work. I know there`s a wiring fault as it complains of Brake Linings even though the sensors and brakes are new, and most of the time it won`t detect Lights On, even wioth four new door sensors!
 

·
Registered
Joined
·
1,934 Posts
Discussion Starter · #6 ·
AndyE said:
Sounds to me like you both need to replace your M5s with one where everything works! hiha

Hmmm. Here's one I found earlier!

http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=4550978136
--------------
by the looks of the bidding - you should have no problem selling it, even more so by the fact it is in especially good condition. Very nice. What will you get next?

regards
J
 

·
Registered
Joined
·
1,338 Posts
Jahangeer said:
--------------
by the looks of the bidding - you should have no problem selling it, even more so by the fact it is in especially good condition. Very nice. What will you get next?

regards
J
Thanks J. I hope it will finish at a reasonable value. Haven't really decided what to replace it with next though. How about a 300bhp supercharged Ariel Atom? :cheers:

I'd just need to find 70k down the back of the sofa and I could have an E60 M5!
 

·
Registered
Joined
·
1,689 Posts
I have this problem also.. Doesn't come up all the time tho. But does when car won't turn over on the first turn. Have fitted a new battery.
 

·
Registered
Joined
·
1,934 Posts
Discussion Starter · #9 ·
BURTON said:
I have this problem also.. Doesn't come up all the time tho. But does when car won't turn over on the first turn. Have fitted a new battery.
-----------------

yep mine wa sdoing just that too, it was coming up only on the first turn, when the battery was v low.

I already had a new battery - so there is a leak somewhere and I need to find it.
 

·
Registered
Joined
·
1,095 Posts
I have had it for months in my car. My mechanic had it in his 750i and changed something in the dash to fix it. Said it would cost me $165. I will email him and see exactly what he did to fix. it.
 

·
Registered
Joined
·
1,095 Posts
KKelly said:
I have had it for months in my car. My mechanic had it in his 750i and changed something in the dash to fix it. Said it would cost me $165. I will email him and see exactly what he did to fix. it.
This was his reply. Not much information. I should just get if fixed and then report back:

"Kevin
It could be a few things, I suspect it is a problem in the cluster with
one of the capacitors but it could also be a module. I think the module is the same as my car we could try it to see if the problem goes away."
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top