BMW M5 Forum and M6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
373 Posts
Discussion Starter #1 (Edited)
Hello.
Today I changed the washer hose and the ejectors. I also changed the outside rear view mirrors. It all worked out fine when I tested it.
Then I decided to remove the internal rear view mirror and fix it. The automatic tilt function is not working. I tried to find out where to disconnect the wiring but could not find it so I cut the wires under the celing (I know, I am a certified idiot).
Now I know that one shold remove the little cover on the arm ov
f the mirror and behold, there is a connector there! :1:

After that, but I don't know if it is because of that, the washer does not work, the electrical windows do not work, I cant lock the car and the wipers only work on high speed. The automatic rest function does not work anymore.
WHAT HAVE I DONE??

Does anybody know if the internal rear view mirror is the "electrical brain" of this car? ouich

Does anybody have a clue of what this is?
All help is most welcome.

Thanx!
 

·
Registered
Joined
·
150 Posts
ilundber said:
Hello.

Does anybody have a clue of what this is?
All help is most welcome.

Thanx!
I'm also an idiot, so I might be of help. :byebye:

First make sure you have properly reconnected any wires you have cut. Then check ALL the fuses making sure they are not popped. Replaces and bad ones noting the location. Start by checking all the items that didn't work before. Note which ones work, which ones don't, and which fuses have blown again (if any). From there we can start to narrow down where the problem might be.

Good luck
 

·
Registered
Joined
·
373 Posts
Discussion Starter #3
Tom.
Thank you for the advice. I will make sure that I reconnect the wires correctly.
By the way, I really deo love the quote you have:

"The White House has always attracted the mentally ill."
-Vincent Charles, Secret Service Agent explaining why
security was hightened around the White House.

Most certainly made my day hiha hiha
 

·
Registered
Joined
·
373 Posts
Discussion Starter #5
Sincere appligies :thumbsup:
On the other hand, being reffered to by my self, I think I have the first right to the enterpretation of the meaning on the attack. hiha
 

·
Registered
Joined
·
150 Posts
Gustav said:
Personal attacks (including to yourself) is not allowed :7:
Listen G, these were not attacks, simply self identifications. You better stop picking on us idiots, or we will might have to start a class action against your discriminatory singling out of idiots. We are proud to be idiots, and in this age of tolerance and social concience, more and more idiots are "coming out", so you better be nice to us. ;)
 

·
Registered
Joined
·
373 Posts
Discussion Starter #7
Finally a word of truth. :1:
By the way, I found the problem. It is quite simple. Remove the internal rear view mirror and the follow stops working:
- Windscreen wipers (except high speed, but without the rest function)
- Windscreen washers
- Electrical windows
- Internal lights
- Central locking (therefore no alarm)

I also found a blown fuse under the rear seat.

Put the mirror back again and it works! ouich ouich
 

·
Registered
Joined
·
373 Posts
Discussion Starter #8 (Edited)
Just some additional information.

I opened the mirror and found the problem. The platic screw that is actuated by a small electrical motor and that causes the mirror to tilt had gone loose. I replaced it. Doing that in a clumsy way I managed to break the "legs" of the light sensor. They broke flush with the back of the sensor so I could not re-solder them.
New mirror is 2.500 SEK. From a scrap yard it is 250SEK. The 250SEK mirror works perfectly well! :)

After removing the mirror I tested a lot of functions, as yo have noticed. They all came back when I replaced a 7.5 amps fuse undere the rear seat. I think it blows as a consequence of trying any of the appliances I have listed above while the mirror is out.
 
1 - 8 of 8 Posts
Top