BMW M5 Forum and M6 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
Hey guys,

I left my garage and got about 1 mile from the house, was driving in traffic at about 35mph in 3rd gear and all of a sudden - the car felt like it buckled in the front and I got the message saying "Engine Malfunction - Reduced Power". All the assists shut down completely including power steering, I was barely able to turn on to a side street to pull off and had to push the car off to the side of the street.

I tried to restart the car a couple times, but to no avail. It would start to turn over but the engine never turned on. I waited 20 minutes and tried again, it restarted and then I got the "Increased Emissions" message, which hasn't gone away. The car drove ok after that but I kept it below 3k revs, it wasn't in limp mode or anything. I drove it to the service shop where it currently sits.

Here are all the error codes pulled, a total of 16:


  1. 27A4 - Tank Ventilation Function Test Bank 1
  2. 2B35 - Combustion misfire with Cut-Out Cylinder 1
  3. 2B36 - Combustion misfire with Cut-Out Cylinder 2
  4. 2B37 - Combustion misfire with Cut-Out Cylinder 3
  5. 2B38 - Combustion misfire with Cut-Out Cylinder 4
  6. 2B39 - Combustion misfire with Cut-Out Cylinder 5
  7. 2B3A - Combustion misfire with Cut-Out Cylinder 6
  8. 2B3B - Combustion misfire with Cut-Out Cylinder 7
  9. 2B3C - Combustion misfire with Cut-Out Cylinder 8
  10. 2B3D - Combustion misfire with Cut-Out Cylinder 9
  11. 2B3E - Combustion misfire with Cut-Out Cylinder 10
  12. 2B41 - Combustion misfire with Cut-Out Several Cylinders
  13. 2B57 - Safety Concept Manager Action
  14. 2B96 - Safety Concept Manager Action
  15. 27CF - Building up of Fuel Pressure Sensor Fuel Pump Feed
  16. 2722 - Fuel Pressure Sensor Signal
Any idea what the underlying issue might or what to expect? I imagine the cylinders misfiring is a symptom rather than a cause. Could this due to some type of fuel pressure related issue? Anyone have any similar experiences?

Thank you in advance.
 

·
Registered
Joined
·
265 Posts
I got these same codes when I was messing with my fuel pump. I would suggest you check fuel pressure at the motor. If the pressure is good then my next move would be to see what the indicated pressure is via diag computer. If these values are different then it's a sensor issue. If the values match, then it's time to go into the tank and replace the pump or clogged filter.

Also, when you say the car would not start was it just cranking for 15 seconds or kinda sputter and die?

Sent from my XT1254 using Tapatalk
 

·
Registered
Joined
·
71 Posts
Discussion Starter #4
Looks like you have a problem with your fuel pump.
That's what I would guess, currently awaiting word from the shop tomorrow.

I got these same codes when I was messing with my fuel pump. I would suggest you check fuel pressure at the motor. If the pressure is good then my next move would be to see what the indicated pressure is via diag computer. If these values are different then it's a sensor issue. If the values match, then it's time to go into the tank and replace the pump or clogged filter.

Also, when you say the car would not start was it just cranking for 15 seconds or kinda sputter and die?

Sent from my XT1254 using Tapatalk
Thanks for the detailed reply! The car is in the shop so hopefully they should have a diagnosis tomorrow. When the car wasn't starting, it would crank for 2-3 seconds, then sputter and die a second later. The rev counter would limp getting to maybe 600 revs or so before it died. This happened 4-5 times before I gave up and decided to wait 20 minutes :frown
 

·
Registered
Joined
·
265 Posts
Fuel pressure sensor would be my guess. Car thinks it has no pressure so it's dumping fuel into the cylinders this flooding out the motor. About a $175 part that is stupid simple to replace.

Sent from my XT1254 using Tapatalk
 

·
Registered
Joined
·
71 Posts
Discussion Starter #6
Fuel pressure sensor would be my guess. Car thinks it has no pressure so it's dumping fuel into the cylinders this flooding out the motor. About a $175 part that is stupid simple to replace.

Sent from my XT1254 using Tapatalk
Yep, they just said that the fuel sensor is faulty so they're replacing that first before doing further diagnostics. I'll post back with results, thanks!
 

·
Registered
Joined
·
71 Posts
Discussion Starter #8
Any update on the situation?

Sent from my XT1254 using Tapatalk

Yep, they have to wait to get a new fuel sensor, should be in tomorrow. They said they'll replace it and then run further diagnostics in case there are any other issues. I'll definitely post back with results.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #9
Yep, they have to wait to get a new fuel sensor, should be in tomorrow. They said they'll replace it and then run further diagnostics in case there are any other issues. I'll definitely post back with results.
I just realized that I never posted back with the final result. Replacing the fuel sensor seems to have been the only cure needed. It was <$250 including parts and labor, all covered by insurance. I've had the car back for several days, everything seems to be in great shape. So far so good, thanks everyone.
 
1 - 9 of 9 Posts
Top