BMW M5 Forum and M6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
208 Posts
Discussion Starter #1
Hello all

Having a few issues with my car. It is stalling when coming to a stop or putting car into neutral at highway speeds. Doesnt do this everytime but it is rather embarassing and somethings not right.

Car runs great off idle. Sometimes a slight hesitation when pushing gas from a stop

Currently on stock tune to rule out tune being an issue.
NEW
-Mafs
-precat o2
-Air filters
-Swapped in another IACV
-CPS are only 3 years/30k old
-vanos seals done same time

Only concerning thing is the code says "Short circuit to battery or value too high" Not sure what that could be

Have seen this code before and only occurs at idle RPM

Thank you for ANY help
p1.JPG
Capture.JPG


Stock car with muffler delete and dinan cold air.
dkg.JPG
 

·
Registered
Joined
·
197 Posts
Well it's clearly not happy with your MAF values for some reason; did you make sure to clear/reset the adaptations/fuel trims when you put in the new MAF? Do you have your old MAF? First tests I'd run would be to put the old MAF back in and/or just unplug the new MAF and see how that changes things.
 

·
Registered
Joined
·
208 Posts
Discussion Starter #3
Did this with old mafs and my backup set.

I was an idiot and bought brand new and still same issue.

Yes have reset adaptations right away after a new part and then few days later just to try. Have been trouble shooting for a week

Next step is a smoke / leak test unless better ideas
 
1 - 6 of 6 Posts
Top