BMW M5 Forum and M6 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1 (Edited)
Hey guys,

Wondering if anyone can help point me in the right direction. With 74K on the odo on my 2001, finally experiencing leaking fluids. She's been good thus far, but I've been expecting this day.

Came home one day to find a small pool of oil on the driver's side of the engine underpan. Looked around the engine, and seem to see residue on the Vanos units (I think?). I know people have seen oil leaks from the solenoid unit, but this oil seems to be around the unit behind where the solenoids are housed. I've attached a few pics, I think you can make out the dark spots where the oil residue is.

Recently, I've burned 1L of oil in approx 2k miles, so the leak helps explain that. Throughout the life of the car, I've had a hard-oil burning S62 (usually Mobil1 0W40), but nothing like this. It doesn't seem to be an "active" leak, but one that I'd like to mend nonetheless.

Is this indicative of O-rings that need to be replaced in the solenoids? If so, I think I can handle that. Or is this a bigger problem at bay, and off to the professionals it goes?

Anyone out there have a similar experience and know where I should look? I'm also if this is a red-herring as my Power Steering hoses are starting to leak also, but confused as to the oil residue on the Vanos unit itself?

Thanks in advance. I'll be sure to follow up with findings and resolution.
 

Attachments

·
Registered
Joined
·
6,642 Posts
Looks more like valve cover leak to me....

is the bottom of the vanos unit also oily?

Would clean it up and then try to see where the oil leak comes from
 

·
Registered
Joined
·
13 Posts
yes, it does look like you have a leaking valve cover gasket, depends how fast it is leaking, if you see a lot on the ground its probably mostly power steering hoses, but best is really clean it up nicely and keep monitoring
 

·
Registered
Joined
·
137 Posts
Discussion Starter #4
Ok, thanks for the feedback. I think I have a bunch of leaks going on, probably some power steering ending up on the tray, and then valve covers ending up on the vanos units.

May do some preventative maintenance on the valve covers, the bolts, and the steering hoses. clean everything up, and then see how it works. will get back to this thread with updates so it can be helpful to others.
 

·
Registered
Joined
·
137 Posts
Discussion Starter #5
Thanks for all the help on this board. I eventually replaced all power steering hoses and the valve cover gaskets. Turns out, virtually all the remaining power steering ATF fluid had leaked onto the engine pan! Cleaning it up left a lot of red-colored paper towels. So that was the source of the leak at the engine pan level.

On the Vanos units, definitely seemed to be valve cover seepage. Never gone that deep into the car before (last time was evaporator valve), but the great instructions here helped me through it. Screwed everything back together and was actually able to seat the gaskets correctly. Lucky.

Anyway, hope these thread helps someone who has a similar diagnosis.
 

·
Registered
Joined
·
10,265 Posts
You need to take a look at your driver side MAF in the pic the engine side is not lined up correctly. Sort of cocked minor potential for a future leak.
 
1 - 7 of 7 Posts
Top