BMW M5 Forum and M6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
217 Posts
Discussion Starter #1
Got an intermittent problem with the AC. When I run it low (3-5 lights), afterawhile the speed of the AC blower drops so theirs hardly any air coming through the vents. The AC is still working and air is coming out, but just very very little...its not on automatic.

I dial up the speed and nothing basically happens for 1min - 20 min, then when it feels like it the speed comes back to whatever I dial it onto. Happens on a pretty much daily basis. I thought it was the blower motor, but since it does respond (in its own time) I'm thinking its something with the AC electrics.

Its also recently started to get that stale water smell after I leave it for a couple hours. So, I'm having to run the blower without AC for 1-2min before shutdown to evaporate it.

Anyone had similar problems, especially with the blower speed? Thanks
 

·
Registered
Joined
·
61 Posts
I'm having exactly the same problems. Although, the last two weeks I have had the blower on either full all the time or off completely.
I have dismissed it as age.
I am not due at the dealers for service for another 3 months and I don't want to take it in just for that as it doesn't really annoy me that much.
Is there anybody else with this problem? or is there someone who has resolved this problem?
Maybe you could be kind enough to enlighten us. cherrsagai
 

·
Registered
Joined
·
12,913 Posts
tranck said:
Mine did the same thing and I forget what the fix was but the dealer took care of it at little cost.
There is a fan blower resistor pack that controls fan speed. Located behind the glove box, repaired for me under warranty, it was about a 30 minute fix.
Regards,
Jerry
 

·
Registered
Joined
·
217 Posts
Discussion Starter #5
gsfent said:
There is a fan blower resistor pack that controls fan speed. Located behind the glove box, repaired for me under warranty, it was about a 30 minute fix.
Regards,
Jerry
You were having the same problems as described? Any idea what goes wrong with the resistor pack? Was it repaired or just swapped for a new one? If its a replacement job, I suppose theirs a new part number for the replacement item to stop it happening again? Thanks
 

·
Registered
Joined
·
2,071 Posts
Your problems are definitely a bad final stage resistor. I don't know why BMW can't improve this part after continuous failure over the life of all BMWs since at least 2000. I know X5s have the same issue. Where are the quality control people at BMW? Surely it is not cheaper to keep replacing these under warranties.
 

·
Registered
Joined
·
12,913 Posts
1 - 8 of 8 Posts
Top