BMW M5 Forum and M6 Forums banner

61 - 77 of 77 Posts

·
Registered
Joined
·
17 Posts
I've yet again come to another issue. After fitting in the Xenon NON -AHL headlights, The xenon don't work. Everything else does though, AE also working at full 35 watts and working indicators etc. Just no Xenon headlights, What would be causing this?

I did notice on the BMW Retrofit guide, It list 2 brown wires that are listed as Ground, But my car only has 1 brown?? What do I do?
 

·
Registered
Joined
·
5 Posts
Hi LCM,

Cool pre lci adaptives to lci adaptives harness that you put together. Exactly the solution I need to for my retrofit for my pre-CLI 2006 M5 with Xenon and AHL. Can I purchase one from you? Appreciate your response. Thanks.
 

·
Registered
Joined
·
30 Posts
Hey buddy I have a 06 m5 pre lci and need a plug and play harness for my new lci xenon lights. Can you sell me one please? Please pm me back
 

·
Registered
Joined
·
5 Posts
First, thanks much to LCM for solving my LCI headlight retrofit problem.

LCM can help you. He provided LCI headlight cables to retrofit to existing preLCI connectors so you don't need to cut/splice etc. This assumes you are not changing to LCI taillight. But if you do it is assumed that you are using something like Bruce Miranda cable for taillight. This method does not require running cables all the way back for LCI taillight from LM2 module. If you have LM1 module you must change it to LM2.

LCM is awesome in coding and solving problems. He made LCI bixenon adaptive headlight work perfectly with halo DRL, welcome lights, cornering lights, etc.

Please contact LCM if you need help in your retrofit.
 

·
Registered
Joined
·
198 Posts
thanks for the kind words highrpm, was a pleasure helping to make your ///M look even meaner! Coding took longer than expected but your custom set up (LCI heads and pre-lci bruce miranda boxes on the rear with LCI taillights), all work as expected now! :)

If anyone wants me to check if they have an LM1 or LM2, feel free to PM me your vin....

azp2948, got your PM :)
 

·
Registered
Joined
·
121 Posts
Hi guys,

I'm in the midst of doing the Lci conversion from pre Lci. Build 10/05
I have bought Lci oem tail lights, Bmw retrofit cable, lm2 and updated Lci headlights.
The first thing I noticed on my headlights is that I have only 11 wires all together instead of 12 on each one as it shows in the pdf and some of the colors on the wires don't match.
Anybody experienced this and how were you able to work around it.
Thanks,


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
17 Posts
Hi guys,

I'm in the midst of doing the Lci conversion from pre Lci. Build 10/05
I have bought Lci oem tail lights, Bmw retrofit cable, lm2 and updated Lci headlights.
The first thing I noticed on my headlights is that I have only 11 wires all together instead of 12 on each one as it shows in the pdf and some of the colors on the wires don't match.
Anybody experienced this and how were you able to work around it.
Thanks,


Sent from AutoGuide.com Free App
Are you retrofitting lci halogen or xenon?

In my case I had retrofit xenon then you are missing a ground wire that is all. Pin 1 and Pin 7 from the prelci connector is grounds, but you won't have both, you'll only have one. It should be a brown wire. When I did mines, I just used a wire tap from pin 1 and that's how I got the extra wire.

I used the pin label diagram at the bottom of the retrofit pdf where it tells you the pin number from the pre Lci harness and where it plugs into the Lci harness.
 

·
Registered
Joined
·
121 Posts
Are you retrofitting lci halogen or xenon?



In my case I had retrofit xenon then you are missing a ground wire that is all. Pin 1 and Pin 7 from the prelci connector is grounds, but you won't have both, you'll only have one. It should be a brown wire. When I did mines, I just used a wire tap from pin 1 and that's how I got the extra wire.



I used the pin label diagram at the bottom of the retrofit pdf where it tells you the pin number from the pre Lci harness and where it plugs into the Lci harness.

Thanks for the reply.
I'm retrofitting Lci xenon.
Did you notice your wire colors on the car headlights to be different than the pdf states them or am I colorblind?
Is there anything else that I should be aware of?
Thanks,


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
17 Posts
Is your car is PRE-LCI Halogen?

Aside from that, try this

Before you swap in the LM2,
Access your Light Control Module(The one the car originally came with, and look at PIN 25 and PIN 40 What color is it?

Then on the PRE-LCI connectors for both sides, Look at PIN 4 . Is it the wire the same color PIN 25 and PIN 40 from the LCM?

If they are the same color, this means you just have to ignore the color code, and use the Circuit diagram. That is what I did for mines, I didn't too much rely on the color code because I heard on a certain release of the pdf, the color codes were incorrect.
 

·
Registered
Joined
·
121 Posts
Is your car is PRE-LCI Halogen?



Aside from that, try this



Before you swap in the LM2,

Access your Light Control Module(The one the car originally came with, and look at PIN 25 and PIN 40 What color is it?



Then on the PRE-LCI connectors for both sides, Look at PIN 4 . Is it the wire the same color PIN 25 and PIN 40 from the LCM?



If they are the same color, this means you just have to ignore the color code, and use the Circuit diagram. That is what I did for mines, I didn't too much rely on the color code because I heard on a certain release of the pdf, the color codes were incorrect.

On the Lcm plug I have pin 25 gray/green and pin 40 gray/blue only.
I have gray/green again on pins 42 and 54 if that helps.
On the pre Lci connector for driver side I have gray/green on pin 4 and no blue/gray at all as you can see in the pic.
On the right side on pre Lci connector I have gray/blue on pin 4 as you can see from the pic and no gray/green anywhere else. Also the small plugs next to pre Lci main connectors the colors don't match on either sides. ImageUploadedByAG Free1472520706.257414.jpg ImageUploadedByAG Free1472520746.627220.jpg ImageUploadedByAG Free1472520766.607032.jpg ImageUploadedByAG Free1472520777.756245.jpg ImageUploadedByAG Free1472520789.333153.jpg ImageUploadedByAG Free1472520803.269902.jpg ImageUploadedByAG Free1472520813.703305.jpg
I've included pics of the pre Lci I took off the car and the Lci I'm planning to use for your information if it helps.
Is there anyway you can help me from here onward?
Thanks,


Sent from AutoGuide.com Free App
 
61 - 77 of 77 Posts
About this Discussion
76 Replies
22 Participants
stel_i79
BMW M5 Forum and M6 Forums
M5Board is the best forum community for information on the BMW M5 E60 (V-10), E39 (V-8), E34 (straight 6), E28, F90 and F10. Discuss performance, specs, reviews and more!
Full Forum Listing
Top