BMW M5 Forum and M6 Forums banner

camshaft position sensor

  1. Isolaing Timing Issue

    E39 M5 and E52 Z8 Discussion
    Hey Guys, I've in the last year purchased a nice 00 avusblau metallic M5 (9/99 production date). Absolute beauty. I have recently run into what looks and sounds like a intermittent timing issue. I recently heard it misfiring during warm up in the garage. Got in and sure enough CE light is on. I...
  2. E39 running rough after both Vanos and timing done

    E39 M5 and E52 Z8 Discussion
    Took my m5 to a mechanic a few months ago to fix a couple things including it running rough. It's pulling the code P0011 in bank 1. Both me and the mechanic are at a lose as to what it could be. Anyone have any recommendations? I've included the work order in case anyone's interested.
  3. M5 Issue Resolved!!!!

    E39 M5 and E52 Z8 Discussion
    - Hi, I am new to these boards. Sorry if i am posting in the wrong area. I just wanted to post this so it can help anyone out there that is having similar issues. I bought a 2000 m5 two weeks ago. Everything looked ok, it ran ok. Ofcourse this was my first time driving this car. I bought the...
  4. Need help diagnosing this puzzle...

    E39 M5 and E52 Z8 Discussion
    Two months ago my E39 M5 with 195K miles broke down on the highway. It went into limp mode several times in the prior days, but I was always able to recover by pulling over and shutting the engine off for a few minutes. This has happened a few times since 150K miles, but always started right...
  5. SES light-Camshaft Position Sensor Issues

    E39 M5 and E52 Z8 Discussion
    So, After countless hours searching through the board, I still am a bit confused with my readings. At first, I took my vehicle to Schucks Auto to have them check the fault codes. It read, "Camshaft Position Sensor Bank B." I then bought a Peake reader and through (table 1b) it faulted=OA...
Top