BMW M5 Forum and M6 Forums banner

Search results

1-20 of 52 Results
Advanced Search
  1. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    “When installing, pay attention without fail to yellow marking.” I do not really know what’s that suppose to mean, perhaps the yellow tape is an indication of where the valve connectors suppose to be. Since I don’t think the connectors are not where it should be perhaps that might be the...
  2. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    That could be it. I have been doing a bit of thinking. What about the pressure valve connector installed incorrectly? The picture below was when I removed the transmission prior to any work. I recalled I reconnected the connectors for the pressure valve in a different way in a way to make thing...
  3. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    If I am a betting man, I bet the gearshift fork for R/1 that I moved slightly is the problem because it’s no longer in centre position at point of travel instead 1 is engaged as a centre position of travel as a function of N. Look at teach in transmission error. It stated so clearly. When all...
  4. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    I have a theory of what the problem might be based on the things I did today without removing the transmission. Remember I explained to you that I struggled to reinstall the actuator block to the transmission as something seems to be in the way and I concluded that it was the gearshift fork in...
  5. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    The car will start once I shift to “N”. The reality, is that it doesn’t bother whether or not if the car stuck in 1 so long I shifted to “N” to start the car. It seems to me whether if the car isn’t physically in “N” is irreverent as long the gear position is working and the car can sense that...
  6. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    The car doesn’t feel like it’s physically in “N” at all. The car just start if I shift it into N and press the start button it’s technically not in N when I tried to start it. once I started the car, It will default to “1” on the cluster even if the shift lever is still in “N”, that is not...
  7. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    That’s right the car would only start unless in N. If I have to guess, since the gear position sensor seems to be working, it recognizes that I shifted the car into “N” position and it will start at that point but it will not start if I left the shift lever in drive mode S1 or D1 or 1. I...
  8. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    No it’s not in N because I can’t move or push the car freely forward or backward and N only exist in the cluster very brief in time to start the car and after that N is nonexistent while the engine running. Think about it, I had the car off the ground and the rear wheel would not rotate freely...
  9. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    Yes, in order for the car to start it has to be in “N” and the cluster does display N when I started it, every time. The car will start regardless of the circumstance. The car seems to know what gear it is in. As it’s displaying “1” as the current engage gear. When you say “even with that the...
  10. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    The car just does not disengage. Only the current gear is engaged which is “1” . For some reason it would not disengage from current gear even with ISTA. The car does registering what gear I am selecting. For example, if I shifted to “R”, the shift lever lighting display “R” but the cluster...
  11. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    Any So far this is my findings: -When I disconnected the gear position sensor. I do get error code for it and code clear when reconnected. -When I disconnected the transmission input sensor. There is no code then I reconnected, still no code exist -4F80 appears when I started (terminal 30)...
  12. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    I haven't tried using ISTA for this purpose but INPA. I dared to tired using INPA while the engine running, to have it shift into R or N and that does not work only when the car is in terminal 15 as in ignition on but I will go ahead try with ISTA. Just remember when I using engage gear via...
  13. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    How can it be the gear position sensor? My understanding is that if it's the gear position sensor, the car will not ever start. Every time I tried to start the car, it's guarantee to start. I meant it will always start and at minimum, it will shows "N" when trying to start the car but disappears...
  14. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    I found the error code. It’s 4F80 SMG: Gearbox.
  15. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    Check this out: What I found. There is a readiness that there is no neutral sensor. I remember prior to transmission work. I engaged all the gears without problem. Never see “There is no neutral sensor” And when I used this feature engaging all gears prior, I tends to feel some type of...
  16. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    Current valve pressure on terminal 15 Current valve pressure on terminal 30
  17. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    I meant first time when I reattached the transmission to the engine and there was massive leak and what’s interesting is that 4F43 prompted immediately as soon as I noticed the leak and I didn’t have shifting recognition problems and I took out the transmission twice and inspected and find that...
  18. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    No, I did not. ISTA suggests in order of: 1 teach in clutch 2. Teach in Transmission 3. Clutch slipping point symptoms looking as follows: The shift knob does show shifting input. What I meant is that when the shift knob placed into “N”or “R”, the lighting does illustrate on the shifter...
  19. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    I got in the transmission and I haven’t perform bleeding procedure yet but I build-up pressure several times in succession to identified leak if any because the first time I reinstalled gearbox, the car had massive leak from the actuator block from the shifting solenoids valve not the pressure...
  20. 4f43 hydraulic unit, on period 2010 Bmw M5 121,000 miles

    E60 M5 and E61 M5 Touring Discussion
    How you did it, is rather interesting. Did you, pull in the gearbox by using screws? So far I disassembled the clutch disc to verified clutch spline can slide correctly in input shaft spline to ensure the splines are not damaged. It does slides all the way in and out and I reassembled the...
1-20 of 52 Results
Top