Gear selector stuck - BMW M5 Forum and M6 Forums
E60 M5 and E61 M5 Touring Discussion 2005- Advertiser's Forum

Reply
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 13 Old 19th May 2017, 10:11 AM Thread Starter
Lakotiy
Member, Sport: On DSC: Off
 
Join Date: Oct 2016
Posts: 204
Thanks: 6
Thanked 17 Times in 16 Posts
Gear selector stuck

Installed the new engine today and now it will not crank ok gear selector shift into anything. Totally dead selector. My matco scanner is able to shift into any gear but not the selector. Checked the wiring plugs 5 times already. Says trans fail safe mode. New engine came with a harness and one plug doesn't match. Any insight would help.



Sent from my iPhone using Tapatalk
Lakotiy is online now  
Sponsored Links
Advertisement
 
post #2 of 13 Old 19th May 2017, 12:13 PM
jcolley
m5board.com Site Sponsors
 
jcolley's Avatar
 
Join Date: Apr 2006
Location: Maine
Posts: 5,234
Thanks: 77
Thanked 1,099 Times in 751 Posts
That's an LCI engine harness for a pre-LCI car. That plug carries CAN bus signals for the SMG module. If the SMG doesn't receive them, it won't shift normally.
jcolley is offline  
post #3 of 13 Old 19th May 2017, 05:13 PM Thread Starter
Lakotiy
Member, Sport: On DSC: Off
 
Join Date: Oct 2016
Posts: 204
Thanks: 6
Thanked 17 Times in 16 Posts
Quote:
Originally Posted by jcolley View Post
That's an LCI engine harness for a pre-LCI car. That plug carries CAN bus signals for the SMG module. If the SMG doesn't receive them, it won't shift normally.


Is it possible for me to rewire my original plug or do I need to swap the harness. Also, do you know how many ground points we have? So far I remember one on top of passenger side motor mount


Sent from my iPhone using Tapatalk
Lakotiy is online now  
 
post #4 of 13 Old 19th May 2017, 06:08 PM
jcolley
m5board.com Site Sponsors
 
jcolley's Avatar
 
Join Date: Apr 2006
Location: Maine
Posts: 5,234
Thanks: 77
Thanked 1,099 Times in 751 Posts
Quote:
Originally Posted by Lakotiy View Post
Is it possible for me to rewire my original plug or do I need to swap the harness. Also, do you know how many ground points we have? So far I remember one on top of passenger side motor mount


Sent from my iPhone using Tapatalk
Possible, not recommended. I would swap the engine harness.

Just the one on the cradle, yes.
jcolley is offline  
post #5 of 13 Old 19th May 2017, 06:21 PM Thread Starter
Lakotiy
Member, Sport: On DSC: Off
 
Join Date: Oct 2016
Posts: 204
Thanks: 6
Thanked 17 Times in 16 Posts
Quote:
Originally Posted by jcolley View Post
Possible, not recommended. I would swap the engine harness.



Just the one on the cradle, yes.


Yes, I didn't mess with my trans harness. Should I drop the engine again or take my time and swap my harness with the engine intact?
Found this post, the blue connector is the starter solenoid. There the problem for not cranking


Sent from my iPhone using Tapatalk
Lakotiy is online now  
post #6 of 13 Old 19th May 2017, 06:25 PM Thread Starter
Lakotiy
Member, Sport: On DSC: Off
 
Join Date: Oct 2016
Posts: 204
Thanks: 6
Thanked 17 Times in 16 Posts
Lakotiy is online now  
post #7 of 13 Old 19th May 2017, 06:30 PM
jcolley
m5board.com Site Sponsors
 
jcolley's Avatar
 
Join Date: Apr 2006
Location: Maine
Posts: 5,234
Thanks: 77
Thanked 1,099 Times in 751 Posts
Quote:
Originally Posted by Lakotiy View Post


This is the same plug that doesn't match.


Sent from my iPhone using Tapatalk
Edit: Disregard, I had the E-box oriented backwards. This blue connector is the front? The one you posted looks like the connector in the back inside corner for the SMG harness.

Last edited by jcolley; 19th May 2017 at 06:33 PM.
jcolley is offline  
post #8 of 13 Old 19th May 2017, 06:33 PM Thread Starter
Lakotiy
Member, Sport: On DSC: Off
 
Join Date: Oct 2016
Posts: 204
Thanks: 6
Thanked 17 Times in 16 Posts
Quote:
Originally Posted by jcolley View Post
The starter solenoid relay perhaps, but the solenoid is located on the starter itself.



I can promise you the is a pair of wires in that connector with spiral color banding that is a twisted pair of CAN signals to the SMG module. It's been a while, but if I remember correctly, it's the LLS-CAN from the SMG module to the idle actuators (LLS) and DME.


I'll take your word for it. Thank you! Should I swap the harness with the engine bolted to the chassis it drop the engine?


Sent from my iPhone using Tapatalk
Lakotiy is online now  
post #9 of 13 Old 19th May 2017, 06:35 PM
jcolley
m5board.com Site Sponsors
 
jcolley's Avatar
 
Join Date: Apr 2006
Location: Maine
Posts: 5,234
Thanks: 77
Thanked 1,099 Times in 751 Posts
Quote:
Originally Posted by Lakotiy View Post
I'll take your word for it. Thank you! Should I swap the harness with the engine bolted to the chassis it drop the engine?


Sent from my iPhone using Tapatalk
Check again, I just edited the post you quoted. This connector you can't connect...is it in the front right or the back left of the E-box?
jcolley is offline  
post #10 of 13 Old 19th May 2017, 06:39 PM Thread Starter
Lakotiy
Member, Sport: On DSC: Off
 
Join Date: Oct 2016
Posts: 204
Thanks: 6
Thanked 17 Times in 16 Posts
The blue plug is upfront coming from the engine harness. The white plug is coming from the chassis and supposed to be sitting where the blue plug is at


Sent from my iPhone using Tapatalk
Lakotiy is online now  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 M6 - stuck in gear survyor2 E63 BMW M6 Forum and BMW M6 Convertible | m6board.com 8 18th August 2015 07:42 PM
Warning Light in Gear Selector fasteddie1215 E63 BMW M6 Forum and BMW M6 Convertible | m6board.com 0 27th May 2015 12:15 AM
fixed -- no start / gear selector wont move... HISandHERsM5 E60 M5 and E61 M5 Touring Discussion 6 23rd May 2014 06:57 PM
Paddle Shifts vs. Gear Selector C.James.B E60 M5 and E61 M5 Touring Discussion 8 22nd March 2012 12:02 AM
Stuck in 2nd gear! AliM5 E39 M5 and E52 Z8 Discussion 27 5th February 2010 05:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome