Crazy CCC issues - BMW M5 Forum and M6 Forums
E60 M5 and E61 M5 Touring Discussion 2005- Advertiser's Forum

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 8 Old 20th April 2017, 11:44 PM Thread Starter
BobbyT
Junior Member, warming up (<31 posts)
 
BobbyT's Avatar
 
Join Date: Mar 2017
Location: Detroit
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Crazy CCC issues

I had some weird issues with my 2006 M5 CCC - Bluetooth wouldn't pair a phone (it would connect and show the phone in iDrive, but then delete it within a second or two).
Also, I couldn't edit anything in the MDrive - Anything that I would try to change, would revert back to what it was within about a second.
I ran DIS to see if it could see anything, and it noticed some coding faults in the gateway. I flashed the GW module with KDCan (on K) with WinKFP, and was successful - However, it did not fix the issues above.
I decided to flash the entire CCC the same way, and what I didn't realize is that it was going to take about 7 hours. It got to 100%, then error and brick. Biggest waste of 7 hours ever, considering I monitored the voltage the whole time.
I contacted Bimmergeeks to see if they had a solution with their cable, and they explained that they wouldn't recommend any KDCan on the MOST flashes (which theirs is). However, they suggested either ICOM (my last resort before dealership or new CCC), or CD CCC Recovery Disc - which I was not familiar with. They explained the files, and I burned the correct disc for my CCC hardware (9.5).
Popped the disc in, and in about 1 hour and a half, I was back in business.

Now the current status -
- MDrive is editable, however the EDC line is missing.
- Bluetooth menus look more normal, however the "enable bluetooth" is grayed out, so bluetooth is still not functional. Possible MULF module issue?
- No sound at all from speakers - No radio, chime, nothing...

I checked all the fuses, and pulled negative battery cable for a while, however no change. I was going to hook it up to DIS to see if it can see any faults - however, if anyone has any suggestions on how to resolve this, I'd love to hear it.

Thanks!
An
BobbyT is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 21st April 2017, 11:10 AM
LCM
Member, Sport: On DSC: On (>100 posts)
 
Join Date: Jul 2014
Location: Herts Beds & Bucks, UK
Posts: 170
Thanks: 3
Thanked 8 Times in 8 Posts
LCM is offline  
post #3 of 8 Old 21st April 2017, 12:09 PM
gmak
Member, P500 Sport, MDM on (>800)
 
Join Date: Dec 2014
Location: Canada
Posts: 800
Thanks: 26
Thanked 61 Times in 61 Posts
Did you look in the trunk under the "wheel well" to see if water fried any electronics?
gmak is offline  
 
post #4 of 8 Old 21st April 2017, 01:38 PM Thread Starter
BobbyT
Junior Member, warming up (<31 posts)
 
BobbyT's Avatar
 
Join Date: Mar 2017
Location: Detroit
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by LCM View Post
default code the ccc
What method would you suggest?

Quote:
Originally Posted by gmak View Post
Did you look in the trunk under the "wheel well" to see if water fried any electronics?
I did a bit... looked at MULF, Sat, trunk fuse box, etc. All looked good.
BobbyT is offline  
post #5 of 8 Old 22nd April 2017, 01:09 AM
LCM
Member, Sport: On DSC: On (>100 posts)
 
Join Date: Jul 2014
Location: Herts Beds & Bucks, UK
Posts: 170
Thanks: 3
Thanked 8 Times in 8 Posts
Quote:
Originally Posted by BobbyT View Post
What method would you suggest?
the usual with ncsexpert
LCM is offline  
post #6 of 8 Old 22nd April 2017, 10:05 PM
335xi
m5board.comoholic (>1000 posts)
 
Join Date: Dec 2009
Location: CT, USA
Posts: 1,777
Thanks: 7
Thanked 47 Times in 43 Posts
I have a CCC + Screen for $cheap$

Quote:
Originally Posted by BobbyT View Post
I had some weird issues with my 2006 M5 CCC - Bluetooth wouldn't pair a phone (it would connect and show the phone in iDrive, but then delete it within a second or two).
Also, I couldn't edit anything in the MDrive - Anything that I would try to change, would revert back to what it was within about a second.
I ran DIS to see if it could see anything, and it noticed some coding faults in the gateway. I flashed the GW module with KDCan (on K) with WinKFP, and was successful - However, it did not fix the issues above.
I decided to flash the entire CCC the same way, and what I didn't realize is that it was going to take about 7 hours. It got to 100%, then error and brick. Biggest waste of 7 hours ever, considering I monitored the voltage the whole time.
I contacted Bimmergeeks to see if they had a solution with their cable, and they explained that they wouldn't recommend any KDCan on the MOST flashes (which theirs is). However, they suggested either ICOM (my last resort before dealership or new CCC), or CD CCC Recovery Disc - which I was not familiar with. They explained the files, and I burned the correct disc for my CCC hardware (9.5).
Popped the disc in, and in about 1 hour and a half, I was back in business.

Now the current status -
- MDrive is editable, however the EDC line is missing.
- Bluetooth menus look more normal, however the "enable bluetooth" is grayed out, so bluetooth is still not functional. Possible MULF module issue?
- No sound at all from speakers - No radio, chime, nothing...

I checked all the fuses, and pulled negative battery cable for a while, however no change. I was going to hook it up to DIS to see if it can see any faults - however, if anyone has any suggestions on how to resolve this, I'd love to hear it.

Thanks!
An
It's from my 2008 from when I upgraded to CIC, I will give you a good price.
335xi is offline  
post #7 of 8 Old 25th April 2017, 02:33 PM Thread Starter
BobbyT
Junior Member, warming up (<31 posts)
 
BobbyT's Avatar
 
Join Date: Mar 2017
Location: Detroit
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 335xi View Post
It's from my 2008 from when I upgraded to CIC, I will give you a good price.
I will definitely keep this in mind. I'm skeptical that it's a bad CCC at this moment, but if I can't code it back to normal, I'll contact you on this. Thanks!
BobbyT is offline  
post #8 of 8 Old 25th April 2017, 08:03 PM
LCM
Member, Sport: On DSC: On (>100 posts)
 
Join Date: Jul 2014
Location: Herts Beds & Bucks, UK
Posts: 170
Thanks: 3
Thanked 8 Times in 8 Posts
Quote:
Originally Posted by BobbyT View Post
I will definitely keep this in mind. I'm skeptical that it's a bad CCC at this moment, but if I can't code it back to normal, I'll contact you on this. Thanks!
I share your reasons for skepticism!
LCM is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
texsn95
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
E60 For Sale: I have CCC and CCC Screen from 2008 M5 for sale 335xi Parts / Other For Sale or Wanted 3 30th December 2015 05:11 PM
Would my ccc professional be able to replace a ccc business? pyro225 E63 BMW M6 Forum and BMW M6 Convertible | m6board.com 0 18th March 2012 02:21 PM
Update the CCC ziad E60 M5 and E61 M5 Touring Discussion 3 3rd December 2011 07:45 PM
Issues with DVD CCC Map disc M5 Jed E60 M5 and E61 M5 Touring Discussion 6 14th March 2009 06:05 AM
Another CCC Failure pvr E60 M5 and E61 M5 Touring Discussion 29 20th January 2008 04:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome