Steering angle sensor DIY fix - it worked - Page 4 - BMW M5 Forum and M6 Forums
E60 M5 and E61 M5 Touring Discussion 2005- Advertiser's Forum

 37Likes
Reply
 
LinkBack Thread Tools Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
post #31 of 139 Old 4th May 2013, 10:50 PM
messex
Member, P500 Sport, DSC off (>900)
 
messex's Avatar
 
Join Date: Jan 2011
Location: Greer, SC
Posts: 990
Thanks: 136
Thanked 63 Times in 54 Posts
Another successful fix!

First, thanks for everybody that contributed to this DIY. I was having the exact issue described, and based on the detailed steps and photos given, I was confident I could do this. So, decided to tackle this today. Overall, very straight forward, and so far, it has resolved my issue!!! Can't believe the dealership would charge so much for this. I know they won't 'clean it', but still. Anyway, I am really glad it appears to have fixed my issue!

Actually, for me, my biggest struggle was the first part - pulling the airbag/horn unit off. I was afraid I was 'pushing too hard', and going to break something. In addition, I didn't fully understand how the 'Spring Mechanism' worked. Once I got it off, after several minutes, I understand better how it worked, and you do have to press hard to get all 4 'clamps' free.

I'm a firm believer in having more people working on the DIY, and contributing to it, in order to make it as good as it can be, so I'm attaching a couple extra photos, which might prove helpful for others. Thanks again guys - great find!
Attached Thumbnails
Click image for larger version

Name:	Airbag Rear Side.jpg
Views:	1777
Size:	216.4 KB
ID:	240089  

Click image for larger version

Name:	Springs holding Airbag.jpg
Views:	3782
Size:	291.7 KB
ID:	240097  

Click image for larger version

Name:	Gunk on Unit.jpg
Views:	6821
Size:	344.7 KB
ID:	240105  



Performance Mods
Eurocharged ECU Tune, Charcoal Filter Delete, RPI Ram Air Kit/Block Off Plates, RPI Oil Cooler, M Sprint Booster V2

Cosmetic Mods
H&R Lowering Springs, 20" ConceptOne Wheels, Blacked out Kidneys/Side Vents, 6W Angel Eyes
messex is offline  
The Following User Says Thank You to messex For This Useful Post:
phizzak (19th April 2014)
Sponsored Links
Advertisement
 
post #32 of 139 Old 9th June 2013, 11:37 AM
Bwoyr@aol.com
Junior Member, warming up (<31 posts)
 
Join Date: Jun 2013
Location: New York
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
I did this repair yesterday, after my car was showing drive assist malfunction and start off assist not active, it is working very good, thank you .
Bwoyr@aol.com is offline  
post #33 of 139 Old 11th June 2013, 02:13 AM
z4coupe
Member, Sport: Off DSC: On (>50 posts)
 
z4coupe's Avatar
 
Join Date: Apr 2012
Location: ATL, GA
Posts: 83
Thanks: 7
Thanked 4 Times in 4 Posts
Anyone have the step by step pictures that can be added with the steps and then saved to this DIY? I think this is on my 'to do' list this weekend and the pics would be awesome to have with the already great directions.

Exhaust:
Section 2....Tubi-Style X-pipe
Section 3....Tubi-Style

Lighting:
LED angel eyes
LED turn signals
LED license lamps

Coding:
Euro hazards
Mirrors fold up on lock
Windows up on lock
Extended pathway lighting
Brake force display
No foot on brake start
'I accept' warning deleted
Seat belt 'bing' deleted
True speed in BC
AE & side marker bulb check delete - no more strobing


Rest is stock!
z4coupe is offline  
 
post #34 of 139 Old 11th June 2013, 02:42 AM
Bwoyr@aol.com
Junior Member, warming up (<31 posts)
 
Join Date: Jun 2013
Location: New York
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Bwoyr@aol.com is offline  
post #35 of 139 Old 11th June 2013, 04:08 AM
messex
Member, P500 Sport, DSC off (>900)
 
messex's Avatar
 
Join Date: Jan 2011
Location: Greer, SC
Posts: 990
Thanks: 136
Thanked 63 Times in 54 Posts
Quote:
Originally Posted by z4coupe View Post
Anyone have the step by step pictures that can be added with the steps and then saved to this DIY? I think this is on my 'to do' list this weekend and the pics would be awesome to have with the already great directions.
Posts 9 and 31 have steps and pictures...

Sent from my SCH-I905 using Tapatalk 2


Performance Mods
Eurocharged ECU Tune, Charcoal Filter Delete, RPI Ram Air Kit/Block Off Plates, RPI Oil Cooler, M Sprint Booster V2

Cosmetic Mods
H&R Lowering Springs, 20" ConceptOne Wheels, Blacked out Kidneys/Side Vents, 6W Angel Eyes
messex is offline  
post #36 of 139 Old 13th June 2013, 04:21 AM
ShowMeM5
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Jan 2006
Location: St. Louis
Posts: 98
Thanks: 2
Thanked 3 Times in 3 Posts
bummed

Super easy to follow....but the codes came right back. Wondering if I should rock it out one more time just more thorough cleaning effort? Used a spray electronic cleaner. Great instructions...thanks!
ShowMeM5 is offline  
post #37 of 139 Old 13th June 2013, 12:13 PM
messex
Member, P500 Sport, DSC off (>900)
 
messex's Avatar
 
Join Date: Jan 2011
Location: Greer, SC
Posts: 990
Thanks: 136
Thanked 63 Times in 54 Posts
Everybody I've read said this fixed it up for them. Been weeks and my errors haven't come back. I really cleaned it good. Also, you did follow instructions with the 'arrow', and lining it back up, right? Did you notice the 'grime' that I showed in one of my pictures? Truthfully, if you are getting the exact symptoms (Error codes popping up as soon as you turn the steering wheel the first time you start the car), then I'm 99% sure this is it. I would probably try it again, since it is a fairly easy thing to do (especially the second time). I guess, of course, it could be the part. I don't know what else you have to do to replace the part (maybe 'sync' it up somehow). Good luck, and let us know!


Performance Mods
Eurocharged ECU Tune, Charcoal Filter Delete, RPI Ram Air Kit/Block Off Plates, RPI Oil Cooler, M Sprint Booster V2

Cosmetic Mods
H&R Lowering Springs, 20" ConceptOne Wheels, Blacked out Kidneys/Side Vents, 6W Angel Eyes
messex is offline  
The Following User Says Thank You to messex For This Useful Post:
ShowMeM5 (14th June 2013)
post #38 of 139 Old 13th June 2013, 03:08 PM
ShowMeM5
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Jan 2006
Location: St. Louis
Posts: 98
Thanks: 2
Thanked 3 Times in 3 Posts
bummed

Roger that. I will attempt again tonight. Stand by for results. Last time it took me 1:40. This time I will also remember not to close the trunk with the battery disconnected.
ShowMeM5 is offline  
post #39 of 139 Old 14th June 2013, 03:32 AM
z4coupe
Member, Sport: Off DSC: On (>50 posts)
 
z4coupe's Avatar
 
Join Date: Apr 2012
Location: ATL, GA
Posts: 83
Thanks: 7
Thanked 4 Times in 4 Posts
Too funny. Those pictures were showing as broken links last week for me but now they work! Guess I will be doing this DIY now for sure this weekend! Thanks to all that responded and being kind.

Exhaust:
Section 2....Tubi-Style X-pipe
Section 3....Tubi-Style

Lighting:
LED angel eyes
LED turn signals
LED license lamps

Coding:
Euro hazards
Mirrors fold up on lock
Windows up on lock
Extended pathway lighting
Brake force display
No foot on brake start
'I accept' warning deleted
Seat belt 'bing' deleted
True speed in BC
AE & side marker bulb check delete - no more strobing


Rest is stock!
z4coupe is offline  
post #40 of 139 Old 14th June 2013, 04:11 AM
ShowMeM5
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Jan 2006
Location: St. Louis
Posts: 98
Thanks: 2
Thanked 3 Times in 3 Posts
Dude!

Best day ever! Did it again, step by step. No gunk on the disc(because I cleaned it last time), but there was a ton of gunk on the housing that connects to it. Q-tipped all of it out of there.....5 used during the process. Put everything back, connected battery, fired it up. Lights everywhere! Turned left, right.....still lit up. Turned engine off....sat for a minute ....fired it back up. Lights still on, backed out of garage turned on P500, and then off again and blammo! No more lights!!! Drove around the block(driving lamp/bulb decided to go out on me)and all is good. Rock on!
ShowMeM5 is offline  
The Following User Says Thank You to ShowMeM5 For This Useful Post:
z4coupe (27th August 2013)
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 5 (0 members and 5 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 M5 Steering Angle Sensor Fix and...... KCB4 E60 M5 and E61 M5 Touring Discussion 12 12th September 2014 06:35 PM
Is this Steering Angle Sensor? Barry E60 M5 and E61 M5 Touring Discussion 23 13th October 2010 12:17 PM
DIY Steering angle sensor Viper966 E60 M5 and E61 M5 Touring Discussion 3 25th August 2010 05:07 PM
Steering Angle Sensor Fix for 2007? andrewsherman E60 M5 and E61 M5 Touring Discussion 4 29th August 2006 04:20 AM
No more LC after Steering Angle sensor fix...? Zapper E60 M5 and E61 M5 Touring Discussion 5 16th August 2006 04:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome