DIY: Reprogram Euro SMG software to US cars! (Faster shifts + 4k Launch Control) for free! - Page 27 - BMW M5 Forum and M6 Forums

Go Back   BMW M5 Forum and M6 Forums > BMW M5, M5 Touring, M6 and Z8 Forums > E60 M5 and E61 M5 Touring Discussion

E60 M5 and E61 M5 Touring Discussion 2005- Advertiser's Forum

Like Tree96Likes

Reply
 
LinkBack Thread Tools Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 27th September 2011, 17:39   #261
LJ Martin
Member, P500 Sport, DSC off (>900)
 
LJ Martin's Avatar
 
Join Date: Sep 2009
Location: Marion, Iowa

Garage: 06 M5 black/black 94 740il black, 69 Corvette red, 03 G35 Black

Sales Feedback: (0)

Thanks: 184
Thanked 100 Times in 82 Posts
To the powers that be. Any chance of suspending the rules on pm's and such till this problem is sorted out, at least for the ones having problems and the ones trying to help. 335 what is the status of your car at the present time? Cartek, I think I will wait for a bit on getting together to flash my car till we see how this is going to play out all though it might be worth it to have you do mine and see if it is successful, because if you flash several cars with no problem then we know you are doing something right. Maybe the Professor can shed some light on why some flashes take and others fail. I just called my SA to get the cost on a new smg control unit and the cost to flash it. Will post the info as soon as I get it.
LJ Martin is offline   Reply With Quote Quick reply to this message
Old 27th September 2011, 17:56   #262
cryptyk
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Mar 2008
Location: San Diego, Ca

Garage: None Yet

Sales Feedback: (0)

Thanks: 0
Thanked 4 Times in 3 Posts
Quote:
Originally Posted by profesor_rypson View Post
Don't you have damaged files? Reimport proper data into kfp, try again.
I just reinstalled winKFP from scratch using the same files Cartek is using. Followed everything to the letter.
Hooked up power to the car, and I still get the same error:
Error 200:
Error on reading HW-Number from ECU or logistic file
Please Check: Connection of ECU, Diagnosis Line, ECU-Address, Logistic files.

Index 5: CABD Result Error (CABD Result Parameter)

I bet if I could just get past that, the thing would flash successfully, now that I have power and the correct files.
cryptyk is offline   Reply With Quote Quick reply to this message
Old 27th September 2011, 18:05   #263
cryptyk
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Mar 2008
Location: San Diego, Ca

Garage: None Yet

Sales Feedback: (0)

Thanks: 0
Thanked 4 Times in 3 Posts
Also, the BMW tools, diagnostics and everything are working, if that helps. I don't know what I'm looking at, though. For completeness, here are some screen shots from WinKFP:







The original security error - This is different than the one I get now.
cryptyk is offline   Reply With Quote Quick reply to this message
Old 27th September 2011, 18:05   #264
Miguex
Fellow Member (>400)
 
Join Date: Oct 2008
Location: Calgary, Canada

Garage: BMW X5M

Sales Feedback: (0)

Thanks: 76
Thanked 33 Times in 28 Posts
Quote:
Originally Posted by cryptyk View Post
I just reinstalled winKFP from scratch using the same files Cartek is using. Followed everything to the letter.
Hooked up power to the car, and I still get the same error:
Error 200:
Error on reading HW-Number from ECU or logistic file
Please Check: Connection of ECU, Diagnosis Line, ECU-Address, Logistic files.

Index 5: CABD Result Error (CABD Result Parameter)

I bet if I could just get past that, the thing would flash successfully, now that I have power and the correct files.
1) Does your car run after the program?
2) did you try to use INPA to see all is working (black spots on, some diagnosis, datalogging without any error?
__________________
2010 BMW X5M: Stock + Custom ECU remap by ECUPROGRAM.ca
---------------------------------------------------------------------------------------------------------------------------------------
BMW Coding? Calgary, & Edmonton & Red Deer & Lethbridge area only. For Vancouver and Regina area, on request only.
---------------------------------------------------------------------------------------------------------------------------------------
" I am more terrified of a suburban mom on her cell phone with 3 kids in the back of the SUV, than an enthusiast who had undertaken specialized training, driving their pride and joy."
Miguex is offline   Reply With Quote Quick reply to this message
Old 27th September 2011, 18:08   #265
Miguex
Fellow Member (>400)
 
Join Date: Oct 2008
Location: Calgary, Canada

Garage: BMW X5M

Sales Feedback: (0)

Thanks: 76
Thanked 33 Times in 28 Posts
Cryptyk, Is your car a 2008 model?
Miguex is offline   Reply With Quote Quick reply to this message
Old 27th September 2011, 18:10   #266
cryptyk
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Mar 2008
Location: San Diego, Ca

Garage: None Yet

Sales Feedback: (0)

Thanks: 0
Thanked 4 Times in 3 Posts
Quote:
Originally Posted by Miguex View Post
1) Does your car run after the program?
2) did you try to use INPA to see all is working (black spots on, some diagnosis, datalogging without any error?
The ignition comes on, but there's a transmission fault. INPA works, WinKFP works (up until I try to flash). Yes, it's a 2008.

I called All German Auto in San Diego. They're very highly regarded. They said that they can't help - I need to get it to a dealer for a full reflash. If that doesn't take, they may need to replace the computer.

Just gets worse and worse
cryptyk is offline   Reply With Quote Quick reply to this message
Old 27th September 2011, 18:17   #267
Miguex
Fellow Member (>400)
 
Join Date: Oct 2008
Location: Calgary, Canada

Garage: BMW X5M

Sales Feedback: (0)

Thanks: 76
Thanked 33 Times in 28 Posts
So I see that:

Cartek, vodyk and me have 2006-2007 models and the program works.

335 and cryptyk have 2008 model, it does not work....

it seems that program does not apply for 2008+ or lci models.... it might need new/different flash for lci model.....

Can you post the UIT history of the SMG?
Miguex is offline   Reply With Quote Quick reply to this message
Old 27th September 2011, 18:19   #268
Miguex
Fellow Member (>400)
 
Join Date: Oct 2008
Location: Calgary, Canada

Garage: BMW X5M

Sales Feedback: (0)

Thanks: 76
Thanked 33 Times in 28 Posts
Quote:
Originally Posted by cryptyk View Post
The ignition comes on, but there's a transmission fault.(
Can you drive the car? or it stay in N position?
Miguex is offline   Reply With Quote Quick reply to this message
Old 27th September 2011, 18:50   #269
Rnydyman
Member, Sport: On DSC: On (>100 posts)
 
Rnydyman's Avatar
 
Join Date: Feb 2010
Location: Southeastern Pennsylvania

Garage: '06 Sapphire Black Metallic M5

Sales Feedback: (0)

Thanks: 2
Thanked 12 Times in 12 Posts
Vodyk has an 08. We flashed my '06 successfully
__________________
RPI Scoops, CF delete, Euro SMG Software (Ver. 3)
Rnydyman is offline   Reply With Quote Quick reply to this message
Old 27th September 2011, 19:03   #270
Miguex
Fellow Member (>400)
 
Join Date: Oct 2008
Location: Calgary, Canada

Garage: BMW X5M

Sales Feedback: (0)

Thanks: 76
Thanked 33 Times in 28 Posts
Quote:
Originally Posted by Rnydyman View Post
Vodyk has an 08. We flashed my '06 successfully
Oh I see.... so it is something on the files then....

Mine (06) is successfully.

Maybe we who did it successfully should compress and share the files that worked.
Miguex is offline   Reply With Quote Quick reply to this message
Reply

Bookmarks


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EURO Launch CONTROL FOR M6 IN US! MIAMI-M6 E63 BMW M6 Forum and BMW M6 Convertible | m6board.com 5 6th July 2014 14:53
Anybody try Euro Launch Control in the U.S. yet? 6speed E60 M5 and E61 M5 Touring Discussion 8 24th June 2013 19:57
Euro Spec Launch Control for US Vehicles!?!?! gt40mki E60 M5 and E61 M5 Touring Discussion 11 27th September 2010 21:18
Euro Launch Control - no limitiations on times used? Habib_2 E60 M5 and E61 M5 Touring Discussion 6 16th April 2007 17:34
Launch Control Software?? dkim996tt E60 M5 and E61 M5 Touring Discussion 8 16th May 2006 21:28

Loading...

All times are GMT +2. The time now is 16:25.



Everything Copyright 2000-2008. Do not use ANYTHING from this site without written permission. All images, graphics, sound files, video files and text appearing on this web site are the exclusive property of m5board.com and are protected under international copyright laws. All images, graphics, sound files, video files and text on this site are for on-screen and on-site viewing and listening only. No part of this web site may be reproduced, copied, saved, stored, manipulated, or used in any form for personal or commercial purposes without the prior written permission of m5board.com. Use of any image or graphic as the basis for another photographic concept or illustration is a violation of the copyright. Any copyright infringement will be prosecuted to the full extent of federal and international copyright laws. M5board.com is an enthusiast board and we don't condone any dangerous activity. Our airfield events are completely safe based on years of experience, we conduct them during clear visibility with mature participants that have several years of experience with high-performance automobiles, large unobstructed run-off zones on sealed off private former military airbases and we clearly mark the braking zones. If inexperienced with high speed driving we do not recommend organizing your own event but attending a high-performance driving school. The use of the term "BMW" on this site is for reference only, and does not imply any connection between m5board.com and BMW AG or BMW North America.