DSC Light Permenantly ON. ABS Fine. - BMW M5 Forum and M6 Forums

Go Back   BMW M5 Forum and M6 Forums > BMW M5, M5 Touring, M6 and Z8 Forums > E39 M5 and E52 Z8 Discussion

E39 M5 and E52 Z8 Discussion 1998-2003 Advertiser's Forum


Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 8th September 2011, 15:00   #1
100%Cocoa
m5board.comoholic (>1000 posts)
 
100%Cocoa's Avatar
 
Join Date: Feb 2005
Location: Battersea, London
Age: 42

Garage: E39 M5 Carbon Black/Caramel

Sales Feedback: (0)

Thanks: 894
Thanked 424 Times in 203 Posts
DSC Light Permenantly ON. ABS Fine.

Hi guys,

When I started the car this morning the DSC light did not go of as it normally does. Pressing the DSC button does nothing. There are NO other warning lights.

I tried afew things on the way to work and the DSC is definitely off, as my sideways exit from the Tesco's roundabout proved .

The ABS however appeas to be fine, as I actually didn't crash into the back of the Saab 93 that was trying to beat me to work, and then messed up his M4/A4 exit strategy just by West London Audi.

I'll plug ABO into INPA when I get home later and get some codes off her, but I wondered if anyone had any previous experience or just thoughts on the matter? I did some searching and it seems that a dodgy DSC unit causes the ABS light to come on as well, so I'm hoping it's not that.

I'll post again when I've got the INPA results but feel free to chip in if you have an idea how much pain my wallet is about to go through!

Barney.
100%Cocoa is online now   Reply With Quote
Old 8th September 2011, 15:21   #2
cab
m5board.comoholic (>1000 posts)
 
cab's Avatar
 
Join Date: Sep 2008
Location: Grapevine, TX

Garage: 2002 LMB/Caramel (sold)

Sales Feedback: (0)

Thanks: 26
Thanked 168 Times in 114 Posts
It could be one of the wheel sensors - you can check that with INPA (it will show you all 4 sensors and the codes). However, on the wife's 530i (identical symptoms) it was the ABS module which I had rebuilt for $185 USD + shipping (took a week). Several places on E-bay, etc. Tons of threads on the BMW ABS module on Bimmerforums.com I used BBA Remanufacturing (recommended on the other board) who actually may have a UK location.
cab is offline   Reply With Quote
Old 8th September 2011, 15:25   #3
yellowgixxer
m5board.comoholic (>1000 posts)
 
yellowgixxer's Avatar
 
Join Date: Mar 2006
Location: Kent/Surrey border

Garage: E39 M5 in Le Mans Blue

Sales Feedback: (0)

Thanks: 408
Thanked 268 Times in 188 Posts
Hi Barney,

I think that if a wheel sensor goes u/s then it takes the ABS out as well. Certainly did on mine. Do you have anything else weird happening? Mileometer not going up, for example? Because perhaps you're just good at modulating your brakes and the ABS actually isn't working at all?

I'm going to hope for that because it's the cheapest option. Other than a blown fuse, of course. Is there a DSC fuse?

SB
yellowgixxer is offline   Reply With Quote
Old 8th September 2011, 15:46   #4
Strike
m5board.comoholic (>1000 posts)
 
Strike's Avatar
 
Join Date: Sep 2008
Location: Philadelphia

Garage: 2002 Jet Black

Sales Feedback: (1)

Thanks: 201
Thanked 205 Times in 170 Posts
Check the brake light microswitch on the brake pedal. Sometimes it comes loose and can cause that. Happened to mine. Don't know how it happened but checked it, snapped it into place, all was well again.
__________________
2002 Jet Black/Imola Red Sport
Dinan Stage I Software
K&N Filters - Brake Ducts
K40 Undetectable
AXXIS ULT pads
Black/White CF Roundels
Body Color Grills
Greyscale ///M Logos
Smoked Tails
30% Tint
Intravee II
Strike is online now   Reply With Quote
Old 8th September 2011, 16:14   #5
Sailor24
M5 Expert (>4000)
 
Sailor24's Avatar
 
Join Date: Oct 2010
Location: Corner Brook, NFLD, Can
Age: 52

Garage: 2000 Anthracite,

Sales Feedback: (0)

Thanks: 771
Thanked 1,125 Times in 893 Posts
Different DSC unit on this car ,but it is all I have. My sisters 3 wagon had DSC only light and it was a steering angle sensor. I forget exactly what the reset procedure was but I think it was as simple as lock to lock steering wheel rotation. The other thing people were giving me as a possibility was the G force sensor. Never got that far because the steering had the code. Don't think you will have a problem figuring it out once you plug it in.
Sailor24 is online now   Reply With Quote
Old 8th September 2011, 17:11   #6
Lunker325
m5board.comoholic (>1000 posts)
 
Lunker325's Avatar
 
Join Date: Jan 2009
Location: Columbus Ohio

Garage: 2011 E90 M3

Sales Feedback: (7)

Thanks: 251
Thanked 297 Times in 226 Posts
Also check your brake fluid level. Happened to me a while ago, topped off the brake fluid, been fine ever since.
__________________
2002 Sterling Grey/ Silverstone - sold
2011 E90 M3 Jerez/Fox Red - current bucket
Lunker325 is offline   Reply With Quote
Old 8th September 2011, 18:42   #7
100%Cocoa
m5board.comoholic (>1000 posts)
 
100%Cocoa's Avatar
 
Join Date: Feb 2005
Location: Battersea, London
Age: 42

Garage: E39 M5 Carbon Black/Caramel

Sales Feedback: (0)

Thanks: 894
Thanked 424 Times in 203 Posts
Thanks fro the replies guys. I'll be off home in a mo so we'll see what INPA shows up. Fingers crossed it's a nice simple one! I'll try the ABS again too just to be sure too.
100%Cocoa is online now   Reply With Quote
Old 8th September 2011, 18:44   #8
lothar
Senior Member (>500)
 
Join Date: Oct 2009
Location: Sacramento, CA
Age: 39

Garage: 2003 Ti. Silver M5

Sales Feedback: (0)

Thanks: 52
Thanked 94 Times in 76 Posts
I had a similar issue, but the light would intermittently come on (car usually started without it lit up). I had a number of steering angle sensor faults. Cleared the errors, recalibrated the sensor and it hasn't been back since.
lothar is offline   Reply With Quote
Old 8th September 2011, 19:12   #9
ACHTUNGM5
Member, P500, DSC On (>600)
 
ACHTUNGM5's Avatar
 
Join Date: Jul 2009
Location: USA

Garage: 2001 M5 TITANIUM SILVER

Sales Feedback: (0)

Thanks: 39
Thanked 29 Times in 21 Posts
brake fluid
ACHTUNGM5 is online now   Reply With Quote
Old 8th September 2011, 20:53   #10
100%Cocoa
m5board.comoholic (>1000 posts)
 
100%Cocoa's Avatar
 
Join Date: Feb 2005
Location: Battersea, London
Age: 42

Garage: E39 M5 Carbon Black/Caramel

Sales Feedback: (0)

Thanks: 894
Thanked 424 Times in 203 Posts
So...... I've spent a while browsing my modules and I think we have an answer. I'll just attach the pics and let you see for yourself.....

A few points first:

1) The car was completely normal on the way home. No lights and all functions seemed ok. Don't you just love intermittent faults

2) The fault seems obvious when you see the error code screen grabs......

3) When I read the analogue readings, the DSC light, Brake Pad Light & ABS light all came on and the DSC button did nothing. They went off after a while though and everything's fine again. Has anyone else got experience of this?

4) I included a bunch of other pics as I thought those without INPA would be curious to see just a tiny snippet of the wealth of information it can give you!

Now the pics -


.
Attached Thumbnails
DSC Light Permenantly ON. ABS Fine.-steerng-angle-sensor-error.jpg  

DSC Light Permenantly ON. ABS Fine.-90-degree-angle.jpg  

DSC Light Permenantly ON. ABS Fine.-analogue-dsc-screen.jpg  

DSC Light Permenantly ON. ABS Fine.-wheel-speed.jpg  

DSC Light Permenantly ON. ABS Fine.-steering-angle-can.jpg  

DSC Light Permenantly ON. ABS Fine.-angle-can-2.jpg  

100%Cocoa is online now   Reply With Quote
Reply

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No hot air from blower, cold air works fine, fan works fine. amessimon E39 M5 and E52 Z8 Discussion 14 19th October 2011 20:31
SES Light (But Runs Fine) captain_anonymous_2003 E39 M5 and E52 Z8 Discussion 26 15th December 2009 22:38
fine FINE! I'll post pics of my M5! w00t!! *formal introduction* btmlinedan E39 M5 and E52 Z8 Discussion 26 28th August 2009 17:22
***One Fine Day*** M-Crazy Owners Gallery 4 31st October 2007 02:20
SES light but car runs fine?? jordantii E39 M5 and E52 Z8 Discussion 7 2nd August 2005 22:24

Loading...

All times are GMT +2. The time now is 20:21.



Everything Copyright 2000-2008. Do not use ANYTHING from this site without written permission. All images, graphics, sound files, video files and text appearing on this web site are the exclusive property of m5board.com and are protected under international copyright laws. All images, graphics, sound files, video files and text on this site are for on-screen and on-site viewing and listening only. No part of this web site may be reproduced, copied, saved, stored, manipulated, or used in any form for personal or commercial purposes without the prior written permission of m5board.com. Use of any image or graphic as the basis for another photographic concept or illustration is a violation of the copyright. Any copyright infringement will be prosecuted to the full extent of federal and international copyright laws. M5board.com is an enthusiast board and we don't condone any dangerous activity. Our airfield events are completely safe based on years of experience, we conduct them during clear visibility with mature participants that have several years of experience with high-performance automobiles, large unobstructed run-off zones on sealed off private former military airbases and we clearly mark the braking zones. If inexperienced with high speed driving we do not recommend organizing your own event but attending a high-performance driving school. The use of the term "BMW" on this site is for reference only, and does not imply any connection between m5board.com and BMW AG or BMW North America.